Bug 16

Summary: Implement switching between integrated and discrete graphics cards
Product: AMD Catalyst™Proprietary Display Driver Reporter: Sharabdin <muse1988>
Component: X11 DriverAssignee: nobody
Status: CLOSED WONTFIX    
Severity: enhancement CC: alexad2011, avelo, Compxpert, minnigaliev-r, muse1988, sauthess
Priority: low    
Version: .archived   
Hardware: Radeon HD 5000 Series   
OS: Linux   

Description Sharabdin 2011-01-13 12:27:53 CST
Hello, you write in a notebook users who installed two video cards, one for saving the other for performance, the problem is that on linux with your driver AMD Catalyst 10.12 there is no switch between the video card and Windows 7 everything is fine because there is a function of ATI PowerXpress, I ask you to implement this on linux. sorry for my bad english, respect your customers.
 

Steps to reproduce:
1. Solving the problem with switching of discrete graphics cards
Comment 1 Sharabdin 2011-01-13 12:30:40 CST
save
Comment 2 Sharabdin 2011-01-13 12:33:50 CST
Hello, you write in a notebook users who installed two video cards, one for
saving power the other for performance, the problem is that on linux with your driver
AMD Catalyst 10.12 there is no switch between the video card and Windows 7
everything is fine because there is a function of ATI PowerXpress, I ask you to
implement this on linux. sorry for my bad english, respect your customers.


Steps to reproduce:
1. Solving the problem with switching of discrete graphics cards
Comment 3 ⚡ Thunde® ⚡ 2011-01-14 06:21:44 CST
VOTE FOR
Comment 4 Anton 2011-01-18 07:12:42 CST
Importance should be set to Major as there is a major loss of function. In this case, really no function at all...
Comment 5 AlexAD 2011-01-24 09:16:35 CST
Should increase to importance of Major as it is having a large impact on many uses see...

http://linux-hybrid-graphics.blogspot.com/2010/07/using-acpicall-module-to-switch-onoff.html
http://asusm51ta-with-linux.blogspot.com/
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/312756

Bug 312756 with over 400 comments and over 300 people uploading there system information to help open source developers find a way round this failure.
Comment 6 BryanG 2011-01-31 07:55:47 CST
I just recently got a new notebook with an ATI 5650 and was completely unaware these new Core i5s have a built-in iGPU. Now I'm stuck with the opensource driver because my notebook manufacturer chooses to not allow you to change bios options including the choice to boot with out the iGPU. So since my notebook manufacturer won't support turning it off on bios surely someone else might right? Wrong. Although Vga_Switcheroo does successfully allow me to switch between them the AMD driver does not support this (yet?). It seems it doesn't know where to look for the proper vbios and is picking up the one from the integrated gpu obviously the wrong code so it doesn't load. It would be nice if the AMD driver could either support some method of turning off the iGPU or at least support switching through vga_switcheroo.
Comment 7 sauthess 2011-03-21 08:58:07 CDT
Good afternoon,

The same here...

Mobility Radeon HD 5470 with core i5 (so integrated graphic card...).

Impossible to install graphic drivers (I can't disable integrated chipset in my bios so no solution at all to use ma hardware...).

Thanks for you help !

I'm open to test driver on my laptop if it can help solve issue..

Best Regards,
Comment 8 sauthess 2011-03-21 12:31:43 CDT
Precision : I just seen that the bug is open for 10.12.

I've also tried last version 11.2 ...

The problem is the same : 
The driver ask me to disable the integrated card but I can't do it (nor in bios or using acpi calls). 

I'm in the same situation than the person that posted just before me (and I think we are a lot in this case !)

Thanks in advance for your help ! 

Best Regards.
Comment 9 Anton 2011-03-21 14:09:30 CDT
Same here

No way to use Ati in a Intel/Ati hybrid even with 11.2
I really don't understand why AMD doesn't give relevance to this.

Many of us have bought a computer with ATI graphics, that cannot use the ATI card. The only stable solution right now is stay with Intel card and try to disable ATI with acpi_call, because if you don't do that, ATI not-working card will drain your battery very fast...
Seem that they don't want linux people with ATI's... unbelievable!
Comment 10 Michael Cronenworth 2011-04-01 23:19:54 CDT
This message is a reminder that your bug is marked as Catalyst 10.12.

The current Catalyst version is 11.3.

Approximately 7 days from now the Bugzilla administrator will be removing the 10.12 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla administrator provides this as a unofficial, free service to AMD customers, and I like to keep my systems neat and tidy. If you would like to keep your bug from being closed, please try a new Catalyst version and update the 'version' field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will change it for you.
Comment 11 sauthess 2011-04-03 11:58:41 CDT
Good afternoon,

You're right, I've just tested the 11.3 version and it's a lot better (3D works for me and switch is present but not fully operational for me).

I have few problems but I want to do more tests before reporting anything.

I'm not the opener of this case but I agree with you (unusefull at all as new version is present)

Best Regards,
Comment 12 Michael Cronenworth 2011-04-08 18:51:21 CDT
This bug is being closed due to the 'version' being 10.2 after 7 days of the previous closure notice.

Thank you for your bug report.