Bug 177 - xrandr and HDMI problems in 11.6
: xrandr and HDMI problems in 11.6
Status: CLOSED WONTFIX
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: Kernel Module
: .archived
: All Linux
: low normal
Assigned To: nobody
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-22 16:36 CDT by chris
Modified: 2011-12-24 11:53 CST (History)
1 user (show)



Attachments
atisysteminfo-report (327.60 KB, text/plain)
2011-06-22 16:37 CDT, chris
Details

Note You need to log in before you can comment on or make changes to this bug.
Description chris 2011-06-22 16:36:37 CDT
Description of problem: 

Recognition of HDMI displays seems to be half-broken:

Steps to reproduce:
1. Connect a screen with HDMI
2. try to activate it 

Actual result:
Nothing happens.
xrandr doesn't recognize it ("DFP1 disconnected"). With 11.5 I remember it activating immediately.
When connecting and when disconnecting this line gets written to the logs:

[fglrx:fireglAsyncioIntEnableMsgHandler] *ERROR* IRQMGR returned error 1 when trying to enable interrupt source 20100000

Expected result:
The HDMI connected screen being accessible through xrandr.

Connecting a screen with VGA still works well as in 11.5.

I have found some oddities when trying to activate the screen. This is a screen that has HDMI input (actually it is DVI, I use an adapter that worked fine with 11.5 and intel graphics so it shouldn't be the problem) and VGA input.

I connect the screen to the VGA input and activate it with
xrandr --output CRT1 --mode 1600x1200 --right-of LVDS
Then I disconnect the screen from VGA without disabling it first and connect it to HDMI.
Upon running xrandr with no arguments then xrandr segfaults (?)

~ % xrandr
Screen 0: minimum 320 x 200, current 3200 x 1200, maximum 4000 x 4000
LVDS connected 1600x900+0+0 (normal left inverted right x axis y axis) 382mm x 214mm
   1600x900       60.3*+
   1440x900       60.3  
   1280x768       60.3  
   1280x720       60.3  
   1024x768       60.3  
   1024x600       60.3  
   800x600        60.3  
   800x480        60.3  
   640x480        60.3  
DFP1 connected 1600x1200+0+0 (normal left inverted right x axis y axis) 408mm x 306mm
[1]    8251 segmentation fault (core dumped)  xrandr

After that the HDMI screen immediately activates and works flawlessly.

I discovered that I don't even need to activate the screen with VGA.
So I do this:
I connect the screen with VGA but don't activate it. I confirm with xrandr that indeed DDC data is read.
I then disconnect it and connect it to HDMI. The error line gets written to the log and nothing happens.
In this case running xrandr won't segfault but display this error message:

~ % xrandr
xrandr: server did not report mode 0xb3 for output DFP1

After this the HDMI screen also works flawlessly.
Comment 1 chris 2011-06-22 16:37:24 CDT
Created attachment 157 [details]
atisysteminfo-report
Comment 2 s3Pol 2011-09-26 08:54:55 CDT
Hello,

I have the same problem in my laptop.
anyone have news about this issue?
Comment 3 Michael Cronenworth 2011-12-17 10:29:38 CST
This message is a reminder that your bug is marked as Catalyst 11.6.

The current Catalyst version is 11.12.

Approximately 7 days from now the Bugzilla administrator will be removing the
11.6 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla
administrator provides this as a unofficial, free service to AMD customers, and
I like to keep my systems neat and tidy. If you would like to keep your bug
from being closed, please try a new Catalyst version and update the 'version'
field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will
change it for you.
Comment 4 Michael Cronenworth 2011-12-24 11:52:14 CST
This bug is being closed due to the 'version' being 11.6 after 7 days of the
previous closure notice.

Thank you for your bug report.