Bug 230 - [fglrx] ASIC hang happened
Summary: [fglrx] ASIC hang happened
Status: CLOSED WONTFIX
Alias: None
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: OpenGL Driver (show other bugs)
Version: .archived
Hardware: Radeon HD 5000 Series Linux
: low normal
Assignee: nobody
URL:
Depends on:
Blocks:
 
Reported: 2011-08-17 11:20 CDT by Alistair Buxton
Modified: 2012-07-17 09:11 CDT (History)
16 users (show)



Attachments
xorg log (54.24 KB, text/x-log)
2011-08-17 11:20 CDT, Alistair Buxton
Details
ASIC hang happened (5.28 KB, text/plain)
2011-09-03 16:41 CDT, Jeremy
Details
ATI system info (414.63 KB, text/plain)
2011-09-05 00:39 CDT, Jon Stanley
Details
First Xorg stack trace (3.74 KB, text/plain)
2011-09-16 17:48 CDT, Lance Johnson
Details
Second Xorg stack trace, after ASIC hang detection in fglrx (9.91 KB, text/plain)
2011-09-16 17:50 CDT, Lance Johnson
Details
3rd attachment; systeminfo (503.23 KB, text/plain)
2011-09-16 17:55 CDT, Lance Johnson
Details
dmidecode dump and messages.log segment (28.74 KB, text/plain)
2011-12-10 10:30 CST, Justin
Details
X11 configuration (1.81 KB, application/octet-stream)
2012-05-28 18:30 CDT, Don Hughes
Details
Xorg.log for the ASIC hang reported above (38.04 KB, text/plain)
2012-06-02 05:53 CDT, hd6570
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alistair Buxton 2011-08-17 11:20:05 CDT
Created attachment 194 [details]
xorg log

Description of problem: 

Card locks up, processes using it become defunct, reboot required.

[526454.770023] [fglrx] ASIC hang happened
[526454.770028] Pid: 30698, comm: cgminer Tainted: P            2.6.38-10-generic #46-Ubuntu
[526454.770031] Call Trace:
[526454.770081]  [<ffffffffa0078d4e>] ? KCL_DEBUG_OsDump+0xe/0x10 [fglrx]
[526454.770103]  [<ffffffffa008614c>] ? firegl_hardwareHangRecovery+0x1c/0x50 [fglrx]
[526454.770140]  [<ffffffffa0107619>] ? _ZN4Asic9WaitUntil15ResetASICIfHungEv+0x9/0x10 [fglrx]
[526454.770175]  [<ffffffffa01075cc>] ? _ZN4Asic9WaitUntil15WaitForCompleteEv+0x6c/0xb0 [fglrx]
[526454.770210]  [<ffffffffa010517f>] ? _ZN4Asic19PM4ElapsedTimeStampEj14_LARGE_INTEGER12_QS_CP_RING_+0xaf/0x160 [fglrx]
[526454.770244]  [<ffffffffa00feb23>] ? _ZN15QS_PRIVATE_CORE27multiVpuPM4ElapsedTimeStampEj14_LARGE_INTEGER12_QS_CP_RING_+0x33/0x50 [fglrx]
[526454.770278]  [<ffffffffa00f8b44>] ? _Z19uQSTimeStampRetiredmjj14_LARGE_INTEGER+0x74/0x80 [fglrx]
[526454.770311]  [<ffffffffa00f4ab7>] ? _Z8uCWDDEQCmjjPvjS_+0x4f7/0x1100 [fglrx]
[526454.770315]  [<ffffffff8108d81e>] ? down+0x2e/0x50
[526454.770339]  [<ffffffffa00a3d74>] ? firegl_cmmqs_CWDDE_32+0x334/0x440 [fglrx]
[526454.770362]  [<ffffffffa00a27e0>] ? firegl_cmmqs_CWDDE32+0x70/0x100 [fglrx]
[526454.770385]  [<ffffffffa00a2770>] ? firegl_cmmqs_CWDDE32+0x0/0x100 [fglrx]
[526454.770405]  [<ffffffffa0081d9a>] ? firegl_ioctl+0x1ea/0x250 [fglrx]
[526454.770423]  [<ffffffffa0072d7e>] ? ip_firegl_unlocked_ioctl+0xe/0x20 [fglrx]
[526454.770426]  [<ffffffff811764cf>] ? do_vfs_ioctl+0x8f/0x360
[526454.770429]  [<ffffffff815c09fc>] ? schedule+0x3ec/0x760
[526454.770432]  [<ffffffff81176831>] ? sys_ioctl+0x91/0xa0
[526454.770434]  [<ffffffff8100c002>] ? system_call_fastpath+0x16/0x1b
[526454.770438] pubdev:0xffffffffa02af4a0, num of device:1 , name:fglrx, major 8, minor 84. 
[526454.770440] device 0 : 0xffff880064208000 .
[526454.770442] Asic ID:0x6898, revision:0x2, MMIOReg:0xffffc90010b00000.
[526454.770444] FB phys addr: 0xc0000000, MC :0xf00000000, Total FB size :0x40000000.
[526454.770446] gart table MC:0xf0fb07000, Physical:0xcfb07000, size:0x1f8000.
[526454.770449] mc_node :FB, total 1 zones
[526454.770450]     MC start:0xf00000000, Physical:0xc0000000, size:0xfd00000.
[526454.770452]     Mapped heap -- Offset:0x0, size:0xfb07000, reference count:22, mapping count:0,
[526454.770455]     Mapped heap -- Offset:0x0, size:0x1000000, reference count:1, mapping count:0,
[526454.770457]     Mapped heap -- Offset:0xfb07000, size:0x1f9000, reference count:1, mapping count:0,
[526454.770459] mc_node :INV_FB, total 1 zones
[526454.770460]     MC start:0xf0fd00000, Physical:0xcfd00000, size:0x30300000.
[526454.770462]     Mapped heap -- Offset:0x302f4000, size:0xc000, reference count:1, mapping count:0,
[526454.770464] mc_node :GART_USWC, total 2 zones
[526454.770465]     MC start:0x27950000, Physical:0x0, size:0x27400000.
[526454.770467]     Mapped heap -- Offset:0x30000, size:0x2000000, reference count:18, mapping count:0,
[526454.770469] mc_node :GART_CACHEABLE, total 3 zones
[526454.770471]     MC start:0x10400000, Physical:0x0, size:0x17550000.
[526454.770473]     Mapped heap -- Offset:0x3600000, size:0x200000, reference count:1, mapping count:0,
[526454.770475]     Mapped heap -- Offset:0x3400000, size:0x200000, reference count:2, mapping count:0,
[526454.770477]     Mapped heap -- Offset:0x2a00000, size:0xa00000, reference count:2, mapping count:0,
[526454.770479]     Mapped heap -- Offset:0x2000000, size:0xa00000, reference count:9, mapping count:0,
[526454.770481]     Mapped heap -- Offset:0x1600000, size:0xa00000, reference count:3, mapping count:0,
[526454.770483]     Mapped heap -- Offset:0xc00000, size:0xa00000, reference count:3, mapping count:0,
[526454.770486]     Mapped heap -- Offset:0x200000, size:0xa00000, reference count:3, mapping count:0,
[526454.770488]     Mapped heap -- Offset:0x0, size:0x200000, reference count:9, mapping count:0,
[526454.770490]     Mapped heap -- Offset:0xef000, size:0x11000, reference count:1, mapping count:0,
[526454.770493] GRBM : 0xb0633828, SRBM : 0x20004ec0 .
[526454.770496] CP_RB_BASE : 0x279800, CP_RB_RPTR : 0x3bbc0 , CP_RB_WPTR :0x3bbc0.
[526454.770499] CP_IB1_BUFSZ:0x0, CP_IB1_BASE_HI:0x0, CP_IB1_BASE_LO:0x27f5a000.
[526454.770501] last submit IB buffer -- MC :0x27f5a000,phys:0x5a375000.
[526454.770504] Dump the trace queue.
[526454.770505] End of dump


Steps to reproduce:
1. Buy an ATI card.
2. Start using it.
3. Wait.

Actual result: 
[fglrx] ASIC hang happened

Expected result: 
ASIC hang doesn't happen.

Also, I don't have any atigetsysteminfo.sh and even if I did, I doubt it would successfully run, since anything that touches the graphics card is currently crashing to the point where it cannot even be killed.
Comment 1 Jeremy 2011-09-03 16:41:54 CDT
Created attachment 217 [details]
ASIC hang happened
Comment 2 Jeremy 2011-09-03 16:53:51 CDT
I confirm this.  I have a Sapphire Radeon 6950 2GB.  Neither the mouse nor the keyboard has any effect; X stops responding completely.  I noticed that while the computer does not respond to the mouse or keyboard, I can SSH into it.  When I do this, I see that X is using 100% of one core, and kill -s 9 [any process] (as root) has no effect.  However, I can use the remote shell normally otherwise, and shutdown -r now reboots it cleanly.
Comment 3 Jon Stanley 2011-09-05 00:37:38 CDT
Since I could ssh in when this occurs, I was able to setup kdump and gather a vmcore from a system in this state (a sysrq-c forced crash). The offending process (Xorg, not surprisingly) looks like this:


crash> bt 2961
PID: 2961   TASK: ffff880205d2dcc0  CPU: 3   COMMAND: "Xorg"
 #0 [ffff88023f4c7e80] crash_nmi_callback at ffffffff8101f8dd
 #1 [ffff88023f4c7ea0] notifier_call_chain at ffffffff814ba3cb
 #2 [ffff88023f4c7ee0] atomic_notifier_call_chain at ffffffff814ba423
 #3 [ffff88023f4c7ef0] notify_die at ffffffff814ba453
 #4 [ffff88023f4c7f20] do_nmi at ffffffff814b7c74
 #5 [ffff88023f4c7f50] nmi at ffffffff814b7990
    [exception RIP: rb_next+32]
    RIP: ffffffff8123bad9  RSP: ffff880200e9fa98  RFLAGS: 00000046
    RAX: 0000000000000000  RBX: ffff88023079d400  RCX: 0000000001312ba3
    RDX: 0000000000000000  RSI: ffff88023079d400  RDI: ffff88023079d410
    RBP: ffff880200e9fa98   R8: 0000000000000000   R9: 0000000000000001
    R10: 000005700d1119ad  R11: ffff88023f4d26c0  R12: ffff88022ead4400
    R13: ffff88023079d410  R14: ffff88023f4d26c0  R15: ffff880205d2e088
    ORIG_RAX: ffffffffffffffff  CS: 0010  SS: 0018
--- <NMI exception stack> ---
 #6 [ffff880200e9fa98] rb_next at ffffffff8123bad9
 #7 [ffff880200e9faa0] set_next_entity at ffffffff81042ca1
 #8 [ffff880200e9fad0] pick_next_task_fair at ffffffff810466c7
 #9 [ffff880200e9fb20] pick_next_task at ffffffff81047394
#10 [ffff880200e9fb40] schedule at ffffffff814b55e2
#11 [ffff880200e9fbd0] KCL_GlobalKernelScheduler at ffffffffa010598e [fglrx]
#12 [ffff880200e9fbe0] firegl_hardwareHangRecovery at ffffffffa0116b56 [fglrx]
#13 [ffff880200e9fbf0] _ZN4Asic9WaitUntil15ResetASICIfHungEv at ffffffffa01a3699 [fglrx]
#14 [ffff880200e9fc00] _ZN4Asic9WaitUntil15WaitForCompleteEv at ffffffffa01a364c [fglrx]
#15 [ffff880200e9fc20] _ZN15ExecutableUnits10CPRingIdleE15idle_WaitMethod12_QS_CP_RING_ at ffffffffa019e8f4 [fglrx]
#16 [ffff880200e9fcb0] _ZN15ExecutableUnits7PM4idleE15idle_WaitMethod at ffffffffa019e7bb [fglrx]
#17 [ffff880200e9fcd0] _ZN15QS_PRIVATE_CORE9QsPM4idleE15idle_WaitMethod at ffffffffa0197231 [fglrx]
#18 [ffff880200e9fcf0] _ZN10QS_PRIVATE11synchronizeEv at ffffffffa01826ca [fglrx]
#19 [ffff880200e9fd00] _Z8uCWDDEQCmjjPvjS_ at ffffffffa018bd35 [fglrx]
#20 [ffff880200e9fd60] firegl_cmmqs_CWDDE_32 at ffffffffa0135272 [fglrx]
#21 [ffff880200e9fda0] firegl_cmmqs_CWDDE32 at ffffffffa0133ba0 [fglrx]
#22 [ffff880200e9fe10] firegl_ioctl at ffffffffa0112758 [fglrx]
#23 [ffff880200e9fe90] ip_firegl_unlocked_ioctl at ffffffffa01047a7 [fglrx]
#24 [ffff880200e9fea0] do_vfs_ioctl at ffffffff81134aea
#25 [ffff880200e9ff30] sys_ioctl at ffffffff81134b81
#26 [ffff880200e9ff80] system_call_fastpath at ffffffff814bd7c2
    RIP: 00000039302d8af7  RSP: 00007fff3f958f18  RFLAGS: 00003283
    RAX: 0000000000000010  RBX: ffffffff814bd7c2  RCX: 0000000000000890
    RDX: 00007fff3f9591b0  RSI: 00000000c03064a6  RDI: 000000000000000f
    RBP: 00007fff3f959230   R8: 0000000000000000   R9: 0000000000000000
    R10: 0000000000ffde80  R11: 0000000000003283  R12: 0000000001fdd21c
    R13: 00000000012764a0  R14: 0000000001883b08  R15: 0000000000ffd3e0
    ORIG_RAX: 0000000000000010  CS: 0033  SS: 002b

And as I suspected, trying to kill this process is just stacking signals on it's signal queue:

SIGPENDING: yes
   BLOCKED: 0000000000000000
PRIVATE_PENDING
    SIGNAL: 0000000000000100
  SIGQUEUE: (empty)
SHARED_PENDING
    SIGNAL: 0000000010006100
  SIGQUEUE:  SIG      SIGINFO     
              14  ffff8801b5daeab8
              29  ffff880116517478
              15  ffff88022e404bf8
               9  ffff88022e404b58

The complete vmcore (and matching vmlinux) is available if someone wants to look at it further.

This is on a Radeon HD 6850 with three 1920x1080 displays, one hooked up with an active adapter and two DVI.
Comment 4 Jon Stanley 2011-09-05 00:39:01 CDT
Created attachment 221 [details]
ATI system info
Comment 5 Lance Johnson 2011-09-16 17:48:20 CDT
Created attachment 234 [details]
First Xorg stack trace

I, too, have this problem.  Three monitors using CCC for 5760 x 1080 eyefinity.  Just got these cards installed yesterday.  I've had three hangs, now.

For me, the hangs are non-recoverable and necessitate a hard reset.  No reboot is possible; the box hangs waiting for perpetually hung processes to exit.  This is a profoundly bad bug, as it involves basic usability of the box.

This isn't a "My video tears a little bit when I move the player window around really fast" bug, this is a "I just installed these drivers for this hardware and they DONT WORK.  DO NOT BUY THIS HARDWARE!" type of bug.  Just so we're clear.

I shall attach further information in subsequent posts.  This attachment is the initial Xorg stack trace, closely followed by the second Xorg stack with the ASIC hang detected in fglrx.  The third attachment is atisysteminfo-report.txt

FWIW, I also received a bunch of pulseaudio messages that generally indicate some kind of bus problem immediately after the first crash, and they continue until reset:

Sep 16 14:19:26 localhost pulseaudio[4784]: ratelimit.c: 23 events suppressed
Sep 16 14:19:26 localhost pulseaudio[4784]: asyncq.c: q overrun, queuing locally
Sep 16 14:19:31 localhost pulseaudio[4784]: last message repeated 10 times
Sep 16 14:19:31 localhost pulseaudio[4784]: ratelimit.c: 23 events suppressed
Sep 16 14:19:31 localhost pulseaudio[4784]: asyncq.c: q overrun, queuing locally
Sep 16 14:19:37 localhost pulseaudio[4784]: last message repeated 10 times

&tc.  Worth noting that there was no audio playback happening prior or subsequent to the crash.
Comment 6 Lance Johnson 2011-09-16 17:50:33 CDT
Created attachment 235 [details]
Second Xorg stack trace, after ASIC hang detection in fglrx

This is with two MSI twin frozr II 6950 cards in crossfire
Comment 7 Lance Johnson 2011-09-16 17:55:29 CDT
Created attachment 236 [details]
3rd attachment; systeminfo

two 6950 MSI twin frozr II in crossfire driver linux, hang bug no recovery after crash
Comment 8 Bart 2011-10-21 04:07:10 CDT
I confirm this aswell. After upgrading to Ubuntu 11.10 ( Linux kernel 3.0.12) this occurs quite often ( 3 times in 2 hours). I have a Sapphire Radeon 6950 2GB.  Neither the mouse nor the keyboard has any effect; X stops responding completely. 
The only way to safely restart the Pc is alt+ SysReq + REISUB.
Comment 9 Michael Cronenworth 2011-11-01 08:01:48 CDT
This message is a reminder that your bug is marked as Catalyst 11.4.

The current Catalyst version is 11.10.

Approximately 7 days from now the Bugzilla administrator will be removing the
11.4 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla
administrator provides this as a unofficial, free service to AMD customers, and
I like to keep my systems neat and tidy. If you would like to keep your bug
from being closed, please try a new Catalyst version and update the 'version'
field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will
change it for you.
Comment 10 Michael Cronenworth 2011-11-07 22:14:32 CST
This bug is being closed due to the 'version' being 11.4 after 7 days of the
previous closure notice.

Thank you for your bug report.
Comment 11 tim99 2011-11-20 12:37:59 CST
(In reply to comment #10)
> This bug is being closed due to the 'version' being 11.4 after 7 days of the
> previous closure notice.
> 
> Thank you for your bug report.

Unfortunately the bug is still present in Catalyst 11.11 ; I have exactly the same symptoms as #10.

I suggest it should be marked as a major bug since a "hard reboot" is necessary and it happens every few hours...

Has anybody tried downgrading to a previous version as a temporary workaround ?
Comment 12 Jeremy 2011-11-20 13:47:29 CST
The same bug happened to me in 11.8.  I switched to the open-source driver, but am willing to switch back to the Catalyst driver if anyone wants me to to help investigate this problem, since the open-source drivers do not provide as high performance as the Catalyst ones, and they have their own (less major) bugs.
Comment 13 Justin 2011-12-10 10:28:46 CST
Apologies in advance for being angry and rude, but why the *hell* has this been marked WONTFIX? This *is* *a* *critical* bug! There are duplicates & related reports galore. Just after a few quick searches:

http://ati.cchtml.com/show_bug.cgi?id=89 
http://ati.cchtml.com/show_bug.cgi?id=153
http://ati.cchtml.com/show_bug.cgi?id=262

I have had similar, unpredictable ASIC hard lockups since purchasing my Radeon Mobility HD5870 based laptop one year ago. I switched to the xf86-video-ati drivers since around July (with great success) due to this problem completely screwing me up under pressure at work. Just switched back to 11.11 to find the problem has not and (if the report status is to be believed), /will not/ be fixed. :|

Attaching dmidecode dump as well as a similar messages.log section for reference. The only way to reproduce this is through high uptime on the newer cards. Please devs, read the comments. This isn't an isolated issue. If you guys can nail this issue it will be much appreciated!
Comment 14 Justin 2011-12-10 10:30:08 CST
Created attachment 302 [details]
dmidecode dump and messages.log segment
Comment 15 Jeremy 2011-12-11 08:57:18 CST
It's closed because this bug was filed for driver version 11.4, which is a few versions behind the current one.  Apparently, they want for us to keep filing the bug for each new version of the driver ;)
Comment 16 pierre.boudier@amd.com 2011-12-11 09:23:29 CST
Hi,

I would like to clarify:
- this website is not owned, controlled by amd
- the policy of the maintainer is to delete old bugs 
-  old bugs are often fixed in recent driver, so the policy is not out of merit
- amd does understand the value of this website, and we will  investigate/fix issues
- specific reports with easy to reproduce test case are much more likely to get fixed quickly

Regards,

Pierre
Comment 17 aaranya 2011-12-28 12:45:35 CST
I can confirm that this bug happens with 11.12 as well:


[ 7988.720099] [fglrx] ASIC hang happened
[ 7988.720124] Pid: 1186, comm: Xorg Tainted: P            3.0.0-14-generic #23-Ubuntu
[ 7988.720132] Call Trace:
[ 7988.720305]  [<ffffffffa0239f6e>] KCL_DEBUG_OsDump+0xe/0x10 [fglrx]
[ 7988.720406]  [<ffffffffa024748c>] firegl_hardwareHangRecovery+0x1c/0x50 [fglrx]
[ 7988.720570]  [<ffffffffa02d36c4>] ? _ZN18mmEnginesContainer9timestampEP26_QS_MM_TIMESTAMP_PACKET_INP27_QS_MM_TIMESTAMP_PACKET_OUT+0x184/0x1c0 [fglrx]
[ 7988.720591]  [<ffffffff8106e658>] ? lock_timer_base.isra.29+0x38/0x70
[ 7988.720602]  [<ffffffff8106f072>] ? try_to_del_timer_sync+0x92/0x130
[ 7988.720710]  [<ffffffffa0266b20>] ? firegl_cmmqs_notify_mvpu+0x2e0/0x2e0 [fglrx]
[ 7988.720849]  [<ffffffffa02b3a1a>] ? IsThreadTSExpired+0xca/0x110 [fglrx]
[ 7988.720956]  [<ffffffffa0266b7b>] ? firegl_cmmqs_TSExpired+0x5b/0xd0 [fglrx]
[ 7988.721056]  [<ffffffffa025214a>] ? irqmgr_wrap_wait_for_hifreq_interrupt_ex+0xca/0x400 [fglrx]
[ 7988.721156]  [<ffffffffa02502fb>] ? MCIL_SuspendThread+0xdb/0x120 [fglrx]
[ 7988.721301]  [<ffffffffa02bd3a2>] ? _ZN2OS13suspendThreadEj+0x22/0x30 [fglrx]
[ 7988.721439]  [<ffffffffa02b60aa>] ? CMMQSWaitOnTsSignal+0xaa/0x100 [fglrx]
[ 7988.721584]  [<ffffffffa02c57f2>] ? _Z8uCWDDEQCmjjPvjS_+0xc32/0x10c0 [fglrx]
[ 7988.721690]  [<ffffffffa0266672>] ? firegl_cmmqs_CWDDE_32+0x332/0x440 [fglrx]
[ 7988.721795]  [<ffffffffa0264fa0>] ? firegl_cmmqs_CWDDE32+0x70/0x100 [fglrx]
[ 7988.721810]  [<ffffffff81283e6a>] ? security_capable+0x2a/0x30
[ 7988.721913]  [<ffffffffa0264f30>] ? firegl_cmmqs_createdriver+0x170/0x170 [fglrx]
[ 7988.722008]  [<ffffffffa024302d>] ? firegl_ioctl+0x1ed/0x250 [fglrx]
[ 7988.722095]  [<ffffffffa02339be>] ? ip_firegl_unlocked_ioctl+0xe/0x20 [fglrx]
[ 7988.722107]  [<ffffffff81179dca>] ? do_vfs_ioctl+0x8a/0x340
[ 7988.722119]  [<ffffffff81168270>] ? vfs_read+0xb0/0x180
[ 7988.722129]  [<ffffffff8117a111>] ? sys_ioctl+0x91/0xa0
[ 7988.722143]  [<ffffffff815f36c2>] ? system_call_fastpath+0x16/0x1b
[ 7988.722157] pubdev:0xffffffffa04c2740, num of device:1 , name:fglrx, major 8, minor 92. 
[ 7988.722167] device 0 : 0xffff880233060000 .
[ 7988.722176] Asic ID:0x9802, revision:0x23, MMIOReg:0xffffc90012e00000.
[ 7988.722186] FB phys addr: 0xc0000000, MC :0xf00000000, Total FB size :0x18000000.
[ 7988.722197] gart table MC:0xf0fbfd000, Physical:0xcfbfd000, size:0x402000.
[ 7988.722207] mc_node :FB, total 1 zones
[ 7988.722215]     MC start:0xf00000000, Physical:0xc0000000, size:0x10000000.
[ 7988.722228]     Mapped heap -- Offset:0x0, size:0xfbfd000, reference count:90, mapping count:0,
[ 7988.722238]     Mapped heap -- Offset:0x0, size:0x1000000, reference count:1, mapping count:0,
[ 7988.722250]     Mapped heap -- Offset:0xfbfd000, size:0x403000, reference count:1, mapping count:0,
[ 7988.722259] mc_node :INV_FB, total 1 zones
[ 7988.722267]     MC start:0xf10000000, Physical:0xd0000000, size:0x8000000.
[ 7988.722277]     Mapped heap -- Offset:0x7ff4000, size:0xc000, reference count:1, mapping count:0,
[ 7988.722286] mc_node :GART_USWC, total 2 zones
[ 7988.722294]     MC start:0x40100000, Physical:0x0, size:0x50000000.
[ 7988.722304]     Mapped heap -- Offset:0x3000000, size:0x800000, reference count:1, mapping count:0,
[ 7988.722316]     Mapped heap -- Offset:0x2800000, size:0x800000, reference count:1, mapping count:0,
[ 7988.722327]     Mapped heap -- Offset:0x2000000, size:0x800000, reference count:1, mapping count:0,
[ 7988.722338]     Mapped heap -- Offset:0x0, size:0x2000000, reference count:15, mapping count:0,
[ 7988.722347] mc_node :GART_CACHEABLE, total 3 zones
[ 7988.722355]     MC start:0x10400000, Physical:0x0, size:0x2fd00000.
[ 7988.722365]     Mapped heap -- Offset:0x5400000, size:0x200000, reference count:1, mapping count:0,
[ 7988.722377]     Mapped heap -- Offset:0x5200000, size:0x200000, reference count:1, mapping count:0,
[ 7988.722389]     Mapped heap -- Offset:0x5600000, size:0x900000, reference count:2, mapping count:0,
[ 7988.722400]     Mapped heap -- Offset:0x4900000, size:0x900000, reference count:2, mapping count:0,
[ 7988.722411]     Mapped heap -- Offset:0x1100000, size:0x200000, reference count:4, mapping count:0,
[ 7988.722422]     Mapped heap -- Offset:0x4200000, size:0x700000, reference count:8, mapping count:0,
[ 7988.722433]     Mapped heap -- Offset:0x3d00000, size:0x500000, reference count:2, mapping count:0,
[ 7988.722444]     Mapped heap -- Offset:0x3800000, size:0x500000, reference count:2, mapping count:0,
[ 7988.722456]     Mapped heap -- Offset:0xb00000, size:0x600000, reference count:4, mapping count:0,
[ 7988.722467]     Mapped heap -- Offset:0x2f00000, size:0x900000, reference count:3, mapping count:0,
[ 7988.722479]     Mapped heap -- Offset:0x2600000, size:0x900000, reference count:2, mapping count:0,
[ 7988.722490]     Mapped heap -- Offset:0x1d00000, size:0x900000, reference count:3, mapping count:0,
[ 7988.722501]     Mapped heap -- Offset:0x1400000, size:0x900000, reference count:23, mapping count:0,
[ 7988.722513]     Mapped heap -- Offset:0x200000, size:0x900000, reference count:15, mapping count:0,
[ 7988.722523]     Mapped heap -- Offset:0x0, size:0x200000, reference count:24, mapping count:0,
[ 7988.722534]     Mapped heap -- Offset:0xef000, size:0x11000, reference count:1, mapping count:0,
[ 7988.722547] GRBM : 0xe7724828, SRBM : 0x20004840 .
[ 7988.722557] CP_RB_BASE : 0x401000, CP_RB_RPTR : 0x3f130 , CP_RB_WPTR :0x3f2d0.
[ 7988.722568] CP_IB1_BUFSZ:0x1250, CP_IB1_BASE_HI:0x0, CP_IB1_BASE_LO:0x4065e000.
[ 7988.722578] last submit IB buffer -- MC :0x4065e000,phys:0x220449000.
[ 7988.722591] Dump the trace queue.
[ 7988.722596] End of dump
Comment 18 Andrew Aladjev 2012-02-26 11:37:47 CST
I can confirm this on the radeon 6470 mobile with 12.1
the importance of the bug is critical!
Comment 19 M. Schinkel 2012-03-22 07:16:03 CDT
Happens here too:


lspci:
======
05:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Turks [Radeon HD 6570]
05:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Turks HDMI Audio [Radeon HD 6000 Series]


Kernel log:
===========

[fglrx] ASIC hang happened
Pid: 16959, comm: Xorg Tainted: P           O 3.2.12-daedalus #13
Call Trace:
 [<ffffffffa02545cc>] ? firegl_hardwareHangRecovery+0x1c/0x50 [fglrx]
 [<ffffffffa02ef399>] ? _ZN4Asic9WaitUntil15ResetASICIfHungEv+0x9/0x10 [fglrx]
 [<ffffffffa02ef33c>] ? _ZN4Asic9WaitUntil15WaitForCompleteEv+0x9c/0xf0 [fglrx]
 [<ffffffffa02e9f3e>] ? _ZN15ExecutableUnits10CPRingIdleE15idle_WaitMethod12_QS_CP_RING_+0x11e/0x1e0 [fglrx]
 [<ffffffffa02e9dcc>] ? _ZN15ExecutableUnits7PM4idleE15idle_WaitMethod+0x4c/0x90 [fglrx]
 [<ffffffffa02e9936>] ? _ZN15ExecutableUnits9assertPM4Eb+0x56/0x70 [fglrx]
 [<ffffffffa02f3c39>] ? _ZN8AsicR6009assertPM4Eb+0x39/0x80 [fglrx]
 [<ffffffffa02c2403>] ? CMMQS_Initialize_WA+0x183/0x1b0 [fglrx]
 [<ffffffffa0273ec2>] ? firegl_cmmqs_init+0x642/0xb80 [fglrx]
 [<ffffffffa0256fd4>] ? firegl_init_iommu+0x94/0x170 [fglrx]
 [<ffffffffa0273116>] ? firegl_cmmqs_createdriver+0x96/0x1a0 [fglrx]
 [<ffffffff81046d29>] ? ns_capable+0x29/0x50
 [<ffffffffa0273080>] ? firegl_uvd_destroy+0x4e0/0x4e0 [fglrx]
 [<ffffffffa025012d>] ? firegl_ioctl+0x1ed/0xf30 [fglrx]
 [<ffffffffa0241c99>] ? ip_firegl_unlocked_ioctl+0x9/0x10 [fglrx]
 [<ffffffff810fa1e6>] ? do_vfs_ioctl+0x96/0x500
 [<ffffffff810e90f7>] ? vfs_write+0x127/0x170
 [<ffffffff810fa699>] ? sys_ioctl+0x49/0x80
 [<ffffffff814b0ebb>] ? system_call_fastpath+0x16/0x1b
pubdev:0xffffffffa04e2a00, num of device:1 , name:fglrx, major 8, minor 95.
device 0 : 0xffff88060f7dc000 .
Asic ID:0x6759, revision:0x28, MMIOReg:0xffffc90010280000.
FB phys addr: 0xd0000000, MC :0xf00000000, Total FB size :0x80000000.
gart table MC:0xf0f8fd000, Physical:0xdf8fd000, size:0x402000.
mc_node :FB, total 1 zones
    MC start:0xf00000000, Physical:0xd0000000, size:0xfd00000.
    Mapped heap -- Offset:0x0, size:0xf8fd000, reference count:1, mapping count:0,
    Mapped heap -- Offset:0x0, size:0x1000000, reference count:1, mapping count:0,
    Mapped heap -- Offset:0xf8fd000, size:0x403000, reference count:1, mapping count:0,
mc_node :INV_FB, total 1 zones
    MC start:0xf0fd00000, Physical:0xdfd00000, size:0x70300000.
    Mapped heap -- Offset:0x702f4000, size:0xc000, reference count:1, mapping count:0,
mc_node :GART_USWC, total 3 zones
    MC start:0x40100000, Physical:0x0, size:0x50000000.
    Mapped heap -- Offset:0x0, size:0x2000000, reference count:1, mapping count:0,
mc_node :GART_CACHEABLE, total 3 zones
    MC start:0x10400000, Physical:0x0, size:0x2fd00000.
    Mapped heap -- Offset:0x0, size:0x200000, reference count:1, mapping count:0,
    Mapped heap -- Offset:0xef000, size:0x11000, reference count:1, mapping count:0,
GRBM : 0xa0003828, SRBM : 0x200000c0 .
CP_RB_BASE : 0x401000, CP_RB_RPTR : 0x10 , CP_RB_WPTR :0x10.
CP_IB1_BUFSZ:0x0, CP_IB1_BASE_HI:0x0, CP_IB1_BASE_LO:0x0.
last submit IB buffer -- MC :0x0. Can't found mapped physical page for this MC .
Dump the trace queue.
End of dump
Comment 20 Don Hughes 2012-05-21 11:14:43 CDT
Using Catalyst 12.4 Radeon HD 5450 and SuSE Linux 11.4 I get the following on three different systems:


May 21 07:49:55 ???? kernel: [46085.928017] Pid: 6996, comm: X Tainted: P           O 3.3.6-24-default #1
May 21 07:49:55 ???? kernel: [46085.928020] Call Trace:
May 21 07:49:55 ???? kernel: [46085.928045]  [<ffffffff8100445a>] dump_trace+0x9a/0x260
May 21 07:49:55 ???? kernel: [46085.928054]  [<ffffffff815587a0>] dump_stack+0x69/0x6f
May 21 07:49:55 ???? kernel: [46085.928157]  [<ffffffffa02650cc>] firegl_hardwareHangRecovery+0x1c/0x50 [fglrx]
May 21 07:49:55 ???? kernel: [46085.928270]  [<ffffffffa0300cd9>] _ZN4Asic9WaitUntil15ResetASICIfHungEv+0x9/0x10 [fglrx]
May 21 07:49:55 ???? kernel: [46085.928555]  [<ffffffffa0300c7c>] _ZN4Asic9WaitUntil15WaitForCompleteEv+0x9c/0xf0 [fglrx]
May 21 07:49:55 ???? kernel: [46085.928821]  [<ffffffffa02fb77e>] _ZN15ExecutableUnits10CPRingIdleE15idle_WaitMethod12_QS_CP_RING_+0x11e/0x1e0 [fglrx]
May 21 07:49:55 ???? kernel: [46085.929075]  [<ffffffffa02fb60c>] _ZN15ExecutableUnits7PM4idleE15idle_WaitMethod+0x4c/0x90 [fglrx]
May 21 07:49:55 ???? kernel: [46085.929329]  [<ffffffffa02fb13e>] _ZN15ExecutableUnits9assertPM4Eb+0x1e/0x70 [fglrx]
May 21 07:49:55 ???? kernel: [46085.929583]  [<ffffffffa0305519>] _ZN8AsicR6009assertPM4Eb+0x39/0x80 [fglrx]
May 21 07:49:55 ???? kernel: [46085.929851]  [<ffffffffa02d3b24>] CMMQS_DisableQS+0x24/0x30 [fglrx]
May 21 07:49:55 ???? kernel: [46085.930012]  [<ffffffffa02852a8>] firegl_cmmqs_Disable_QS+0x58/0xf0 [fglrx]
May 21 07:49:55 ???? kernel: [46085.930109]  [<ffffffffa0284112>] firegl_cmmqs_disableqs+0x12/0x70 [fglrx]
May 21 07:49:55 ???? kernel: [46085.930201]  [<ffffffffa0260ded>] firegl_ioctl+0x1ed/0x250 [fglrx]
May 21 07:49:55 ???? kernel: [46085.930269]  [<ffffffffa0251e89>] ip_firegl_unlocked_ioctl+0x9/0x10 [fglrx]
May 21 07:49:55 ???? kernel: [46085.930279]  [<ffffffff81168a15>] do_vfs_ioctl+0x75/0x2d0
May 21 07:49:55 ???? kernel: [46085.930285]  [<ffffffff81168d08>] sys_ioctl+0x98/0xa0
May 21 07:49:55 ???? kernel: [46085.930292]  [<ffffffff81578639>] system_call_fastpath+0x16/0x1b
May 21 07:49:55 ???? kernel: [46085.930306]  [<00007f1ff99ad837>] 0x7f1ff99ad836
May 21 07:49:55 ???? kernel: [46085.930311] pubdev:0xffffffffa0501320, num of device:1 , name:fglrx, major 8, minor 96.
May 21 07:49:55 ???? kernel: [46085.930314] device 0 : 0xffff8806252d4000 .
May 21 07:49:55 ???? kernel: [46085.930317] Asic ID:0x68f9, revision:0x3c, MMIOReg:0xffffc90014ac0000.
May 21 07:49:55 ???? kernel: [46085.930320] FB phys addr: 0xd0000000, MC :0xf00000000, Total FB size :0x20000000.
May 21 07:49:55 ???? kernel: [46085.930323] gart table MC:0xf0f8fd000, Physical:0xdf8fd000, size:0x402000.
May 21 07:49:55 ???? kernel: [46085.930326] mc_node :FB, total 1 zones
May 21 07:49:55 ???? kernel: [46085.930328]     MC start:0xf00000000, Physical:0xd0000000, size:0xfd00000.
May 21 07:49:55 ???? kernel: [46085.930332]     Mapped heap -- Offset:0x0, size:0xf8fd000, reference count:28, mapping count:0,
May 21 07:49:55 ???? kernel: [46085.930335]     Mapped heap -- Offset:0x0, size:0x1000000, reference count:1, mapping count:0,
May 21 07:49:55 ???? kernel: [46085.930338]     Mapped heap -- Offset:0xf8fd000, size:0x403000, reference count:1, mapping count:0,
May 21 07:49:55 ???? kernel: [46085.930340] mc_node :INV_FB, total 1 zones
May 21 07:49:55 ???? kernel: [46085.930342]     MC start:0xf0fd00000, Physical:0xdfd00000, size:0x10300000.
May 21 07:49:55 ???? kernel: [46085.930345]     Mapped heap -- Offset:0x102f4000, size:0xc000, reference count:1, mapping count:0,
May 21 07:49:55 ???? kernel: [46085.930348] mc_node :GART_USWC, total 3 zones
May 21 07:49:55 ???? kernel: [46085.930350]     MC start:0x40100000, Physical:0x0, size:0x50000000.
May 21 07:49:55 ???? kernel: [46085.930353]     Mapped heap -- Offset:0x0, size:0x2000000, reference count:9, mapping count:0,
May 21 07:49:55 ???? kernel: [46085.930355] mc_node :GART_CACHEABLE, total 3 zones
May 21 07:49:55 ???? kernel: [46085.930357]     MC start:0x10400000, Physical:0x0, size:0x2fd00000.
May 21 07:49:55 ???? kernel: [46085.930360]     Mapped heap -- Offset:0x1300000, size:0x300000, reference count:2, mapping count:0,
May 21 07:49:55 ???? kernel: [46085.930363]     Mapped heap -- Offset:0x1600000, size:0x800000, reference count:2, mapping count:0,
May 21 07:49:55 ???? kernel: [46085.930366]     Mapped heap -- Offset:0x1000000, size:0x300000, reference count:1, mapping count:0,
May 21 07:49:55 ???? kernel: [46085.930369]     Mapped heap -- Offset:0xc00000, size:0x400000, reference count:2, mapping count:0,
May 21 07:49:55 ???? kernel: [46085.930372]     Mapped heap -- Offset:0x900000, size:0x300000, reference count:7, mapping count:0,
May 21 07:49:55 ???? kernel: [46085.930375]     Mapped heap -- Offset:0x600000, size:0x300000, reference count:2, mapping count:0,
May 21 07:49:55 ???? kernel: [46085.930378]     Mapped heap -- Offset:0x200000, size:0x400000, reference count:5, mapping count:0,
May 21 07:49:55 ???? kernel: [46085.930381]     Mapped heap -- Offset:0x0, size:0x200000, reference count:8, mapping count:0,
May 21 07:49:55 ???? kernel: [46085.930384]     Mapped heap -- Offset:0xef000, size:0x11000, reference count:1, mapping count:0,
May 21 07:49:55 ???? kernel: [46085.930388] GRBM : 0xa0003828, SRBM : 0x200000c0 .
May 21 07:49:55 ???? kernel: [46085.930392] CP_RB_BASE : 0x401000, CP_RB_RPTR : 0x1f500 , CP_RB_WPTR :0x1f500.
May 21 07:49:55 ???? kernel: [46085.930396] CP_IB1_BUFSZ:0x0, CP_IB1_BASE_HI:0x0, CP_IB1_BASE_LO:0x4027c000.
May 21 07:49:55 ???? kernel: [46085.930399] last submit IB buffer -- MC :0x4027c000,phys:0x224cfa000.
May 21 07:49:55 ???? kernel: [46085.930403] Dump the trace queue.
May 21 07:49:55 ???? kernel: [46085.930404] End of dump
Comment 21 pierre.boudier@amd.com 2012-05-21 11:17:51 CDT
do you have a specific app/test which triggers the hang ?
Comment 22 Don Hughes 2012-05-21 12:48:27 CDT
No,

But it does seem to happen most often when I use ctrl-alt-f2 to switch between the X display and a terminal window.

It has happened when just opening a GnomeTerminal window.

It seems to happen 1-2 times a day, but it is not consistent.
Comment 23 Gang Liu 2012-05-24 02:32:22 CDT
We can't reproduce the the issue with following configuration. OS/Driver/ASIC is same. There might be some other factor which cause the disconnect. For example, how many displays you are using and what's the resolution? Could you attach the atisysteminfo for us to have further investigation? Thanks.

OS: suse11.4 x86
Driver: amd-driver-installer-12-4-x86.x86_64.run
ASIC: Cedar Pro (HD5450)
Comment 24 Don Hughes 2012-05-28 18:29:59 CDT
I do not have a atisysteminfo file that I could find on my system.  I have attached the X11 config.

I have two monitors.  One at 1920x1080 and one at 1680x1050.
Comment 25 Don Hughes 2012-05-28 18:30:37 CDT
Created attachment 470 [details]
X11 configuration
Comment 26 hd6570 2012-06-02 05:49:40 CDT
openSUSE 11.4, 
kernel-desktop 3.1.10, 
Xorg 1.10.4, 
KDE 4.7.4, 
amd-driver-installer-8.98-x86.x86_64, 
AMD Radeon HD 6570" (Chipset = 0x6759)

Often at opening a new X session, X hangs completely and eats up one CPU core completely. The machine can be reached with ssh and rebooted. In messages, the following in entry can be found:




Jun  2 10:53:57 pc kernel: [ 8351.017008] Pid: 7435, comm: Xorg Tainted: P            3.1.10-16.1-desktop #1
Jun  2 10:53:57 pc kernel: [ 8351.017012] Call Trace:
Jun  2 10:53:57 pc kernel: [ 8351.017022]  [<ffffffff81004538>] dump_trace+0x88/0x380
Jun  2 10:53:57 pc kernel: [ 8351.017028]  [<ffffffff815a794a>] dump_stack+0x69/0x6f
Jun  2 10:53:57 pc kernel: [ 8351.017071]  [<ffffffffa013b16c>] firegl_hardwareHangRecovery+0x1c/0x30 [fglrx]
Jun  2 10:53:57 pc kernel: [ 8351.017136]  [<ffffffffa01b4619>] _ZN4Asic9WaitUntil15ResetASICIfHungEv+0x9/0x10 [fglrx]
Jun  2 10:53:57 pc kernel: [ 8351.017271]  [<ffffffffa01b45bc>] _ZN4Asic9WaitUntil15WaitForCompleteEv+0x9c/0xf0 [fglrx]
Jun  2 10:53:57 pc kernel: [ 8351.017414]  [<ffffffffa01c5c6e>] _ZN15ExecutableUnits10CPRingIdleE15idle_WaitMethod12_QS_CP_RING_+0x11e/0x1e0 [fglrx]
Jun  2 10:53:57 pc kernel: [ 8351.017572]  [<ffffffffa01c5afb>] _ZN15ExecutableUnits7PM4idleE15idle_WaitMethod+0x4b/0x90 [fglrx]
Jun  2 10:53:57 pc kernel: [ 8351.017729]  [<ffffffffa01c562e>] _ZN15ExecutableUnits9assertPM4Eb+0x1e/0x70 [fglrx]
Jun  2 10:53:57 pc kernel: [ 8351.017884]  [<ffffffffa01e6d09>] _ZN8AsicR6009assertPM4Eb+0x39/0x80 [fglrx]
Jun  2 10:53:57 pc kernel: [ 8351.018102]  [<ffffffffa019c8a4>] CMMQS_DisableQS+0x24/0x30 [fglrx]
Jun  2 10:53:57 pc kernel: [ 8351.018203]  [<ffffffffa015d368>] firegl_cmmqs_Disable_QS+0x58/0xf0 [fglrx]
Jun  2 10:53:57 pc kernel: [ 8351.018265]  [<ffffffffa015c152>] firegl_cmmqs_disableqs+0x12/0x70 [fglrx]
Jun  2 10:53:57 pc kernel: [ 8351.018322]  [<ffffffffa0136e6d>] firegl_ioctl+0x1ed/0x250 [fglrx]
Jun  2 10:53:57 pc kernel: [ 8351.018362]  [<ffffffffa0127f99>] ip_firegl_unlocked_ioctl+0x9/0x10 [fglrx]
Jun  2 10:53:57 pc kernel: [ 8351.018373]  [<ffffffff8116f414>] do_vfs_ioctl+0x84/0x2d0
Jun  2 10:53:57 pc kernel: [ 8351.018380]  [<ffffffff8116f6f8>] sys_ioctl+0x98/0xa0
Jun  2 10:53:57 pc kernel: [ 8351.018387]  [<ffffffff815b2052>] system_call_fastpath+0x16/0x1b
Jun  2 10:53:57 pc kernel: [ 8351.018399]  [<00007ffcbadf6d87>] 0x7ffcbadf6d86
Jun  2 10:53:57 pc kernel: [ 8351.018405] pubdev:0xffffffffa034bc00, num of device:1 , name:fglrx, major 8, minor 98. 
Jun  2 10:53:57 pc kernel: [ 8351.018410] device 0 : 0xffff88021f8d0000 .
Jun  2 10:53:57 pc kernel: [ 8351.018415] Asic ID:0x6759, revision:0x28, MMIOReg:0xffffc90012740000.
Jun  2 10:53:57 pc kernel: [ 8351.018420] FB phys addr: 0xd0000000, MC :0xf00000000, Total FB size :0x40000000.
Jun  2 10:53:57 pc kernel: [ 8351.018426] gart table MC:0xf0f8fd000, Physical:0xdf8fd000, size:0x402000.
Jun  2 10:53:57 pc kernel: [ 8351.018431] mc_node :FB, total 1 zones
Jun  2 10:53:57 pc kernel: [ 8351.018436]     MC start:0xf00000000, Physical:0xd0000000, size:0xfd00000.
Jun  2 10:53:57 pc kernel: [ 8351.018441]     Mapped heap -- Offset:0x0, size:0xf8fd000, reference count:139, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018447]     Mapped heap -- Offset:0x0, size:0x1000000, reference count:1, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018456]     Mapped heap -- Offset:0xf8fd000, size:0x403000, reference count:1, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018462] mc_node :INV_FB, total 1 zones
Jun  2 10:53:57 pc kernel: [ 8351.018466]     MC start:0xf0fd00000, Physical:0xdfd00000, size:0x30300000.
Jun  2 10:53:57 pc kernel: [ 8351.018472]     Mapped heap -- Offset:0x302f4000, size:0xc000, reference count:1, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018477] mc_node :GART_USWC, total 3 zones
Jun  2 10:53:57 pc kernel: [ 8351.018482]     MC start:0x40100000, Physical:0x0, size:0x50000000.
Jun  2 10:53:57 pc kernel: [ 8351.018487]     Mapped heap -- Offset:0x2000000, size:0x1000000, reference count:1, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018493]     Mapped heap -- Offset:0x0, size:0x2000000, reference count:11, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018498] mc_node :GART_CACHEABLE, total 3 zones
Jun  2 10:53:57 pc kernel: [ 8351.018503]     MC start:0x10400000, Physical:0x0, size:0x2fd00000.
Jun  2 10:53:57 pc kernel: [ 8351.018487]     Mapped heap -- Offset:0x2000000, size:0x1000000, reference count:1, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018493]     Mapped heap -- Offset:0x0, size:0x2000000, reference count:11, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018498] mc_node :GART_CACHEABLE, total 3 zones
Jun  2 10:53:57 pc kernel: [ 8351.018503]     MC start:0x10400000, Physical:0x0, size:0x2fd00000.
Jun  2 10:53:57 pc kernel: [ 8351.018508]     Mapped heap -- Offset:0x10300000, size:0xb00000, reference count:2, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018514]     Mapped heap -- Offset:0xdd00000, size:0xb00000, reference count:1, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018520]     Mapped heap -- Offset:0xfa00000, size:0x900000, reference count:1, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018525]     Mapped heap -- Offset:0xf000000, size:0xa00000, reference count:2, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018534]     Mapped heap -- Offset:0xd400000, size:0x900000, reference count:2, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018545]     Mapped heap -- Offset:0xb500000, size:0x900000, reference count:3, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018556]     Mapped heap -- Offset:0xcb00000, size:0x900000, reference count:1, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018566]     Mapped heap -- Offset:0xac00000, size:0x900000, reference count:5, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018577]     Mapped heap -- Offset:0xc200000, size:0x900000, reference count:2, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018588]     Mapped heap -- Offset:0xa100000, size:0xb00000, reference count:3, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018600]     Mapped heap -- Offset:0x8c00000, size:0xa00000, reference count:2, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018610]     Mapped heap -- Offset:0x9600000, size:0xb00000, reference count:2, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018622]     Mapped heap -- Offset:0x8200000, size:0xa00000, reference count:2, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018634]     Mapped heap -- Offset:0x7800000, size:0xa00000, reference count:2, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018645]     Mapped heap -- Offset:0x7400000, size:0x400000, reference count:2, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018656]     Mapped heap -- Offset:0x6a00000, size:0xa00000, reference count:7, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018666]     Mapped heap -- Offset:0x6000000, size:0xa00000, reference count:5, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018676]     Mapped heap -- Offset:0x5600000, size:0xa00000, reference count:4, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018686]     Mapped heap -- Offset:0x4c00000, size:0xa00000, reference count:3, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018697]     Mapped heap -- Offset:0x4200000, size:0xa00000, reference count:3, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018708]     Mapped heap -- Offset:0x3800000, size:0xa00000, reference count:3, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018719]     Mapped heap -- Offset:0x2e00000, size:0xa00000, reference count:3, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018731]     Mapped heap -- Offset:0x2a00000, size:0x400000, reference count:4, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018743]     Mapped heap -- Offset:0x2000000, size:0xa00000, reference count:28, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018755]     Mapped heap -- Offset:0x200000, size:0xa00000, reference count:20, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018766]     Mapped heap -- Offset:0x1600000, size:0xa00000, reference count:5, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018778]     Mapped heap -- Offset:0xc00000, size:0xa00000, reference count:36, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018788]     Mapped heap -- Offset:0x0, size:0x200000, reference count:16, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018798]     Mapped heap -- Offset:0xef000, size:0x11000, reference count:1, mapping count:0,
Jun  2 10:53:57 pc kernel: [ 8351.018811] GRBM : 0xa0003828, SRBM : 0x200000c0 .
Jun  2 10:53:57 pc kernel: [ 8351.018824] CP_RB_BASE : 0x401000, CP_RB_RPTR : 0x1f840 , CP_RB_WPTR :0x1f840.
Jun  2 10:53:57 pc kernel: [ 8351.018834] CP_IB1_BUFSZ:0x0, CP_IB1_BASE_HI:0x0, CP_IB1_BASE_LO:0x407b9000.
Jun  2 10:53:57 pc kernel: [ 8351.018846] last submit IB buffer -- MC :0x407b9000,phys:0x107e1000.
Jun  2 10:53:57 pc kernel: [ 8351.018863] Dump the trace queue.
Jun  2 10:53:57 pc kernel: [ 8351.018870] End of dump
Comment 27 hd6570 2012-06-02 05:53:19 CDT
Created attachment 474 [details]
Xorg.log for the ASIC hang reported above
Comment 28 dhdd 2012-07-03 02:00:33 CDT
Why is this bug not being reopened? Clearly the problem persists in 12.4, it does for me too.
Comment 29 Andrew Aladjev 2012-07-03 02:07:00 CDT
I can reproduce it under last 12.6 with HD6470. I have no reopen button. I wont ever buy ati "products" because there are completely no support
Comment 30 hd6570 2012-07-03 03:59:03 CDT
I can confirm the problem for 12.6 (Radeon HD 6570), too.

They changed their release management because they wanted to get more quality, to get the bugs fixed. A good idea.

What happened: The time between the releases is now much longer, the quality stuck at the old point.

Honestly: Did you really believe, that this new release management would change anything?

I don't think they have any serious interest in support of Linux (the opensource driver is even more unusable).

My problem: Is there a gfx card out there from nvidia, which has the same proficiency level as Radeon HD 6570 and is w/o fan? Until now, I couldn't find any. That's my problem and AMD probably knows about that ... .

Sorry, but I'm really, really angry meanwhile about the ignorance of AMD.
Comment 31 Don Hughes 2012-07-12 05:34:29 CDT
This is still a problem with 12.6

How do we get it re-opened?
Comment 32 Rob 2012-07-17 09:11:32 CDT
my ATI/AMD hardware: XFX hd5870 on 3x 1920x1200 monitors

(This is a VERY common issue/bug, please give it the attention it deserves)

For me the error is quite easy to reproduce, it's only intermittent (sometimes 3 times on 1 day sometimes, when i'm really lucky, i have a stable machine for a week or so) so sometimes takes a bit longer. Generally after a few longer openGL sessions (flightgear, flightsimulator in my case, fgfs)  will crash your desktop from version 11.1 to the ones that are out today. (just start fgfs, and let it run for some time). Sometimes the screen just freezes, sometimes it goes to standby. Though sometimes when you are unlucky starting a webGL enabled browser is enough to crash Xorg.

It's very unfortunate that ATI/AMD will not or simply cant find the cause of this problem and squash the bug once and for all. If you guys need a test machine to reproduce the error on let me know and i can set one up remotely via ssh at your office, or in worst case grant you access on my system if its really this hard for you to reproduce, to properly help the people that fund your company. (useless offer i guess, as you never replied to my emails neither)

Kernel versions, xorg or ati driver version seem unimportant, it exists for a long time and its *heavy understatement* quite disappointing to see this receiving so little attention.

Though since my NVIDIA experience is even more if not just as crappy, i don't have much other choice for a bit decent openGL performance for the period that the drivers don't crash my xorg.

I'm not going to buy the coming ATI 7990 (or any other card) before i see this bug is fixed on my 5870; maybe i will simply give NVIDIA another chance. Everybody reporting this bug wants to see improvement, see you having better support/drivers then NVIDIA. You are really slacking here.

I won't be providing more detailed logs or extracts, i think plenty of people already did. Yet even writing this feels useless...

Jul 17 14:22:46 x2 kernel: [146148.195530] [fglrx] ASIC hang happened
Jul 17 14:22:46 x2 kernel: [146148.195534] Pid: 7790, comm: fgfs Tainted: P            2.6.35.14-106.fc14.x86_64 #1
Jul 17 14:22:46 x2 kernel: [146148.195536] Call Trace:
Jul 17 14:22:46 x2 kernel: [146148.195575]  [<ffffffffa00c9a42>] KCL_DEBUG_OsDump+0xe/0x10 [fglrx]
Jul 17 14:22:46 x2 kernel: [146148.195632]  [<ffffffffa00d6d6c>] firegl_hardwareHangRecovery+0x1c/0x30 [fglrx]
Jul 17 14:22:46 x2 kernel: [146148.195682]  [<ffffffffa0150219>] ? _ZN4Asic9WaitUntil15ResetASICIfHungEv+0x9/0x10 [fglrx]
Jul 17 14:22:46 x2 kernel: [146148.195732]  [<ffffffffa01501bc>] ? _ZN4Asic9WaitUntil15WaitForCompleteEv+0x9c/0xf0 [fglrx]
Jul 17 14:22:46 x2 kernel: [146148.195784]  [<ffffffffa016186e>] ? _ZN15ExecutableUnits10CPRingIdleE15idle_WaitMethod12_QS_CP_RING_+0x11e/0x1e0 [fglrx]
Jul 17 14:22:46 x2 kernel: [146148.195838]  [<ffffffffa01616fb>] ? _ZN15ExecutableUnits7PM4idleE15idle_WaitMethod+0x4b/0x90 [fglrx]
Jul 17 14:22:46 x2 kernel: [146148.195887]  [<ffffffffa0157ab1>] ? _ZN15QS_PRIVATE_CORE9QsPM4idleE15idle_WaitMethod+0x31/0x60 [fglrx]
Jul 17 14:22:46 x2 kernel: [146148.195934]  [<ffffffffa0140dce>] ? _ZN10QS_PRIVATE11synchronizeEv+0xce/0xe0 [fglrx]
Jul 17 14:22:46 x2 kernel: [146148.195983]  [<ffffffffa014a8b5>] ? _Z8uCWDDEQCmjjPvjS_+0x3b5/0x10c0 [fglrx]
Jul 17 14:22:46 x2 kernel: [146148.195989]  [<ffffffff8146b667>] ? _raw_spin_unlock_irqrestore+0x17/0x19
Jul 17 14:22:46 x2 kernel: [146148.196020]  [<ffffffffa00f936f>] ? firegl_cmmqs_CWDDE_32+0x36f/0x480 [fglrx]
Jul 17 14:22:46 x2 kernel: [146148.196051]  [<ffffffffa00f7a5e>] ? firegl_cmmqs_CWDDE32+0x6e/0x100 [fglrx]
Jul 17 14:22:46 x2 kernel: [146148.196082]  [<ffffffffa00f79f0>] ? firegl_cmmqs_CWDDE32+0x0/0x100 [fglrx]
Jul 17 14:22:46 x2 kernel: [146148.196106]  [<ffffffffa00d2a6d>] ? firegl_ioctl+0x1ed/0x250 [fglrx]
Jul 17 14:22:46 x2 kernel: [146148.196124]  [<ffffffffa00c4ac2>] ? ip_firegl_unlocked_ioctl+0xe/0x12 [fglrx]
Jul 17 14:22:46 x2 kernel: [146148.196128]  [<ffffffff81124b07>] ? vfs_ioctl+0x36/0xa7
Jul 17 14:22:46 x2 kernel: [146148.196130]  [<ffffffff81125468>] ? do_vfs_ioctl+0x468/0x49b
Jul 17 14:22:46 x2 kernel: [146148.196135]  [<ffffffff8103c165>] ? need_resched+0x23/0x2d
Jul 17 14:22:46 x2 kernel: [146148.196139]  [<ffffffff81118c16>] ? fput+0x22/0x1ed
Jul 17 14:22:46 x2 kernel: [146148.196142]  [<ffffffff81076d11>] ? sys_futex+0x134/0x143
Jul 17 14:22:46 x2 kernel: [146148.196145]  [<ffffffff811254f1>] ? sys_ioctl+0x56/0x79
Jul 17 14:22:46 x2 kernel: [146148.196149]  [<ffffffff81009cb2>] ? system_call_fastpath+0x16/0x1b
Jul 17 14:22:46 x2 kernel: [146148.196153] pubdev:0xffffffffa02e49e0, num of device:1 , name:fglrx, major 8, minor 98. 
Jul 17 14:22:46 x2 kernel: [146148.196156] device 0 : 0xffff880603684000 .
Jul 17 14:22:46 x2 kernel: [146148.196159] Asic ID:0x6898, revision:0x2, MMIOReg:0xffffc90007ec0000.
Jul 17 14:22:46 x2 kernel: [146148.196162] FB phys addr: 0xe0000000, MC :0xf00000000, Total FB size :0x40000000.
Jul 17 14:22:46 x2 kernel: [146148.196165] gart table MC:0xf0f8fd000, Physical:0xef8fd000, size:0x402000.
Jul 17 14:22:46 x2 kernel: [146148.196167] mc_node :FB, total 1 zones
Jul 17 14:22:46 x2 kernel: [146148.196170]     MC start:0xf00000000, Physical:0xe0000000, size:0xfd00000.
Jul 17 14:22:46 x2 kernel: [146148.196173]     Mapped heap -- Offset:0x0, size:0xf8fd000, reference count:1, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196175]     Mapped heap -- Offset:0x0, size:0x1000000, reference count:1, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196178]     Mapped heap -- Offset:0xf8fd000, size:0x403000, reference count:1, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196180] mc_node :INV_FB, total 1 zones
Jul 17 14:22:46 x2 kernel: [146148.196183]     MC start:0xf0fd00000, Physical:0xefd00000, size:0x30300000.
Jul 17 14:22:46 x2 kernel: [146148.196185]     Mapped heap -- Offset:0x302f4000, size:0xc000, reference count:1, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196188] mc_node :GART_USWC, total 3 zones
Jul 17 14:22:46 x2 kernel: [146148.196190]     MC start:0x40100000, Physical:0x0, size:0x50000000.
Jul 17 14:22:46 x2 kernel: [146148.196193]     Mapped heap -- Offset:0x5800000, size:0x800000, reference count:1, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196195]     Mapped heap -- Offset:0x5000000, size:0x800000, reference count:5, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196198]     Mapped heap -- Offset:0x4800000, size:0x800000, reference count:6, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196201]     Mapped heap -- Offset:0x4000000, size:0x800000, reference count:8, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196204]     Mapped heap -- Offset:0x3800000, size:0x800000, reference count:5, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196207]     Mapped heap -- Offset:0x3000000, size:0x800000, reference count:1, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196211]     Mapped heap -- Offset:0x2800000, size:0x800000, reference count:1, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196214]     Mapped heap -- Offset:0x2000000, size:0x800000, reference count:1, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196217]     Mapped heap -- Offset:0x0, size:0x2000000, reference count:4, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196220] mc_node :GART_CACHEABLE, total 3 zones
Jul 17 14:22:46 x2 kernel: [146148.196222]     MC start:0x10400000, Physical:0x0, size:0x2fd00000.
Jul 17 14:22:46 x2 kernel: [146148.196225]     Mapped heap -- Offset:0x9e00000, size:0x600000, reference count:1, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196229]     Mapped heap -- Offset:0x9300000, size:0x500000, reference count:1, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196232]     Mapped heap -- Offset:0xde00000, size:0x1b00000, reference count:1, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196235]     Mapped heap -- Offset:0xc300000, size:0x1b00000, reference count:1, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196238]     Mapped heap -- Offset:0x14a00000, size:0x1b00000, reference count:1, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196241]     Mapped heap -- Offset:0x12f00000, size:0x1b00000, reference count:1, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196245]     Mapped heap -- Offset:0x11400000, size:0x1b00000, reference count:1, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196248]     Mapped heap -- Offset:0xc200000, size:0x100000, reference count:1, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196251]     Mapped heap -- Offset:0x7100000, size:0x1b00000, reference count:1, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196255]     Mapped heap -- Offset:0x6700000, size:0xa00000, reference count:1, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196258]     Mapped heap -- Offset:0x5d00000, size:0xa00000, reference count:1, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196261]     Mapped heap -- Offset:0x5300000, size:0xa00000, reference count:1, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196264]     Mapped heap -- Offset:0x3800000, size:0x1b00000, reference count:1, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196267]     Mapped heap -- Offset:0x1d00000, size:0x1b00000, reference count:1, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196270]     Mapped heap -- Offset:0x200000, size:0x1b00000, reference count:1, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196273]     Mapped heap -- Offset:0x0, size:0x200000, reference count:2, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196277]     Mapped heap -- Offset:0xef000, size:0x11000, reference count:1, mapping count:0,
Jul 17 14:22:46 x2 kernel: [146148.196286] GRBM : 0x3828, SRBM : 0x20000ac0 .
Jul 17 14:22:46 x2 kernel: [146148.196290] CP_RB_BASE : 0x401000, CP_RB_RPTR : 0x18580 , CP_RB_WPTR :0x18580.
Jul 17 14:22:46 x2 kernel: [146148.196295] CP_IB1_BUFSZ:0x0, CP_IB1_BASE_HI:0x0, CP_IB1_BASE_LO:0x40647000.
Jul 17 14:22:46 x2 kernel: [146148.196298] last submit IB buffer -- MC :0x40647000,phys:0x5e7814000.
Jul 17 14:22:46 x2 kernel: [146148.196301] Dump the trace queue.
Jul 17 14:22:46 x2 kernel: [146148.196303] End of dump