Bug 244 - Heroes of Newerth poor performance
: Heroes of Newerth poor performance
Status: CLOSED WONTFIX
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: OpenGL Driver
: .archived
: Radeon HD 4000 Series Linux
: low normal
Assigned To: nobody
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-27 17:28 CDT by Roman Šmakal
Modified: 2012-02-02 18:29 CST (History)
5 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Šmakal 2011-08-27 17:28:15 CDT
Description of problem: 
Heroes of Newerth has poor framerate when using fglrx driver. No matter which details are set up, FPS keep going between 15~30 on HD4670 - thats just bad. Aspect of details settings on performance is minimal.

Steps to reproduce:
1. Get Heroes of Newerth (its Free to Play now)
2. Create a new practice game
3. Pick a hero, wait for the game to load
4. Write host_drawfps 1 into console (Ctrl + Shift + F8)
5. Try to change details - none or minimal framerate changes

Actual result: 
15~30 FPS
Expected result: 
The card should made around 60 ~ 100 FPS without any problems. Something is broken.
Comment 1 Roman Šmakal 2011-08-28 04:59:44 CDT
Just for information, its not caused by only this actual driver version at all. Its long-term bug, but i just got annoyed enough right now to submit him into bugzilla :)
Comment 2 qaridarium 2011-08-28 09:41:44 CDT
hi i do have the same problem it runs on 29fps all the time but if there is a Firefox+flash open with gpu acceleration it drops to less than 20fps and i do have massive mouse input lag. 

right now i use a phenomII B50 X4 @3,8ghz with an hd4670 

maybe it should do more than 30fps...
Comment 3 qaridarium 2011-09-14 16:16:55 CDT
i do more testing

a hd4850 with an phenom II x4@3,8ghz makes only 22fps... 

the windows version in wine makes more than 60fps with a much better graphic output.

Other interesting responses: 

ZedDB:
"With my 4870 card I had 120 fps in the menus (max) and around 60-90 fps ingame. But after the drivers upped the opengl support from 2.1 to ~3.3 i get 60fps in the menus and ~30fps ingame and the game shutters/laggs (has mini pauses) like crazy." 


Ungweliante:
"Until fglrx 10.4, the performance was correct.[...]
When I installed fglrx 10.5 the performance became abysmal. It was so bad that I quit playing HoN for long time. I kept it installed, and tried it sometimes with the new driver versions. After some months, I was able to play again with minimum settings.[...] I had to install windows 7 [...]It was incredible. The default graphics were gorgeous in comparison, and the first game I played I found that the game was so fast that I always "overreacted". I was acting everytime too early, I was missing my Linux lag!!!![...]
[...linuxclind] HoN in a Radeon 4670 is not playable even at minimum settings without any 3D desktop."

xpander:
"like i said before i dont have those problems with 5770"
Comment 4 pierre.boudier@amd.com 2011-09-14 16:45:29 CDT
hi,

I have some questions:

" I had to install windows 7 [...]It was incredible. The
default graphics were gorgeous in comparison"
- are you sure that you run the proprietary driver and not the open source ?
(the opengl driver code is 95% shared with windows...)


"the windows version in wine makes more than 60fps with a much better graphic
output."
-> are you saying that a linux native version is much worse than the windows version running through wine on linux ? if that is the case, then the issue seems to be with the game itself and not the gfx driver. (wine will eventually use opengl too)
Comment 5 Ungweliante 2011-09-14 17:16:12 CDT
Hello, I am the same Ungweliante in Phoronix forums.

To Pierre Boudier:

Yes sir, I am completely sure I am using fglrx drivers. The game was not playable with the free drivers.

The game plays much faster with wine, because it uses a diferent render engine. It uses a Direct3D render engine that is translated to OpenGL with wine. Heroes of Newerth's OpenGL render is worse than its Direct3D engine.

But it became MUCH worse in the 10.4 to 10.5 fglrx transition.

Best regards.
Comment 6 pierre.boudier@amd.com 2011-09-14 18:03:26 CDT
ok. so there is not much we can do about the game renderer being much worse in the native version compared to the windows version, but we can look at the reported perf regression.
Comment 7 qaridarium 2011-09-15 04:45:27 CDT
LOL  i wondering about the possibility to understand something wrong.

@pierre.boudier@amd.com

about: "- are you sure that you run the proprietary driver and not the open source ? (the opengl driver code is 95% shared with windows...)"

the default in windows is the directX renderer and not the openGL renderer.
means the comparison is openGL on nativ linux compared to directX nativ windows. 

about: "are you saying that a linux native version is much worse than the windows
version running through wine on linux ? if that is the case, then the issue
seems to be with the game itself and not the gfx driver. (wine will eventually
use opengl too)"

and again the default for windows is directX  means its windows-version-on-wine-with-directX against the nativ linux version. And yes the windows version with directX makes a much better graphik output and much more fps.

its just a check that it is a openGL 2.1 problem because wine translate the directX code into an openGL3.2 code and the orginal HON openGL renderer is openGL2.1
Comment 8 qaridarium 2011-09-15 04:57:08 CDT
some points are not the full true:

"The game plays much faster with wine, because it uses a diferent render engine.
It uses a Direct3D render engine that is translated to OpenGL with wine. Heroes
of Newerth's OpenGL render is worse than its Direct3D engine."

do you know that wine can make 2 different kind of openGL translations.
wine can do a slow shader translator based ogl2.1 and a very fast wine openGL extension based openGL3.2 one. 
the original HON engine was openGL2.1  and wine translate the HON directX engine into an OpenGL3.2 code. 

so the performance regression is a OpenGL2.1 problem and not a OpenGL3 problem.
because on openGL3 it makes full speed and on OpenGL2.1 it slow down very hard. 


"But it became MUCH worse in the 10.4 to 10.5 fglrx transition."

the OpenGL2.1 regression is there  10.4->10.5


"ok. so there is not much we can do about the game renderer being much worse in
the native version compared to the windows version, but we can look at the
reported perf regression."

amd can do much more.  sure they can find the openGL2.1 regression in 10.4->10.5 but they can do more.

wine have the ability to translate directX9 code into openGL3.2 code and in the fall of hon it is so much better in graphic and speed amd should cooperate with S2-games to put an additional second openGL renderer in the native hon clind based on the wine translation output.

this should very cheap and will bring a great impact. 

AMD spend money in wine to build the directX->OpenGL translator its now the time to earn the improvements!
Comment 9 Ungweliante 2011-09-15 05:08:17 CDT
Hello,

let´s forget about wine, as this is an AMD bugzilla.

Heroes of Newerth, native Linux client.

It had a decent performance with fglrx 10.4.

I upgrade to fglrx 10.5, the performance was abysmal.

In that version change, there seems to be a regression for fglrx in radeons 4xxx.


Best regards.
Comment 10 qaridarium 2011-09-15 05:34:40 CDT
(In reply to comment #9)
> Hello,
> let´s forget about wine, as this is an AMD bugzilla.
> Heroes of Newerth, native Linux client.
> It had a decent performance with fglrx 10.4.
> I upgrade to fglrx 10.5, the performance was abysmal.
> In that version change, there seems to be a regression for fglrx in radeons
> 4xxx.
> Best regards.

amd spend money on the wine renderer why not use it to ad an additional openGL3 renderer based on the dx9->ogl output of wine? 

this should be very cheap to dev and will bring a great performance impact.
Comment 11 Ungweliante 2011-09-15 06:15:31 CDT
Man, this is a bugzilla, an interface to report bugs.

Your suggestions will be unheard here, and will make more complicated to work on this bug.
Comment 12 qaridarium 2011-09-15 08:01:19 CDT
(In reply to comment #11)
> Man, this is a bugzilla, an interface to report bugs.
> Your suggestions will be unheard here, and will make more complicated to work
> on this bug.

In the past amd heard my suggestions. 

Its not the place how makes a suggestion good its the power of the impact if the suggestion come true what makes a suggestion good.

Many Linux people play hon and amd will profit if they care about a good renderer for the Linux version.
Comment 13 Xpander 2011-09-15 11:52:58 CDT
yeah, confirming that i dont have those performance problems with ati hd 5770
catalyst drivers i have used are 11.4 to 11.8. kernel 2.6.37 - 3.0.4
it seems more likely some problem with previous generation hardware. like 4xxx series. anyone else with newer gpus that can comment it?
Comment 14 amigo_zhen 2011-09-15 23:48:30 CDT
I met a strange problem while installation: 

root@RD790:~/Desktop# sh HoNClient-2.1.8.1.sh 
199096+0 records in
388+1 records out
199096 bytes (199 kB) copied, 0.056828 s, 3.5 MB/s



PANIC
  Initial setup failed. Cannot continue.

===========
I see the same issue is frequently mentioned in the HON or Ubuntu forum.
What game version and OS do you use? I will try them later. Thanks.

p.s: fglrx 10.4/10.5. Do you mean the Catalyst 10.4/10.5(I see you found the regression between them, but the drivers are out of date. How about the latest?)?
Comment 15 Roman Šmakal 2011-09-16 02:48:06 CDT
I have Ubuntu Natty (KDE) and game is slow even with latest drivers. Catalyst 10.4 is propably a version where regression started.
Try to re-download installer and run it as non-root user.
Comment 16 qaridarium 2011-09-16 06:05:10 CDT
@amigo_zhen you don't have to install it you also can just unpack the game file and start it directly.  also the regression found on 10.4->10.5 means the last 10.8 catalyst also contain the regression. It makes no sense to report a bug that is not there in the last version...

i think you also can use the windows version in wine and use the openGL renderer it should show the same regression. because same openGL code is used.
Comment 17 Ungweliante 2011-09-16 06:19:09 CDT
Please, be careful with the driver versions.

The big drop in performance was between 10.4 and 10.5

This is MORE THAN ONE YEAR AGO.

The actual version is 11.8.

I can´t compare the performance between 11.8 and 10.5, but both are way behind 10.4

Best regards.
Comment 18 Ungweliante 2011-09-16 06:21:11 CDT
Maybe we should move the discussion back to the Phoronix forum thread
Comment 19 Michael Cronenworth 2012-01-26 23:52:53 CST
This message is a reminder that your bug is marked as Catalyst 11.7.

The current Catalyst version is 12.1.

Approximately 7 days from now the Bugzilla administrator will be removing the
11.7 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla
administrator provides this as a unofficial, free service to AMD customers, and
I like to keep my systems neat and tidy. If you would like to keep your bug
from being closed, please try a new Catalyst version and update the 'version'
field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will
change it for you.
Comment 20 Ungweliante 2012-01-29 16:07:27 CST
Hello, I rechecked the game with the latest fglrx driver versions.

I've got improved performance with the following versions:

Heroes of Newerth 2.5 ( Latest )
Fglrx 11-11
System Debian SID x64 updated ( Kernel 3.1 )

Tt could've improved in previous versions, they were not tested.

With the latest versions today, it is running correctly too. 

Heroes of Newerth 2.5.8.1 ( Latest )
Fglrx 12-1
System Debian SID x64 updated ( Kernel 3.2 )

Even though the performance improved it is not stellar at all. But it may be similar to the one I got with 10.4 before the performance dive.

It doesn't go much over 30 FPS but it is somewhat playable.
Comment 21 Michael Cronenworth 2012-02-02 18:28:46 CST
This bug is being closed due to the 'version' being 11.7 after 7 days of the
previous closure notice.

Thank you for your bug report.