Bug 276 - (WW) PowerXpress feature is not supported on A+I Mux platform. Please uninstall fglrx driver.
: (WW) PowerXpress feature is not supported on A+I Mux platform. Please uninsta...
Status: CLOSED WONTFIX
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: X11 Driver
: .archived
: All Linux
: low normal
Assigned To: nobody
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-30 02:10 CDT by ryan.beasley
Modified: 2014-03-31 12:13 CDT (History)
17 users (show)



Attachments
X log (8.02 KB, application/x-trash)
2011-09-30 02:10 CDT, ryan.beasley
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ryan.beasley 2011-09-30 02:10:28 CDT
Created attachment 245 [details]
X log

Description of problem: Summary says it all, I think.  Not here to whine, but this is the closest to an "official channel" I can find for saying, "Hey, there _are_ users asking for this."

Steps to reproduce:
1. Get a laptop with the ATI/AMD+Intel hybrid graphics, such as a HP Envy 17 2070-NR.  Mine has a Radeon HD6850M.
2. Install the latest Catalyst (11.9) drivers.
3. Try to start the X server.

Actual result:
- X server fails to launch.
- X log indicates that hybrid graphics (still?) aren't supported.
[    24.264] (WW) PowerXpress feature is not supported on A+I Mux platform. Please uninstall fglrx driver.
[    24.264] (EE) No devices detected.
[    24.264]
Fatal server error:
[    24.264] no screens found
[    24.264]

Expected result: 
- X server launches.  ;)
Comment 1 sauthess 2011-10-03 02:38:19 CDT
Good morning,


Same here with HP dm4-1162sf with Radeon HD 5470 + core i5.

11.8 version works on the same hardware.

same request as the initial post : X server launches.  ;)
Comment 2 Mircha Emanuel D'Angelo 2011-10-03 05:45:46 CDT
The same on my HP G62 with ATI RADEON HD 5400 and Intel.

Needed to back on ati driver 11.8
Comment 3 Fernando 2011-10-08 16:30:24 CDT
Same problem on Lenovo Y560 - i5 - ATI Radeon HD 5730 

The ati drivers never worked for me. The fan cooler is always running.
Comment 4 John Freed 2011-10-27 04:34:11 CDT
Trying to understand why this is classified as a "normal" bug. It is, at the very least, "critical" as defined by this site. 

To be clear, it makes X crash, so that there is NO display at all. It prevents X from falling back to load other drivers. It is, therefore, critical -- that is, it causes "crashes, loss of data, severe memory leak".
Comment 5 sauthess 2011-11-01 06:10:09 CDT
Hi all,

Agree with John Freed, just try 11.10 from http://www.pcinpact.com/link.php?url=http%3A%2F%2Fwww2.ati.com%2Fdrivers%2Flinux%2Fati-driver-installer-11-10-x86.x86_64.run

Always the same result...

It seams that ATI do not support their products more that 1 year... (I bought this laptop on march....). The strange thing is that this laptop was only supported 2 month (from 11.6 to 11.8 drivers versions...)

Looking for a solution to hide Intel chipset by software solution as my bios do not offers this solution....

One sure thing, I will never buy other ATI based laptop if AMD/ATI don't support linux platforms correctly (as I only use Linux....).

If someone have an idea to hide intel chipset using linux configuration, I'll thank him a lot !

BR,
Comment 6 msmechanized 2011-11-16 11:21:59 CST
Since i had not seen that bug, i posted the same one in this url

http://ati.cchtml.com/show_bug.cgi?id=331

come on AMD we know u can support this.
Comment 7 msmechanized 2011-11-16 11:23:03 CST
> 
> One sure thing, I will never buy other ATI based laptop if AMD/ATI don't
> support linux platforms correctly (as I only use Linux....).
> 
> If someone have an idea to hide intel chipset using linux configuration, I'll
> thank him a lot !
> 
> BR,

BTW nvidia said they would not support their optimus==hybrid graphics technology on linux, so there is not really a choice right now..
Comment 8 sauthess 2011-11-16 12:48:19 CST
Hi,

BTW nvidia said they would not support their optimus==hybrid graphics
technology on linux, so there is not really a choice right now..
-> I didn't know as I focus on my actual AMD/intel laptop...
ok, so let's say that linux users do not have solution as majority of corrects laptop are in this case...(hybrid AMD or NVIDIA ...)
I want to be able to save power when working and play when I want, it's not a big request I think...(as the technicals solutions exists...)
Comment 9 msmechanized 2011-11-18 06:21:41 CST
This is still not fixed with the 11.11 driver.Has anyone else tried with the new driver?
Comment 10 John Freed 2011-11-18 09:03:32 CST
(In reply to comment #9)
> This is still not fixed with the 11.11 driver.Has anyone else tried with the
> new driver?

Agreed, still not fixed with 11.11
Comment 11 Xiaozhe Wang 2011-11-24 23:48:17 CST
The same on my Alienware M17xR3, sigh...

Alienware M17xR3 i7 2720QM with AMD Radeon HD 6990M
Comment 12 msmechanized 2011-12-13 19:03:12 CST
Is this fixed with the version 11.12?
Comment 13 John Freed 2011-12-14 02:20:41 CST
I have, with great difficulty, got the Intel (i915) and Radeon (radeon) open-source drivers working together on my HP G72. These two pages helped a lot:
https://launchpad.net/~hybrid-graphics-linux
https://help.ubuntu.com/community/HybridGraphics

Short version: I had to remove the "quiet rhgb" parameters from the boot line.
More experimenting and longer version to come.

Computer, which was frequently exceeding 90 degrees C and shutting down, now runs normally at 45-50 degrees, or 55-60 using the ATI card. So far so good.
Comment 14 sauthess 2011-12-14 14:05:36 CST
just tried 11.12 on ubuntu 11.10 and always the same message....

Hopes disapears from month to month with new releases that never solve this bug....
Comment 15 John Freed 2011-12-15 08:50:10 CST
(In reply to comment #13)
> I have, with great difficulty, got the Intel (i915) and Radeon (radeon)
> open-source drivers working together on my HP G72. These two pages helped a
> lot:
> https://launchpad.net/~hybrid-graphics-linux
> https://help.ubuntu.com/community/HybridGraphics
> 
> Short version: I had to remove the "quiet rhgb" parameters from the boot line.
> More experimenting and longer version to come.
> 
> Computer, which was frequently exceeding 90 degrees C and shutting down, now
> runs normally at 45-50 degrees, or 55-60 using the ATI card. So far so good.

FYI, here are the key parameters on my machine:

REMOVE: rhgb quiet
MANDATORY ADD: i915.i915_enable_fbc=1 i915.i915_enable_rc6=1 video.allow_duplicates=1
OPTIONAL, to save power: i915.lvds_downclock=1 radeon.dynclks=1
NOT needed, on my machine, but others report as useful: acpi_osi=Linux pcie_aspm=force
Comment 16 John Freed 2011-12-28 13:47:42 CST
It appears that ATI is now marketing a version 4.0 of the Radeon cards that is "muxless" and that Catalyst has not supported the "A+I Mux" version since 11.8

This would indicate that we have three choices:
1) Downgrade to Catalyst 11.8
2) Remove Catalyst. If you choose that option, be sure to reinstall Mesa, as Catalyst stomps all over it and makes it unusable if you don't have the proprietary driver.
3) Buy a version 4.0 "muxless" graphics card.

I have chosen Option 2. See my Comment #15 above for details.
Comment 17 John Freed 2011-12-28 13:51:05 CST
(In reply to comment #16)
> It appears that ATI is now marketing a version 4.0 of the Radeon cards that is
> "muxless" and that Catalyst has not supported the "A+I Mux" version since 11.8
> 
> This would indicate that we have three choices:
> 1) Downgrade to Catalyst 11.8
> 2) Remove Catalyst. If you choose that option, be sure to reinstall Mesa, as
> Catalyst stomps all over it and makes it unusable if you don't have the
> proprietary driver.
> 3) Buy a version 4.0 "muxless" graphics card.
> 
> I have chosen Option 2. See my Comment #15 above for details.

See this page for info on reinstalling Mesa:
https://wiki.ubuntu.com/X/Troubleshooting/FglrxInteferesWithRadeonDriver
Comment 18 msmechanized 2012-01-26 13:10:07 CST
Guys, what about the 12.1 driver, has anyone tried it yet?
Comment 19 sauthess 2012-01-26 14:16:25 CST
Hi all,

Just tested 12.1 on ubuntu 11.10 : same log appears...

AMD, can you please take a look at this problem ?

Thanks,

BR,
Comment 20 pierre.boudier@amd.com 2012-01-27 05:15:51 CST
We understand the desire for this feature but it is problematic on Linux. 

You can disable the intel gpu in the bios, and your system should work with the amd hardware. 

The amd gpu has tons of power saving technique which should kick in, and power express is not always a good thing (for instance, we had issues with apps not working in intel driver because of the difference in OpenGL core versions or extensions...).
Comment 21 sauthess 2012-01-27 05:57:24 CST
Hello Pierre,

First of all, I think you can't imagine how I appreciate your feedback. From few month I was imagining that nobody at ATI/AMD side listen to us. So thanks a lot.

The problem is : If I could disable intel chipset, I will have a solution. but it's not the case on my laptop (no option in bios) so it's blocking for me (and I'm not alone if you take a look on Web).

This switching feature was working  pretty well from 11.6 to 11.8 so I didn't understand (now I'm using 11.8 version on ubuntu 10.04 without major problem). As this works before, it's not an impossible task ;)

I can't use new linux or Xorg versions as from 11.9, your driver refuse to start with my hardware.

I'm worried as I bought this laptop on february 2011 and it isn't supported anymore starting from september...
I use only linux on all my computers (3) and plays games (Linux and Windows ones) that need your GPU (that's why I bought this laptop with AMD GPU at beginning...)

I have tried to disable intel GPU using /sys like this :
echo 0 > /sys/bus/pci/devices/0000:00:02.0/enable
echo 1 > /sys/bus/pci/devices/0000:00:02.0/remove

but this didn't have the same effect as bios one as X refuse to start too (with another error message....) and I didn't found a solution.

If you have a software solution to disable a GPU (even tricky one), share with us, I'm sure that linux users in my case will really appreciate.

I can do all tests you want helping you helping us to solve this issue (on all distribution you want if needed...).

In all case, thanks a new time for your interest.

BR,

Samuel
Comment 22 pierre.boudier@amd.com 2012-01-27 07:16:12 CST
The best mechanism is usually the bios option, since that is way ahead of any OS/driver specific behavior; I just discovered from your feedback that oem may disable the option !

I don't know if there is an easy software workaround yet.
Comment 23 sauthess 2012-01-28 10:53:14 CST
Hello,

As you are aware of this now, is there a chance that I will have a solution in a next release (in all case, I think my comment was usefull ;) )?

I see multiple possibilities :

- AMD/ATI start supporting this hardware as did few month ago (best solution ;))

- a software solution is found to hide intel GPU from linux as it is made by bios 

- an option is added to fglrx to allow starting X even if another gpu is present (by specifying PCIID to use in X conf file for exemple). I do not know if it's technically possible but it's a solution I think. 

BR,
Comment 24 sean.settle 2012-01-28 13:37:57 CST
Similar problem with A8-3530MX with AMD Radeon 6620G and AMD Radeon 6650M, such as an HP Pavilion dv6z-6c00 CTO

I think AMD should definately support switchable graphics like in this kind of system given that it's all AMD components.  This problem exists in the AMD Catalyst Linux and Windows 7 drivers.

Since system builders like HP rarely update their display drivers, and don't provide Linux support, AMD should incorporate this into their official drivers.
Comment 25 John Freed 2012-01-29 05:21:14 CST
I, too, would like to thank Pierre for his reply. I suspect, as I noted in Comment #15, that AMD/ATI is not devoting any further development efforts into the muxed cards, as they have a new generation on the market. (It is irritating that they did briefly support them and then suffered a regression!)

For those like me who lack the BIOS option, the only alternative is the open source driver. The good news is that it is now usable.
Comment 26 Xiaozhe Wang 2012-01-31 03:30:47 CST
(In reply to comment #23)
> Hello,
> 
> As you are aware of this now, is there a chance that I will have a solution in
> a next release (in all case, I think my comment was usefull ;) )?
> 
> I see multiple possibilities :
> 
> - AMD/ATI start supporting this hardware as did few month ago (best solution
> ;))
> 
> - a software solution is found to hide intel GPU from linux as it is made by
> bios 
> 
> - an option is added to fglrx to allow starting X even if another gpu is
> present (by specifying PCIID to use in X conf file for exemple). I do not know
> if it's technically possible but it's a solution I think. 
> 
> BR,

Just found a unlocked BIOS (A08 ver) for Alienware M17x R3, which provides the previous missing video card switching option. The link is:

http://forum.notebookreview.com/alienware-m17x/615105-guide-disabling-m17x-r3-igp.html

I flashed it and disabled IGP, then fglrx works like a charm...

But still, some software ways are needed to make things work on other kinds of laptops.

BTW: @sauthess I saw your older posts here: http://www.mail-archive.com/hybrid-graphics-linux@lists.launchpad.net/msg01799.html , and it seems that you had made things work on ArchLinux by removing IGP pci device? Could you share some details?

On Ubuntu I always got a blank screen when starting X using that method. Blacklisting i915 module didn't help too.
Comment 27 sauthess 2012-01-31 06:42:52 CST
Hi,

Yes succeeded on Arch (the equivalent method do not work on Ubuntu I do not know Why) 

The method used is as follow :
1) install ATI/AD drivers
2) Create a file : /etc/modprobe.d/i915.conf containing "blacklist i915"
3) Modify /etc/mkinitcpio.conf file as follow :
MODULES="fglrx" (you can test with "radeon" module too but it's not my goal...)
4) launchs "mkinitcpio -p linux" to update initrd
5) modify /etc/rc.local file to include :
echo 0 > /sys/bus/pci/devices/0000:00:02.0/enable
echo 1 > /sys/bus/pci/devices/0000:00:02.0/remove
(please modify your pciid depending of your hardware (0000:00:02.0))
6) verify that you have a correct /etc/X11/xorg.conf file (means containing fglrx)
7) reboot
8) on boot add "vga=791" to kernel boot command line (to be able to see the terminal)

This will finish on a terminal, if you put lspci command, you'll see only ATI card, and you'll see these logs when starting X so I think something is missing (/var/log/Xorg.0.log) : 
[   261.706] (II) fglrx(0): Primary V_BIOS segment is: 0xc000
[   261.707] (II) fglrx(0): Invalid ATI BIOS from int10, the adapter is not VGA-enabled
[   261.707] (EE) fglrx(0): Invalid video BIOS signature!
[   261.707] (EE) fglrx(0): GetBIOSParameter failed
[   261.707] (EE) fglrx(0): PreInitAdapter failed
[   261.707] (EE) fglrx(0): PreInit failed
[   261.707] (II) fglrx(0): === [xdl_xs111_atiddxPreInit] === end

When looking on google, this problem is solved on putting discrete card on but it's my problem (I do not have an option to switch in Bios...)

If someone have an idea...
Comment 28 Anton Anikin 2012-03-03 16:09:08 CST
Same problem on HP tm2 laptop
Comment 29 russianneuromancer 2012-03-08 11:38:33 CST
This feature was work half-year ago. Why it's disabled?
Why AMD intentionally make troubles for customers?
Comment 30 sauthess 2012-03-10 04:13:19 CST
Hi all,

Always the same thing with 12.2 version....

Is someone have an idea to solve this ? (Is someone succeeded to disable intel chipset by sofware solution or something else ?)

AMD ? When will you reactivate the working switch that exists on 11.8 version of your driver to solve this problem ? 
As already said : If you have other workaroung (option on fglrx to not verify that my laptop is a mux one or something else...All people in my situation will greatly thank you !)

BR,

Samuel
Comment 31 Hans 2012-04-02 06:57:59 CDT
Any change with the new version?
Comment 32 pierre.boudier@amd.com 2012-04-02 07:10:27 CDT
at this time, the only option is to ask the OEM for a bios which does not remove the option to disable the intel graphics. I understand the inconvenience, but I don't have better news, sorry.
Comment 33 sean.settle 2012-04-02 07:17:06 CDT
(In reply to comment #24)
> Similar problem with A8-3530MX with AMD Radeon 6620G and AMD Radeon 6650M, such
> as an HP Pavilion dv6z-6c00 CTO
> 
> I think AMD should definately support switchable graphics like in this kind of
> system given that it's all AMD components.  This problem exists in the AMD
> Catalyst Linux and Windows 7 drivers.
> 
> Since system builders like HP rarely update their display drivers, and don't
> provide Linux support, AMD should incorporate this into their official drivers.

The most recent AMD Catalyst linux driver 12.3 works pretty well now with my system configuration.  I can switch between igpu and dgpu, however I can't seem to use both the igpu and dgpu concurrently.
Comment 34 sauthess 2012-04-02 08:41:36 CDT
Hi all,

Had hope when reading last comment but it's not working on my configuration (core i5 + ATI 5470)...

Always this f...ing message "not supported on A+I mux platform, please uninstall..."

Hope this will be solved in next month !

thanks in advance !
Comment 35 sean.settle 2012-04-02 08:48:55 CDT
(In reply to comment #34)
> Hi all,
> 
> Had hope when reading last comment but it's not working on my configuration
> (core i5 + ATI 5470)...
> 
> Always this f...ing message "not supported on A+I mux platform, please
> uninstall..."
> 
> Hope this will be solved in next month !
> 
> thanks in advance !

Sorry I got your hopes up.  I think my system just had a little better luck since my cpu and gpus are all from the same vendor.

BTW, what are your current settings in xorg.conf and with aticonfig (--lsa, --pxl, etc.)?
Comment 36 sauthess 2012-04-02 09:02:41 CDT
Hi,

I use 11.8 driver version on ubuntu 10.04 that is the only solution for now. On this, I can easily switch using graphical interface or text command (aticonfig --pxl-dgpu or something like that ;) ). All work well, starting 11.9, this message start to appear...

For newer distribution, no solution at all (I just tested 12.3 on ubuntu 11.10).
So I use only i915 driver (but I can't play windows game...)

This answer the question ?

I'd like to use newer distribution for day-to-day use (including playing games) but can't as I have no working driver...

Hope this will be solved before end of support of ubuntu 10.04...
Comment 37 Michael Cronenworth 2012-04-25 18:19:54 CDT
This message is a reminder that your bug is marked as Catalyst 11.9.

The current Catalyst version is 12.4.

Approximately 7 days from now the Bugzilla administrator will be removing the
11.9 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla
administrator provides this as a unofficial, free service to AMD customers, and
I like to keep my systems neat and tidy. If you would like to keep your bug
from being closed, please try a new Catalyst version and update the 'version'
field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will
change it for you.
Comment 38 Hans 2012-04-26 06:41:18 CDT
Anyone tried with newer kernel versions (3.3)?
Comment 39 sauthess 2012-04-26 17:01:22 CDT
Always the same for me on ubuntu 11.10...(kernel 3.0)

For me it's not kernel related : amd do not support this anymore....
:(

I'll open a new case on 12.4 (I could open 1 one each version since 11.9....)
Comment 40 sauthess 2012-04-26 17:09:19 CDT
New bug opened : http://ati.cchtml.com/show_bug.cgi?id=491
Comment 41 russianneuromancer 2012-04-26 18:15:17 CDT
> I'll open a new case on 12.4
You doesn't need to do that. Just confirm bug with 12.4 is enough.
Comment 42 pip@iszf.irk.ru 2012-04-27 03:32:09 CDT
(In reply to comment #41)
> > I'll open a new case on 12.4
> You doesn't need to do that. Just confirm bug with 12.4 is enough.

Just to confirm that the problem exist with 12.4, on Ubuntu 12.04 and Mageia 2
platforms, Laptop HP ENVY 1210NR, A+I mux (Redwood (DIS) and Intel (IGD) graphic cards). Same  as other said: after installation, configuring and reboot, Xorg stops with:
"PowerXpress feature is not supported on A+I Mux platform.
Please uninstall fglrx driver."

I appreciate the AMD contribution to the free ATI drivers, but I could not  use 3d capabilities of radeon (xorg 7.6, mesa-8.0.2) when I switch to discrete graphic cards using vga_switcheroo. Moreover, I found that the 2D perfomance of intel card(integrated) is much better than for radeon.
Comment 43 pip@iszf.irk.ru 2012-04-27 03:34:22 CDT
(In reply to comment #38)
> Anyone tried with newer kernel versions (3.3)?

Yes, I tried 12.4 on 3.3.1 on Mageia. Does not work!
Comment 44 pip@iszf.irk.ru 2012-04-27 03:53:25 CDT
(In reply to comment #38)
> Anyone tried with newer kernel versions (3.3)?

Yes, I tried 12.4 on 3.3.1 on Mageia. Does not work!
Comment 45 Michael Cronenworth 2012-05-04 00:44:51 CDT
*** Bug 491 has been marked as a duplicate of this bug. ***
Comment 46 Michael Cronenworth 2012-05-04 00:54:04 CDT
*** Bug 331 has been marked as a duplicate of this bug. ***
Comment 47 sauthess 2012-06-02 10:35:06 CDT
The last version of driver is 12.4... We are June, 2nd...Can we expect a major version with this problem solved ?

Is someone at ATI/AMD listening us or this bug report is just to be able to say : we support linux users....

I no longer have patience to wait that this laptop will be supported as it should be... (more than one year that I try to have simply that I have bought : a working computer !)

Thanks AMD/ATI to react to complaints of your CST...

BR,
Comment 48 fritzler 2012-06-17 15:39:40 CDT
12.6 beta does not work :-(

now, i sell my Envy 14.  i don't want to wait longer.
Comment 49 sauthess 2012-06-18 10:22:56 CDT
Hi, 

Same here (HP dm4-1162sf sold...)

I've bought an optimus enabled laptop and all work perfectly in 3 hours.

Sorry to say that but it's a reality : if you want linux enabled laptop, go away from ATI laptops
Comment 50 fritzler 2012-06-20 13:35:51 CDT
> I've bought an optimus enabled laptop and all work perfectly in 3 hours.

Nvidia Optimus? Nvidia's proprietary driver does not supported Optimus yet. And Nvidia has no plans to do this in the future.

how does the Nvidia card work in your computer?

sorry for my english, it's not very good :-(
Comment 51 sauthess 2012-06-26 00:37:52 CDT
Hi,

You're right Nvidia does not support optimus but at least some good people made a working solution (bumblebee).

As far as I know, we do not have chance with this kind of laptop...
ATI/AMD support switch expect for mux laptop...

Anyway, I sold my old non working one...

BR,
Comment 52 pgerard 2012-06-26 00:50:16 CDT
Same with an HP Pavillon dv6 (intel core i5 - ATI Mobility Radeon Premium Graphics).
It's hard to always search what we have to buy :-(((
Comment 53 fritzler 2012-06-29 14:40:39 CDT
12.6 release does not work...

12.7 beta ist here, but not for Linux.
Comment 54 jay4evr 2012-07-19 15:20:12 CDT
I just wanted to echo the problems brought up here.  I have an HP Envy 17 3D model 2100.  It's a great machine - but no ATI 3D graphics with fglrx in Linux.  There are no BIOS options at all, and it's either all open source Intel drivers, or, well nothing.  It's a shame that such a nice laptop with the Excellent AMD 6850m inside can't take advantage of it in my preferred OS...

Please consider re-enabling the code that allowed this to work.

Thank you!

Jason
Comment 55 jay4evr 2012-07-19 15:22:05 CDT
Also, I can confirm that the bug still remains in 12.6.
Comment 56 Hans 2012-07-19 15:23:23 CDT
Bad AMD/ATI is bad. After many months, result: nothing.
Comment 57 solax 2012-09-05 07:01:31 CDT
Same problem on HP DV6 3322. I'll never buy another AMD/ATI product in the future, neither I'll suggest to buy to anybody.

Thank you AMD/ATI.
Comment 58 pip@iszf.irk.ru 2012-09-10 21:37:41 CDT
(In reply to comment #54)
> I just wanted to echo the problems brought up here.  I have an HP Envy 17 3D
> model 2100.  It's a great machine - but no ATI 3D graphics with fglrx in Linux.
>  There are no BIOS options at all, and it's either all open source Intel
> drivers, or, well nothing.  It's a shame that such a nice laptop with the
> Excellent AMD 6850m inside can't take advantage of it in my preferred OS...
> 
> Please consider re-enabling the code that allowed this to work.
> 
> Thank you!
> 
> Jason
It would be fair to say that in this case the problem is due to HP. Look at the comment 32. I have similar laptop  hp envy 1210nr. The problem is that HP remove the switch from the BIOS. They care mostly about  windows users. If windows users
have problem they could restore it see: http://h30434.www3.hp.com/t5/Notebook-Display-and-Video/Official-HP-statement-on-Switchable-Graphics-and-Open-GL/td-p/766285
Comment 59 pip@iszf.irk.ru 2012-10-25 09:06:24 CDT
It seems there is some progress with A+I Mux, at least for my card.
 which is : 01:00.0 VGA compatible controller: ATI Technologies Inc Madison [Radeon HD 5000M Series] (rev ff)

I'm running mageia 3 xorg1.13 and kernel3.6.3 and got the following log:
and the latest fglrx.


X.Org X Server 1.13.0
Release Date: 2012-09-05
[    25.807] X Protocol Version 11, Revision 0
[    25.807] Build Operating System: Linux_3.3.8-server-2.mga2 Mageia
[    25.807] Current Operating System: Linux redwood 3.6.3-desktop-1.mga3 #1 SMP Sun Oct 21 18:03:16 UTC 2012 x86_64
[    25.807] Kernel command line: BOOT_IMAGE=linux root=/dev/sda6 splash quiet resume=UUID=38e58e8e-e72c-4e11-b081-b9b77c01905a vga=788
[    25.807] Build Date: 07 October 2012  10:55:13AM
[    25.807]  
[    25.807] Current version of pixman: 0.27.2
[    25.807]    Before reporting problems, check http://bugs.mageia.org
        to make sure that you have the latest version.
[    25.807] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    25.807] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Oct 25 16:24:42 2012
[    25.823] (==) Using config file: "/etc/X11/xorg.conf"
[    25.823] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    26.009] (==) ServerLayout "aticonfig Layout"
[    26.009] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[    26.009] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
[    26.009] (**) |   |-->Device "aticonfig-Device[0]-0"
[    26.009] (==) Automatically adding devices
[    26.009] (==) Automatically enabling devices
[    26.009] (==) Automatically adding GPU devices
[    26.081] (==) FontPath set to:
        catalogue:/etc/X11/fontpath.d
[    26.081] (==) ModulePath set to "/usr/lib64/xorg/extra-modules,/usr/lib64/xorg/modules"
[    26.081] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[    26.081] (II) Loader magic: 0x7fec40
[    26.081] (II) Module ABI versions:
[    26.081]    X.Org ANSI C Emulation: 0.4
[    26.081]    X.Org Video Driver: 13.0
[    26.081]    X.Org XInput driver : 18.0
[    26.081]    X.Org Server Extension : 7.0
[    26.081] (II) config/udev: Adding drm device (/dev/dri/card0)
[    26.082] (--) PCI:*(0:0:2:0) 8086:0046:103c:1436 rev 2, Mem @ 0xc0000000/4194304, 0xb0000000/268435456, I/O @ 0x00004050/8
[    26.082] (--) PCI: (0:1:0:0) 1002:68c1:103c:1436 rev 0, Mem @ 0xa0000000/268435456, 0xc4400000/131072, I/O @ 0x00003000/256, BIOS @ 0x????????/1310
72
,,,,,
[    26.082] (II) Open ACPI successful (/var/run/acpid.socket)
[    26.340] Initializing built-in extension Generic Event Extension
[    26.340] Initializing built-in extension SHAPE
[    26.340] Initializing built-in extension MIT-SHM
[    26.340] Initializing built-in extension XInputExtension
[    26.340] Initializing built-in extension XTEST
[    26.340] Initializing built-in extension BIG-REQUESTS
[    26.340] Initializing built-in extension SYNC
[    26.340] Initializing built-in extension XKEYBOARD
[    26.340] Initializing built-in extension XC-MISC
[    26.340] Initializing built-in extension SECURITY
[    26.340] Initializing built-in extension XINERAMA
[    26.340] Initializing built-in extension XFIXES
[    26.340] Initializing built-in extension XFree86-Bigfont
[    26.340] Initializing built-in extension RENDER
[    26.340] Initializing built-in extension RANDR
[    26.340] Initializing built-in extension COMPOSITE
[    26.340] Initializing built-in extension DAMAGE
[    26.340] Initializing built-in extension MIT-SCREEN-SAVER
[    26.340] Initializing built-in extension DOUBLE-BUFFER
[    26.340] Initializing built-in extension RECORD
[    26.340] Initializing built-in extension DPMS
[    26.340] Initializing built-in extension X-Resource
[    26.340] Initializing built-in extension XVideo
[    26.340] Initializing built-in extension XVideo-MotionCompensation
[    26.340] Initializing built-in extension XFree86-VidModeExtension
[    26.340] Initializing built-in extension XFree86-DGA
[    26.340] Initializing built-in extension XFree86-DRI
[    26.340] Initializing built-in extension DRI2
[    26.340] (II) "glx" will be loaded by default.
[    26.340] (II) LoadModule: "glx"
[    26.381] (II) Loading /usr/lib64/xorg/extra-modules/libglx.so
[    26.475] (II) Module glx: vendor="Advanced Micro Devices, Inc."
[    26.475]    compiled for 6.9.0, module version = 1.0.0
[    26.476] Loading extension GLX
[    26.476] (II) LoadModule: "fglrx"
[    26.722] (II) Loading /usr/lib64/xorg/modules/drivers/fglrx_drv.so
[    27.137] (EE) Failed to load /usr/lib64/xorg/modules/drivers/fglrx_drv.so: /usr/lib64/xorg/modules/drivers/fglrx_drv.so: undefined symbol: noXFree8
6DRIExtension
[    27.137] (II) UnloadModule: "fglrx"
[    27.137] (II) Unloading fglrx
[    27.137] (EE) Failed to load module "fglrx" (loader failed, 7)
[    27.137] (EE) No drivers available.
[    27.137] 
Fatal server error:
[    27.137] no screens found
[    27.137] (EE)

I wounder if someone from AMD team could comment this.
Thanks!
Comment 60 Frederic Van Espen 2012-12-09 05:58:51 CST
I would like to hear some comments by AMD on the above as well.

I have a one year old laptop: Alienware M17xR3 with a Radeon HD6990m.

I am unable to use a recent fglrx driver with this recent card without installing an alienware unsupported BIOS mod. This BIOS mod allows me to disable the integrated GPU, but then I cannot use switchable graphics.

This worked fine in catalyst 11.8, but with the 12.4 driver currently in Debian Wheezy you are forced to disable the integrate GPU.

I think it's in AMD's best interest to fix this since gaming on linux is becoming increasingly popular now that some vendors are starting to support linux clients (e.g. Steam, IndieCity, Desura).
Comment 61 Hans 2013-02-18 14:49:53 CST
Anything new?
Nvidia and Intel are improving their drivers... Where is AMD?
Comment 62 pip@iszf.irk.ru 2013-02-19 02:10:19 CST
It's getting worse for free driver in the new kernel 3.8.0. I can not use vga_switcheroo any more. Only integrated card by Intel is usable. I get black screen after switching to AMD card. So, no dislpay port, laptop is useless for presentations,etc. Iventors of powerxpress should go to hell!
Comment 63 Michael Cronenworth 2013-04-24 22:57:23 CDT
This message is a reminder that your bug is marked as Catalyst 12.4.

The current Catalyst version is 13.4.

Approximately 7 days from now the Bugzilla administrator will be removing the 12.4 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla administrator provides this as a unofficial, free service to AMD customers, and I like to keep my systems neat and tidy. If you would like to keep your bug from being closed, please try a new Catalyst version and update the 'version' field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will change it for you.
Comment 64 pip@iszf.irk.ru 2013-04-25 00:03:52 CDT
(In reply to comment #63)
> This message is a reminder that your bug is marked as Catalyst 12.4.
> 
> The current Catalyst version is 13.4.
> 
> Approximately 7 days from now the Bugzilla administrator will be removing
> the 12.4 version. At that time your bug will be CLOSED as WONTFIX.
> 
> Bug Reporter: Thank you for reporting this issue. However, the Bugzilla
> administrator provides this as a unofficial, free service to AMD customers,
> and I like to keep my systems neat and tidy. If you would like to keep your
> bug from being closed, please try a new Catalyst version and update the
> 'version' field if the issue still occurs.
> 
> If you are unable to update the version, please make a comment and someone
> will change it for you.

Thank you for the great comment! The person from AMD team have no idea what is
going on with the driver produced by his company. The purpose of this bugzilla is not very clear to me. 
This  should be simple to answer will AMD support powerexpress on HD 5000M or not?
Otherwise you lose the respect, because people lose their money buying non-working things!
Comment 65 Frederic Van Espen 2013-04-27 14:38:43 CDT
Just tested on 13.3 beta driver. Still the same issue. Please update version since I cannot change it.
Comment 66 yannick 2013-08-27 11:37:59 CDT
On 13.8 it's still broken. Is there any chance that PowerXpress gets supported on HD5* systems in the future?

If not, it would be fair to communicate this, so we can stop waiting.
Comment 67 Michael Cronenworth 2014-03-18 23:21:58 CDT
This message is a reminder that your bug is marked as Catalyst 13.4.

The current legacy Catalyst version is 13.1.
The current Catalyst version is 13.12.
The current Catalyst beta version is 14.2.

Approximately 7 days from now the Bugzilla administrator will be removing the 13.4 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla administrator provides this as a unofficial, free service to AMD customers, and I like to keep my systems neat and tidy. If you would like to keep your bug from being closed, please try a new Catalyst version and update the 'version' field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will change it for you.
Comment 68 Michael Cronenworth 2014-03-31 12:12:43 CDT
This bug is being closed due to the 'version' being 13.4 after 13 days of the previous closure notice.

Thank you for your bug report.