Bug 304 - Xorg crashes with SIGSEGV
Summary: Xorg crashes with SIGSEGV
Status: CLOSED WONTFIX
Alias: None
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: X11 Driver (show other bugs)
Version: .archived
Hardware: All Linux
: low normal
Assignee: nobody
URL:
Depends on:
Blocks:
 
Reported: 2011-10-20 17:08 CDT by aaranya+amd
Modified: 2012-05-04 00:56 CDT (History)
0 users



Attachments
ATI system info (353.14 KB, text/plain)
2011-10-20 17:08 CDT, aaranya+amd
Details

Note You need to log in before you can comment on or make changes to this bug.
Description aaranya+amd 2011-10-20 17:08:00 CDT
Created attachment 263 [details]
ATI system info

Description of problem: 
I have a TV hooked up via HDMI to an AMD Zacate setup.  If the TV is turned off and turned on after a while, X has already crashed and dropped back to the gdm screen.

Steps to reproduce:
1. Log into system with TV turned on
2. Turn off TV
3. Turn on TV after a while

Actual result: 

Xorg has crashed and restarted into a garbled screen

Expected result: 

Xorg is still running

Note that if the TV is turned off, fglrx assumes that the DFP1 is turned off and CRT1 is activated, even though there is no other display attached.  It is then able to pick up an erroneous DDC information for CRT1 and switches to a mode that is incompatible with the TV.

Here's a backtrace of the crash:


[433750.962] (II) fglrx(0): Hot-plug event occurs on device: 0:1:0
[437925.453]
Backtrace:
[437925.453] 0: /usr/bin/X (xorg_backtrace+0x26) [0x460576]
[437925.453] 1: /usr/bin/X (0x400000+0x64b8a) [0x464b8a]
[437925.453] 2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7fe94bb80000+0x10060) [0x7fe94bb90060]
[437925.454] 3: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/drivers/fglrx_drv.so (xdl_xs110_FGLRXClientGone+0x182) [0x7fe94849f912]
[437925.454] 4: /usr/bin/X (FreeResourceByType+0x12e) [0x44e4ce]
[437925.454] 5: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/drivers/fglrx_drv.so (xdl_xs110_atiddxExtensionsDisableExclusiveMode+0x45) [0x7fe94849fcc5]
[437925.455] 6: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/drivers/fglrx_drv.so (atiddxExtensionsDisableExclusiveMode+0xd) [0x7fe9483a136d]
[437925.455] 7: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/drivers/fglrx_drv.so (0x7fe948035000+0x4a33f3) [0x7fe9484d83f3]
[437925.456] 8: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/drivers/fglrx_drv.so (swlCfExclusiveModeHandler+0x6f) [0x7fe9484d60af]
[437925.457] 9: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/drivers/fglrx_drv.so (swlCwddeCI+0xf0) [0x7fe9484cfbb0]
[437925.457] 10: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/drivers/fglrx_drv.so (0x7fe948035000+0x46e0eb) [0x7fe9484a30eb]
[437925.458] 11: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/drivers/fglrx_drv.so (0x7fe948035000+0x46b52d) [0x7fe9484a052d]
[437925.458] 12: /usr/bin/X (0x400000+0x2fb89) [0x42fb89]
[437925.458] 13: /usr/bin/X (0x400000+0x232fe) [0x4232fe]
[437925.458] 14: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xed) [0x7fe94aabc30d]
[437925.459] 15: /usr/bin/X (0x400000+0x235ed) [0x4235ed]
[437925.459] Segmentation fault at address 0x18
[437925.459]
Caught signal 11 (Segmentation fault). Server aborting
[437925.459]
Comment 1 Michael Cronenworth 2012-04-25 18:19:40 CDT
This message is a reminder that your bug is marked as Catalyst 11.9.

The current Catalyst version is 12.4.

Approximately 7 days from now the Bugzilla administrator will be removing the
11.9 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla
administrator provides this as a unofficial, free service to AMD customers, and
I like to keep my systems neat and tidy. If you would like to keep your bug
from being closed, please try a new Catalyst version and update the 'version'
field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will
change it for you.
Comment 2 Michael Cronenworth 2012-05-04 00:55:19 CDT
This bug is being closed due to the 'version' being 11.9 after 7 days of the
previous closure notice.

Thank you for your bug report.