Bug 337 - XVideo: mplayer -vo xv; X server crash (Fedora 16)
: XVideo: mplayer -vo xv; X server crash (Fedora 16)
Status: CLOSED FIXED
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: X11 Driver
: .archived
: Radeon HD 5000 Series Linux
: low normal
Assigned To: nobody
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-20 23:32 CST by zanghi2000
Modified: 2013-08-14 11:42 CDT (History)
8 users (show)



Attachments
atisysteminfo-report.txt (481.53 KB, text/plain)
2011-11-20 23:32 CST, zanghi2000
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zanghi2000 2011-11-20 23:32:02 CST
Created attachment 286 [details]
atisysteminfo-report.txt

Description of problem: 
after installing Fedora 16 and Catalyst 11.11 I cannot play video file using xv output, not mplayer, nor vlc or else. 

X server crashes after launched the player and I am back to login screen
fallback mode or gnome3 shell

(xv is fine with xorg-radeon)

Steps to reproduce:
1. install an updated Fedora16, 
2. install catalyst 11.11
3. play a video with command: mplayer -vo xv 

Actual result: the Xorg server crashes

Expected result: the player plays the video
Comment 1 Arne Wörner 2011-12-11 04:04:34 CST
on a amd64 box with fc16 i just tried
  mplayer -vo xvmc ...
and it worked fine until i started secondlife (GL):
vo_xvmc: Found matching surface with id=3231564E on 143 port at 0 adapter
vo_xvmc: Using Xv Adaptor #0 (AMD Radeon AVIVO Video)
vo_xvmc: Port 143 grabed
vo_xvmc: Allocated Direct Context
vo_xvmc: data_blocks allocated
vo_xvmc: mv_blocks allocated
vo_xvmc: Motion Compensation context allocated - 8 surfaces
vo_xvmc: idct=1 unsigned_intra=0
vo_xvmc: looking for OSD support
vo_xvmc: No OSD support for this mode
[VD_FFMPEG] XVMC-accelerated MPEG-2.
*** glibc detected *** mplayer: munmap_chunk(): invalid pointer: 0x00007f7103b4dac8 ***
======= Backtrace: =========
/lib64/libc.so.6(+0x7c2d6)[0x7f71139b72d6]
/usr/lib64/libAMDXvBA.so.1(_ZN3DRI16FreeDrawableInfoEPNS_16LMMDDrawableInfoE+0x25)[0x7f7103c51dc5]
/usr/lib64/libAMDXvBA.so.1(_ZN12VideoPresent6RenderEPK11XvMCSurfacemssttsstti+0x2b0)[0x7f7103c58fd0]
/usr/lib64/libAMDXvBA.so.1(XvMCPutSurface+0xc0)[0x7f7103c5ea70]
mplayer[0x48e12e]
mplayer[0x4903d7]
mplayer(main+0x3ab9)[0x431629]
/lib64/libc.so.6(__libc_start_main+0xed)[0x7f711395c69d]
mplayer[0x431eed]

furthermore the whole box crashes when i play secondlife while i watch a movie with "-vo gl"...

is there any workaround?

-arne
Comment 2 Arne Wörner 2011-12-13 13:18:22 CST
with calalyst 11.12
and vmlinuz-3.1.5-1.fc16.x86_64
`mplayer -vo xv ...` still crashes the Xserver... -arne
Comment 3 Florent 2011-12-24 05:29:28 CST
Is it  be possible to test with -vo xv to see if you've got the same backtrace than in 350 bug (ati.cchtml.com/show_bug.cgi?id=350) ?


To see the backtrace of the xserver, you can open the file :
/var/log/Xorg.0.log.old
Comment 4 Arne Wörner 2011-12-24 12:02:38 CST
on my box Xorg.0.log.old says:
[...]
[   377.429] 0: /usr/bin/Xorg (xorg_backtrace+0x2f) [0x462dff]
[   377.429] 1: /usr/bin/Xorg (0x400000+0x67de6) [0x467de6]
[   377.429] 2: /lib64/libpthread.so.0 (0x3dc4e00000+0xf4f0) [0x3dc4e0f4f0]
[   377.429] 3: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xs111LookupPrivate+0x22) [0x7fe559b14fb2]
[   377.430] 4: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xclLookupPrivate+0xd) [0x7fe5594e301d]
[   377.430] 5: /usr/lib64/xorg/modules/amdxmm.so (X740XvPutImage+0x12e) [0x7fe555c498de]
[   377.430] 6: /usr/bin/Xorg (0x400000+0x9abf0) [0x49abf0]
[   377.430] 7: /usr/lib64/xorg/modules/extensions/libextmod.so (0x7fe55ae37000+0x12750) [0x7fe55ae49750]
[   377.430] 8: /usr/bin/Xorg (0x400000+0x33ae1) [0x433ae1]
[   377.430] 9: /usr/bin/Xorg (0x400000+0x22e15) [0x422e15]
[   377.430] 10: /lib64/libc.so.6 (__libc_start_main+0xed) [0x3dc462169d]
[   377.430] 11: /usr/bin/Xorg (0x400000+0x23101) [0x423101]
[   377.430] Segmentation fault at address 0x20
[   377.430] Fatal server error:
[   377.430] Caught signal 11 (Segmentation fault). Server aborting
[...]

-arne
Comment 5 mhilfiker 2011-12-29 14:16:34 CST
Hello,

Is there any Solution?
I've the same Problem with Kernel 3.1.6-1

Thx
mhilfiker
Comment 6 Florent 2011-12-29 15:18:37 CST
@mhilfiker
you can try using -vo gl (or gl_nosw , ...), but some have trouble running mplayer with -vo gl with others software using gl at the same time.
Comment 7 rrumberger 2011-12-30 12:21:57 CST
(In reply to comment #5)
> Is there any Solution?
> I've the same Problem with Kernel 3.1.6-1

Not a solution but a workaround; add the following snippet to your /etc/X11/xorg.conf, that way the crashy code won't be executed:

Section "Extensions"
        Option "XVideo" "Disable"
EndSection
Comment 8 mhilfiker 2011-12-31 10:44:03 CST
(In reply to comment #7)
> (In reply to comment #5)
> > Is there any Solution?
> > I've the same Problem with Kernel 3.1.6-1
> 
> Not a solution but a workaround; add the following snippet to your
> /etc/X11/xorg.conf, that way the crashy code won't be executed:
> 
> Section "Extensions"
>         Option "XVideo" "Disable"
> EndSection


@rrumberger,

Thx for this workaround. It's working with all "video" application... (VLC etc...)
Comment 9 zanghi2000 2012-01-03 09:18:39 CST
(In reply to comment #0)
> Created attachment 286 [details]
> atisysteminfo-report.txt
> 
> Description of problem: 
> after installing Fedora 16 and Catalyst 11.11 I cannot play video file using xv
> output, not mplayer, nor vlc or else. 
> 
> X server crashes after launched the player and I am back to login screen
> fallback mode or gnome3 shell
> 
> (xv is fine with xorg-radeon)
> 
> Steps to reproduce:
> 1. install an updated Fedora16, 
> 2. install catalyst 11.11
> 3. play a video with command: mplayer -vo xv 
> 
> Actual result: the Xorg server crashes
> 
> Expected result: the player plays the video

I did some tests ... 

fresh install from fedora 16.DVD.x86_64+updates+catalyst 11.12 = Xv crashes the Xorg

fresh install from fedora 16.LiveCD.i686+updates+catalyst 11.12 = Xv WORKS !!! 
it works even mplayer-vaapi (Xvba) (and it's nice!!)

please note that LiveCD is 32 bit <----- 

so bug may depend from x86_64 system or some package from full DVD installation
Comment 10 tr-fglrx-bugs@digital-trauma.de 2012-01-03 16:13:38 CST
https://bugs.gentoo.org/391193
Comment 11 russianneuromancer 2012-03-09 02:28:30 CST
That should be fixed in Catalyst 12.2. Do you try it?
Comment 12 Mark Dominik Bürkle 2012-03-25 02:23:05 CDT
https://bugs.gentoo.org/show_bug.cgi?id=391193 is closed fixed,
works for me with hd6470m: no segfault when playing xv video.
Comment 13 Michael Cronenworth 2012-08-19 11:56:28 CDT
This message is a reminder that your bug is marked as Catalyst 11.12.

The current Catalyst version is 12.8.

Approximately 7 days from now the Bugzilla administrator will be removing the
11.12 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla
administrator provides this as a unofficial, free service to AMD customers, and
I like to keep my systems neat and tidy. If you would like to keep your bug
from being closed, please try a new Catalyst version and update the 'version'
field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will
change it for you.
Comment 14 rrumberger 2012-08-19 12:05:57 CDT
(In reply to comment #13)
> Approximately 7 days from now the Bugzilla administrator will be removing the
> 11.12 version. At that time your bug will be CLOSED as WONTFIX.

This has been fixed and is working well with the 12.6 version, so it should be closed as fixed.