Bug 373 - Major opcode of failed request: 139 (ATIFGLEXTENSION) - Ubuntu Oneiric 11.10 x64
: Major opcode of failed request: 139 (ATIFGLEXTENSION) - Ubuntu Oneiric 11.10...
Status: CLOSED WONTFIX
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: OpenGL Driver
: .archived
: Radeon HD 5000 Series Linux
: low normal
Assigned To: nobody
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-27 11:26 CST by Matthew Von Stetina
Modified: 2012-09-03 20:26 CDT (History)
2 users (show)



Attachments
ATI system info report generated by atigetsysteminfo.sh as requested (14.17 KB, text/plain)
2011-12-27 11:26 CST, Matthew Von Stetina
Details
Kurtis' AtiSystemInfo-Report.txt (7.38 KB, text/plain)
2012-03-01 20:11 CST, Kurtis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Von Stetina 2011-12-27 11:26:26 CST
Created attachment 315 [details]
ATI system info report generated by atigetsysteminfo.sh as requested

Description of problem: 
3D rendering is broken upon installation of Catalyst 11.12 on Ubuntu Oneiric 11.10 x64, but Gnome Classic (no effects) loads correctly, albeit with stuttering when moving windows around the screen.  System in question is an Acer Aspire Ethos AS8943G-9319 laptop w/ ATI Radeon HD5850 2GB.  Error message when trying to run fglrx or glxgears is as follows:

X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  139 (ATIFGLEXTENSION)
  Minor opcode of failed request:  66 ()
  Serial number of failed request:  13
  Current serial number in output stream:  13

Steps to reproduce:
1. Follow directions at http://wiki.cchtml.com/index.php/Ubuntu_Oneiric_Installation_Guide to remove fglrx completely and revert to open source drivers by running the following commands in terminal:
sudo sh /usr/share/ati/fglrx-uninstall.sh
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*
sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon
sudo apt-get install xserver-xorg-video-ati
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
sudo rm -rf /etc/ati

2. Follow directions at same guide to build .deb files and install at the same site by running the following commands in terminal:
sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 dkms libqtgui4 wget execstack libelfg0 dh-modaliases
sudo apt-get install ia32-libs
cd ~/; mkdir catalyst11.12; cd catalyst11.12/
wget http://www2.ati.com/drivers/linux/ati-driver-installer-11-12-x86.x86_64.run
chmod +x ati-driver-installer-11-12-x86.x86_64.run
sudo sh ./ati-driver-installer-11-12-x86.x86_64.run --buildpkg Ubuntu/oneiric
sudo dpkg -i --force-overwrite fglrx*.deb (same result without --force-overwrite)
sudo aticonfig --initial -f

3. Reboot, load Gnome Classic (no effects), open terminal and type any of the following commands:
fglrxinfo
glxinfo
glxgears

Actual result: 
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  139 (ATIFGLEXTENSION)
  Minor opcode of failed request:  66 ()
  Serial number of failed request:  13
  Current serial number in output stream:  13

Expected result: 
The glxgears command should show a small window with 3d rendered animated spinning gears, the other two commands should print out information regarding 3d rendering support on the system.

Workaround:
Uninstall fglrx as described in step one, restart, then open a terminal and run the following command:
sudo apt-get install fglrx-updates

This will (correctly) install Catalyst 11.10 from the Ubuntu restricted repositories and enable full 3d support, yielding the results as described in the Expected result notes above.

Additional notes:
Running the sudo dpkg -i --force-overwrite fglrx*.deb command in step 2 yields the following messages during install:
update-alternatives: using /usr/lib/fglrx/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in auto mode.
update-alternatives: warning: forcing reinstallation of alternative /usr/lib/fglrx/ld.so.conf because link group x86_64-linux-gnu_gl_conf is broken.
update-alternatives: using /usr/lib/fglrx/alt_ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in auto mode.

Also, running /usr/share/fglrx/atigetsysteminfo.sh to generate the output file does not complete and results in this message:
Configuration Report can be found at: /home/valkyri9/atisysteminfo-report.txt
Starting configuration collection ...
ls: cannot access /proc/ati/*/*: No such file or directory

I attached the file that was generated, which may be incomplete as a result.
Comment 1 Matthew Von Stetina 2011-12-27 11:32:43 CST
Correction - In step 1. of description, actual command used was:
sudo apt-get install --reinstall libgl1-mesa-glx:i386 libgl1-mesa-glx:amd64 libgl1-mesa-dri:i386 libgl1-mesa-dri:amd64 xserver-xorg-core

As opposed to this one listed in the description which is not supported by 64-bit Oneiric:
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
Comment 2 Kurtis 2012-03-01 19:59:13 CST
I believe I have the same problem and therefore did not want to create a new bug report. I am using a slightly different Linux Distribution (64-bit LinuxMint 12 KDE) and a different computer (Toshiba Satellite L505D-GS6000 w/ Radeon HD 4200). My Kernel version is 3.0.0-12.

When attempting to run any OpenGL application, I get the same errors. For example:

kurtis@toshiba-laptop ~ $ glxinfo
name of display: :0
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  139 (ATIFGLEXTENSION)
  Minor opcode of failed request:  66 ()
  Serial number of failed request:  13
  Current serial number in output stream:  13

I followed Matthew's Step #1 (with the correction noted in his comment) and was successfully able to use OpenGL again. However, I attempted his workaround for hardware acceleration (rebooting and immediately executing 'sudo apt-get install fglrx-updates') but landed back on the original problem.

I saw the same issues listed in his "Notes:" paragraph. I had the exact same problem with 'atigetsysteminfo.sh' displaying the text 'ls: cannot access /proc/ati/*/*: No such file or directory'. I have attached my System Report in case it may help.
Comment 3 Kurtis 2012-03-01 20:01:36 CST
I just realized this was filed under the Radeon HD 5000 platform. If I need to create a separate ticket for my platform (HD 4200), please let me know and I will do so promptly. Thanks.
Comment 4 Kurtis 2012-03-01 20:11:59 CST
Created attachment 370 [details]
Kurtis' AtiSystemInfo-Report.txt
Comment 5 Michael Cronenworth 2012-08-19 11:56:19 CDT
This message is a reminder that your bug is marked as Catalyst 11.12.

The current Catalyst version is 12.8.

Approximately 7 days from now the Bugzilla administrator will be removing the
11.12 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla
administrator provides this as a unofficial, free service to AMD customers, and
I like to keep my systems neat and tidy. If you would like to keep your bug
from being closed, please try a new Catalyst version and update the 'version'
field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will
change it for you.
Comment 6 Michael Cronenworth 2012-09-03 20:25:29 CDT
This bug is being closed due to the 'version' being 11.12 after 15 days of the
previous closure notice.

Thank you for your bug report.