Bug 408 - AMD - 12.1 - gnome-shell[8451]: segfault at 1435c2107 error libglib
: AMD - 12.1 - gnome-shell[8451]: segfault at 1435c2107 error libglib
Status: CLOSED FIXED
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: OpenGL Driver
: .archived
: All Linux
: low normal
Assigned To: nobody
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-27 01:48 CST by Crypto_Ahash
Modified: 2013-08-14 11:42 CDT (History)
11 users (show)



Attachments
atisysteminfo (282.93 KB, text/plain)
2012-01-27 01:48 CST, Crypto_Ahash
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Crypto_Ahash 2012-01-27 01:48:05 CST
Created attachment 339 [details]
atisysteminfo

Description of problem: 
Randomly crashing of gnome-shell with the latest ATi drivers.

Message:
Jan 27 08:38:48 localhost kernel: [ 1335.809319] gnome-shell[8451]: segfault at 1435c2107 ip 00007f02aa0f5618 sp 00007fff806a2f20 error 4 in libglib-2.0.so.0.3000.2[7f02aa093000+120000]

Jan 27 08:47:01 localhost kernel: [ 1828.778902] gnome-shell[8748]: segfault at 35f91e107 ip 00007fcdc5ae0618 sp 00007fffd9a6e360 error 4 in libglib-2.0.so.0.3000.2[7fcdc5a7e000+120000]

I can not reproduce this. It just happens randomly.
Comment 1 pierre.boudier@amd.com 2012-01-27 05:10:27 CST
Can you share the stack trace showing which OpenGL entry points is affected ?
Comment 2 Milan Bouchet-Valat 2012-01-29 05:16:14 CST
For gdb backtraces, see https://bugzilla.redhat.com/show_bug.cgi?id=702257.

The GNOME bug is https://bugzilla.gnome.org/show_bug.cgi?id=668930.
Comment 3 pierre.boudier@amd.com 2012-01-29 06:43:25 CST
I quickly read the redhat bug report, and it is mentioned that this bug happens even without using the closed source driver; did I read incorrectly ?
Comment 4 Milan Bouchet-Valat 2012-01-29 09:19:17 CST
Only one user said that, and he uses a very specific configuration. All other reporters seem to use Catalyst. I can personally confirm that using the Nouveau driver the crash doesn't happen.
Comment 5 Milan Bouchet-Valat 2012-01-29 09:19:56 CST
Oh, and see
https://bugzilla.redhat.com/show_bug.cgi?id=702257#c58
Comment 6 pierre.boudier@amd.com 2012-01-30 01:57:41 CST
Looking at some stack trace, it looks like the crash happens inside glib, and not coming from the display driver: do you agree ?

Could your issue come from two different stl version used by gnome/driver ?
Comment 7 Milan Bouchet-Valat 2012-01-30 02:31:53 CST
(In reply to comment #6)
> Looking at some stack trace, it looks like the crash happens inside glib, and
> not coming from the display driver: do you agree ?
Indeed it happens inside glib, but magazine_chain_pop_head() is called from g_slice_alloc(), which is basically glib's replacement to malloc(). So that very likely indicates memory corruption. It would be interesting to run the Shell under Valgrind when using Catalyst (since you have the source and we don't).

> Could your issue come from two different stl version used by gnome/driver ?
By STL, you mean C++ Standard Template Library? gnome-shell/glib is written in C, and uses glibc.
Comment 8 Julian Rehborn 2012-02-07 09:27:01 CST
I have the same bug. The open source radeon driver runnig without problems.

I using a Radeon Mobility HD 4650.
Comment 9 Donagh 2012-03-07 08:16:49 CST
(In reply to comment #8)
> I have the same bug. The open source radeon driver runnig without problems.
> 
> I using a Radeon Mobility HD 4650.

I'm also experiencing this bug, on both an ATI HD 3450 and an ATI HD 6400. Usually, it happens when I click on the Activities button or, equivalently, when I hit the Windows key. I'd submit a trace, but I have no idea how to generate it...
Comment 10 Christian.Kirbach 2012-03-10 17:45:31 CST
This issue still happens with fglrx 12.2 on Fedora 16 (Radeon HD6670)
Comment 11 Donagh 2012-03-11 09:54:19 CDT
I can confirm that this is still happening with Catalyst 12.2 on Ubuntu 11.10. In my previous post, I stated that I was experiencing this bug with both a HD 3450 and a HD 6400 - the latter was a typo, I meant to say HD 6670. I'm not sure if this makes much of a difference, but it's probably better to clarify than not.
Comment 12 Amarus 2012-03-13 11:32:30 CDT
I can also confirm the issue on both HD6370 and HD3650 using Catalyst 12.2 on Arch Linux.

Also tried installing cinnamon (wanted to try it) and the segfault happens a lot more frequently with it installed.
Comment 13 Sabbath 2012-03-13 16:31:40 CDT
Ati catalyst 12.2 en gnome 3.2

CRASHHHHHHHHHHHHHHHHHHHHHHH
Comment 14 Sabbath 2012-03-13 16:32:06 CDT
ATI RADEON HD 4650 1 GB
Comment 15 Milan Bouchet-Valat 2012-03-14 13:19:02 CDT
A reporter in Fedora managed to get a trace using Valgrind. I think it makes it clear the memory errors come from libfglrx, and not from gnome-shell:
https://bugzilla.redhat.com/attachment.cgi?id=570027

(The bug report itself is
https://bugzilla.redhat.com/show_bug.cgi?id=802903
but it's a duplicate of master bug
https://bugzilla.redhat.com/show_bug.cgi?id=702257)

Can you confirm the problem is in Catalyst?
Comment 16 pierre.boudier@amd.com 2012-03-14 13:50:27 CDT
thanks for the log. we will definitely look into it.
Comment 17 Goulou 2012-03-18 14:42:06 CDT
I get the same problem using Fedora. I already disabled all extensions.
I just cleared the whole configuration of gnome-shell, but the crash still happens.

I'm using ATI proprietary driver, 12.2 (latest) version.
The problem happens mostly when a popup notification window opens up at the top of any window.
When the crash occurs, I'm not using anything besides Firefox and Digikam (the latter opens many notification windows when you edit images).

It is extremely frustrating, since if the crash happens twice in a few minutes, the "Oh no! Something has gone wrong" message appears, and I am forced to restarting my session! However, I know that just restarting gnome-shell would work, since it's what happends usually (WHY does it force me to log off??!).

I'm not sure if it is related, but when the previous notificatoin popup showed up, I got this message :
(gnome-shell:23357): Clutter-WARNING **: Unable to compile the GLSL shader: Fragment shader failed to compile with the following errors:
ERROR: 1:1: error(#105) #version must occur before any other statement in the program
ERROR: error(#273) 1 compilation errors. No code generated

Logs show, at the time of the crash : (result of "tail -f messages Xorg.0.log /home/user/.xsession-errors" in /var/log)

Mar 18 19:50:17 mypc kernel: [ 2997.054405] gnome-shell[23357]: segfault at 427aa4008 ip 000000389d45ff78 sp 00007fff1486d7d0 error 4 in libglib-2.0.so.0.3000.2[389d400000+11e000]

==> /home/user/.xsession-errors <==
gnome-shell-calendar-server[23366]: Got HUP on stdin - exiting
gnome-session[22343]: WARNING: Application 'gnome-shell.desktop' killed by signal

==> messages <==
Mar 18 19:50:17 mypc gnome-session[22343]: WARNING: Application 'gnome-shell.desktop' killed by signal

==> /home/user/.xsession-errors <==
** Message: applet now removed from the notification area
Comment 18 Luke Carrier 2012-04-08 20:14:02 CDT
Occurring for me too, Mobility Radeon HD 4500 in a Dell Studio 1555. The open source drivers don't exhibit the same issue, though I'd rather not use them because of the high temperatures. That said, AMD's drivers seem equally poor in this regard and they prevent me from making any headway in my work by repeatedly crashing my desktop environment.

Consider me another extremely unhappy customer. The blundering with these Gnome Shell issues really is a credit to AMD's commitment to Linux on the desktop, is it not?

Opinions and tempers aside, I'm sure there are thousands of others who'd appreciate this being fixed as soon as possible.
Comment 19 russianneuromancer 2012-06-02 13:29:19 CDT
http://www.phoronix.com/scan.php?page=news_item&px=MTExMTU
> Fix for random crashes with GNOME Shell.

Still issue with 12.6?
Comment 20 Crypto_Ahash 2012-06-02 16:18:36 CDT
No. Problem solved :)
Comment 21 Christian.Kirbach 2012-07-08 13:51:13 CDT
I can concur. This issue has apparently been fixed with the 12.6 driver.