Bug 432 - gnome-shell random crashed with ati driver
: gnome-shell random crashed with ati driver
Status: CLOSED FIXED
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: X11 Driver
: .archived
: Radeon HD 6000 Series Linux
: low major
Assigned To: nobody
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-21 04:04 CST by toplinuxsir
Modified: 2013-08-14 11:43 CDT (History)
5 users (show)



Attachments
Cinnamon 1.4.0 gdb results (35.41 KB, text/plain)
2012-04-21 02:38 CDT, Ken P.
Details
Another Debug result: Xorg.0.log.old (168.67 KB, text/plain)
2012-04-22 18:01 CDT, Ken P.
Details
More Cinnamon 1.4.0 gdb results (29.77 KB, text/plain)
2012-04-22 18:02 CDT, Ken P.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description toplinuxsir 2012-02-21 04:04:37 CST
Description of problem: 

gnome-shell random crashed with ati 12.1 driver 
when click the active button randomly the gnome-shell crashed 
Steps to reproduce:
1.  install debian wheezy , gnome-3.2.1 
2.  install ati 12.1 ati driver 
3.  random click the active button , crashed!
4. when play video with totem ,the gnome-shell crashed!
dmesg output :
[ 2306.507378] gnome-shell[9352]: segfault at 2b2aa5107 ip 00007fa688d01618 sp 00007fff770c61c0 error 4 in libglib-2.0.so.0.3000.2[7fa688c9f000+f6000]
[ 2352.007359] gnome-shell[9803]: segfault at 43c9e7008 ip 00007fb401443618 sp 00007fff540333c0 error 4 in libglib-2.0.so.0.3000.2[7fb4013e1000+f6000]
[ 2354.689103] [fglrx] IRQ 46 Disabled

I switch my graph card to nvidia  the problem is resolved !!

why ?


Expected result:
Comment 1 toplinuxsir 2012-02-21 04:06:28 CST
Please fix the bug ASAP, 
Pls do not make the ati user to be disappointed !\
Thanks !
Comment 2 toplinuxsir 2012-02-21 04:17:06 CST
I promise , If ati can not fix the bug , This will be my last ati card !
fuck !
I bear enough!
Comment 3 toplinuxsir 2012-02-21 04:18:02 CST
I promise , If ati can not fix the bug in the next release , This will be my last ati card !
fuck !
I bear enough!
Comment 4 russianneuromancer 2012-03-09 02:18:54 CST
Do you try Catalyst 12.2?
Comment 5 utkarshsins 2012-03-10 11:52:16 CST
The bug is not fixed in Catalyst 12.2 .. 
Frequent such crashes on my Debian Wheezy, with Gnome Shell 3.2 
Radeon HD 5730M
Comment 6 Carlos Alberto 2012-03-18 14:42:22 CDT
Same Problem with display driver 12.2

# lsb_release -idr
Distributor ID:	SUSE LINUX
Description:	openSUSE 12.1 (x86_64)
Release:	12.1
==============================================================================
# uname -a
Linux xxxx-xxxx.xxxxxx 3.1.9-1.4-desktop #1 SMP PREEMPT Fri Jan 27 08:55:10 UTC 2012 (efb5ff4) x86_64 x86_64 x86_64 GNU/Linux

==============================================================================
01:00.0 VGA compatible controller: ATI Technologies Inc NI Seymour [AMD Radeon HD 6470M] (prog-if 00 [VGA controller])
	Subsystem: Dell Device 04c1
	Flags: bus master, fast devsel, latency 0, IRQ 50
	Memory at c0000000 (64-bit, prefetchable) [size=256M]
	Memory at e0700000 (64-bit, non-prefetchable) [size=128K]
	I/O ports at 3000 [size=256]
	Expansion ROM at e0720000 [disabled] [size=128K]
	Capabilities: [50] Power Management version 3
	Capabilities: [58] Express Legacy Endpoint, MSI 00
	Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
	Capabilities: [150] Advanced Error Reporting
	Kernel driver in use: fglrx_pci

=============================================================================
Mar 18 10:39:39 xxxx-xxxx kernel: [135675.223845] gnome-shell[26559]: segfault at 1cdfd2008 ip 00007f0fa5b90ba8 sp 00007fffa5c8f1e0 error 4 in libglib-2.0.so.
0.3000.1[7f0fa5b2e000+f6000]
Mar 18 10:39:39 xxxx-xxxx gnome-session[2515]: WARNING: Application 'gnome-shell.desktop' killed by signal
Mar 18 10:39:39 xxxx-xxxx polkitd(authority=local): Unregistered Authentication Agent for unix-session:/org/freedesktop/ConsoleKit/Session2 (system bus name :
1.311, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.utf8) (disconnected from bus)
Mar 18 10:39:57 xxxx-xxxx dbus[969]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.11" (uid=0 pid=1100 comm="/usr/sbin/blu
etoothd --udev ") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.368" (uid=1000 pid=3687 comm="/usr/bin/gnome-s
hell ")
Mar 18 10:39:57 xxxx-xxxx dbus-daemon[969]: dbus[969]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.11" (uid=0 pid=1100 c
omm="/usr/sbin/bluetoothd --udev ") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.368" (uid=1000 pid=3687 comm
="/usr/bin/gnome-shell ")
Mar 18 10:39:57 xxxx-xxxx polkitd(authority=local): Registered Authentication Agent for unix-session:/org/freedesktop/ConsoleKit/Session2 (system bus name :1.
370 [/usr/bin/gnome-shell], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.utf8)
Comment 7 pierre.boudier@amd.com 2012-03-19 01:18:05 CDT
Does anyone see the glsl compilation failure reported in another thread ?
"
gnome-shell:23357): Clutter-WARNING **: Unable to compile the GLSL shader:
Fragment shader failed to compile with the following errors:
ERROR: 1:1: error(#105) #version must occur before any other statement in the
program
ERROR: error(#273) 1 compilation errors. No code generated
"
Comment 8 toplinuxsir 2012-03-30 08:09:10 CDT
AMD the shame on you !!!
The gnome-shell still crahsed  with ati catalyst 12.3.
The version 12.3 no bug fixed , no new feature ,
It is just a version number change !!
It is a joke !
AMD shame on you !!!
Comment 9 toplinuxsir 2012-03-30 08:15:17 CDT
[  102.107391] gnome-shell[1927]: segfault at f0d59008 ip 00007f799d96f8f1 sp 00007fffb87ecfc0 error 4 in libglib-2.0.so.0.3000.2[7f799d90d000+f6000]
[  199.793551] gnome-shell[2247] general protection ip:7fe855fb2618 sp:7fff9d3b1c80 error:0 in libglib-2.0.so.0.3000.2[7fe855f50000+f6000]
[  771.921441] gnome-shell[2383]: segfault at 2875e8016 ip 00007fa800ca7ccc sp 00007fff409a2fc0 error 4 in libgobject-2.0.so.0.3000.2[7fa800c73000+4f000]
[  864.552024] gnome-shell[2700]: segfault at 4c525e008 ip 00007f0f4095d618 sp 00007fff6c4afa20 error 4 in libglib-2.0.so.0.3000.2[7f0f408fb000+f6000]

seg fault debian wheezy(x64bit) gnome-shell 3.2  with catalyst 12.3 
GPU is HD6670
Comment 10 toplinuxsir 2012-03-30 08:15:40 CDT
[  102.107391] gnome-shell[1927]: segfault at f0d59008 ip 00007f799d96f8f1 sp 00007fffb87ecfc0 error 4 in libglib-2.0.so.0.3000.2[7f799d90d000+f6000]
[  199.793551] gnome-shell[2247] general protection ip:7fe855fb2618 sp:7fff9d3b1c80 error:0 in libglib-2.0.so.0.3000.2[7fe855f50000+f6000]
[  771.921441] gnome-shell[2383]: segfault at 2875e8016 ip 00007fa800ca7ccc sp 00007fff409a2fc0 error 4 in libgobject-2.0.so.0.3000.2[7fa800c73000+4f000]
[  864.552024] gnome-shell[2700]: segfault at 4c525e008 ip 00007f0f4095d618 sp 00007fff6c4afa20 error 4 in libglib-2.0.so.0.3000.2[7f0f408fb000+f6000]

seg fault debian wheezy(x64bit) gnome-shell 3.2  with catalyst 12.3 
GPU is HD6670
Comment 11 Ken P. 2012-04-21 02:38:35 CDT
Created attachment 437 [details]
Cinnamon 1.4.0 gdb results

I also am seeing this bug on my computer ( Linux Mint 12, AMD64, with Catalyst 12.4 preview [version 8.96.4] installed )... I managed to get the gdb capture of the gnome-shell crash, and this reveals that it originates in a thread that uses the cogl extension for pango.
Comment 12 Ken P. 2012-04-22 18:01:51 CDT
Created attachment 438 [details]
Another Debug result: Xorg.0.log.old

Another post for this bug... The best way to figure out what is going on is to install the numerous debug symbols and trace the crash... Since this involves Clutter ( in particular COGL), I went ahead and used gnome's community type for running gdb on the shell after I installed all the debug libraries.

http://live.gnome.org/GnomeShell/Debugging

As for a rapid way to find the bug, it's easily found by opening up a few programs that one would use on a desktop. In my case, I am able to produce the crash relatively well with running a combination of Firefox 11, XBMC 11.0 ( from the team-xbmc repository ), and Eclipse v3.7.0 on linux mint.
Comment 13 Ken P. 2012-04-22 18:02:57 CDT
Created attachment 439 [details]
More Cinnamon 1.4.0 gdb results
Comment 14 pierre.boudier@amd.com 2012-04-24 02:42:10 CDT
thanks for the stack traces. they were really useful.

we changed our implementation for "#version" which should fix the crash.
"
According to glsl spec, version 4.20, 3.3 Preprocessor, Page 13, 
The #version directive must occur in a shader before anything else, except for comments and white space. 
So the original operation was right. But NV's behavior looks like:
a. only preprocessor codes could be placed before "version" 
b. pragma and extension can't be placed before "version" 
c. the codes between "if" "else" "endif" can't contain no-preprocessor codes. 
"
Comment 15 toplinuxsir 2012-04-26 08:20:08 CDT
The Bug was not resolved with driver 12.4 !
I have tested it just now !
AMD shame on you!!!!!
Comment 16 russianneuromancer 2012-04-26 08:22:40 CDT
Look at comment 14 publishing date, after that look at 12.4 packaging date in CCC.
Comment 17 russianneuromancer 2012-06-19 11:44:47 CDT
So, anybody able to reproduce this issue with Catalyst 12.6?
Comment 18 Vamp898 2012-08-25 15:51:42 CDT
I was not able to reproduce with either 12.5 nor 12.6 or 12.8 (which im running now)

tested Cards are

5450
6570
6670

none of them crashed, GNOME 3.4 is working fine as KDE 4.9 does