Bug 460 - system hangs switching to integrated intel card
Summary: system hangs switching to integrated intel card
Status: CLOSED WONTFIX
Alias: None
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: Catalyst Control Center (show other bugs)
Version: .archived
Hardware: Radeon HD 6000 Series Linux
: low normal
Assignee: nobody
URL:
Depends on:
Blocks:
 
Reported: 2012-03-11 05:56 CDT by luigi
Modified: 2013-01-05 14:56 CST (History)
0 users



Attachments
kern.log (20.00 KB, application/x-gzip)
2013-01-05 14:55 CST, luigi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description luigi 2012-03-11 05:56:11 CDT
Hardware: hydrid Intel HD3000 /Ati HD6470M card. 

I installed Catalyst 12.2 and finally I was able to make it work. 

The problem occurs when from the control center or using aticonfig --px-igpu I switch to intel card, in fact after a logout the system hangs with a black screen. The same after rebooting. 
I tried also to remove the xorg created by aticonfig but it does not work. To make it work again I have to activate the ati card with aticonfig --px-dgpu
Comment 1 Michael Cronenworth 2012-11-27 21:35:53 CST
This message is a reminder that your bug is marked as Catalyst 12.2.

The current Catalyst version is 12.10. A beta driver (12.11) is also available.

Approximately 7 days from now the Bugzilla administrator will be removing the
12.2 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla
administrator provides this as a unofficial, free service to AMD customers, and
I like to keep my systems neat and tidy. If you would like to keep your bug
from being closed, please try a new Catalyst version and update the 'version'
field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will
change it for you.
Comment 2 Michael Cronenworth 2013-01-05 02:07:30 CST
This bug is being closed due to the 'version' being 12.2 after 30+ days of the
previous closure notice.

Thank you for your bug report.

(Oops. Time got away with me.)
Comment 3 luigi 2013-01-05 10:11:27 CST
Sorry I have just received the notice of the last your comment. Today I have tried to install again the catalyst 12.11 and by default are not working. I will summarized the steps I have followed taking suggestions from the web hopefully it will be useful to someone:

sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6
sudo apt-get install dkms libqtgui4 wget execstack libelfg0 dh-modaliases
sudo apt-get install linux-headers-generic xserver-xorg-core libgcc1

For 64bit:
sudo apt-get install ia32-libs lib32gcc1 libc6-i386
cd /usr ; sudo ln -svT lib /usr/lib64

sudo sh ./amd-driver-installer-catalyst-12.11-beta11-x86.x86_64.run --buildpkg Ubuntu/quantal

__________________________________________________________________________________________________________
1st bug fixing:
 
Low graphics mode in muxless hybrid ATI/Intel GPU systems after fglrx upgrade
(https://bugs.launchpad.net/ubuntu/+source/fglrx-installer-updates/+bug/1068404)


install xserver-xorg-video-intel from https://launchpad.net/~andrikos/+archive/ppa/+packages?field.name_filter=&field.status_filter=published&field.series_filter=quantal

sudo dpkg -i xserver-xorg-video-intel_2.20.9-0ubuntu2+andrik2_amd64.deb
__________________________________________________________________________________________________________

sudo dpkg -i fglrx*.deb
sudo aticonfig --initial -f

__________________________________________________________________________________________________________
2nd Temporary bug fixing:

Ref: http://ubuntuforums.org/showthread.php?t=1930450

gksu gedit /etc/X11/Xsession.d/10fglrx

For 32bits system add at the end of 4th line this text : "/usr/lib32/dri" without the quotes. The file should now look like this :

 LIBGL_DRIVERS_PATH=/usr/lib/fglrx/dri 
if [ `uname -m` = 'x86_64' ]; then 
if [ -d /usr/lib32/fglrx/dri ]; then 
LIBGL_DRIVERS_PATH=${LIBGL_DRIVERS_PATH}:/usr/lib32/fglrx/dri:/usr/lib32/dri
if [ ! -z $LD_LIBRARY_PATH ]; then 
LD_LIBRARY_PATH=$LD_LIBRARY_PATH: 
fi 
LD_LIBRARY_PATH=${LD_LIBRARY_PATH}/usr/lib32 
export LD_LIBRARY_PATH 
fi 
fi 
export LIBGL_DRIVERS_PATH


For 64bits system add at the end of 4th line this text : "/usr/lib/x86_64-linux-gnu/dri/" without the quotes. The file should now look like this :

 LIBGL_DRIVERS_PATH=/usr/lib/fglrx/dri 
if [ `uname -m` = 'x86_64' ]; then 
if [ -d /usr/lib32/fglrx/dri ]; then 
LIBGL_DRIVERS_PATH=${LIBGL_DRIVERS_PATH}:/usr/lib32/fglrx/dri:/usr/lib/x86_64-linux-gnu/dri
if [ ! -z $LD_LIBRARY_PATH ]; then 
LD_LIBRARY_PATH=$LD_LIBRARY_PATH: 
fi 
LD_LIBRARY_PATH=${LD_LIBRARY_PATH}/usr/lib32
export LD_LIBRARY_PATH 
fi 
fi 
export LIBGL_DRIVERS_PATH
__________________________________________________________________________________________________________

Hardware: Hp Pavillion 6030el
          Intel® Core™ i7-2630QM
          AMD Radeon HD 7400M Series (but should be HD6470M)

Now it is working fine except:

1) update-alternatives: warning: forcing reinstallation of alternative /usr/lib/fglrx/ld.so.conf because link group x86_64-linux-gnu_gl_conf is broken

2) some segmentation fault shuttiung down the machine, but for the moment I cannot reproduce it.

3) switching to IGPU some applications as playonlinux complain about opengl 32bit libraries.
Comment 4 luigi 2013-01-05 14:55:07 CST
Created attachment 651 [details]
kern.log
Comment 5 luigi 2013-01-05 14:56:12 CST
Unbelievable that almost 2 years Ati is not able to write drivers that are
working on linux. Other few months and I will see HDXXX not supported anymore.
I already had a bad experience with Radeon x1600 and I made a mistake to buy
another machine with Ati.

Segmentation fault occurs shutting down the machine