Bug 462 - driver for low end GPU's
: driver for low end GPU's
Status: CLOSED WONTFIX
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: OpenGL Driver
: .archived
: Other Linux
: low normal
Assigned To: nobody
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 01:50 CDT by dmischa
Modified: 2013-01-05 02:08 CST (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dmischa 2012-03-15 01:50:36 CDT
as in [Bug 205] was stated, low end GPU's (e.g. HD2000 series) are not appropriate supported by the newer drivers. Last well performing driver was for me V9.3. So I would like to request to continue the support also for low end GPU's.

(your high end GPU's of today will be my low end GPU of tomorrow)
Comment 1 pierre.boudier@amd.com 2012-03-15 09:19:38 CDT
the statement that high gpu of today will be the low end from tomorrow is not entirely true.

low end GPU primary design decision is based on cost, and high end GPU design decision is based on performance. for instance memory bandwidth is usually much higher on high end GPU, regardless of generation.

as well, the low end of the market is shifting toward APU (fully integrated GPU inside the CPU).
Comment 2 dmischa 2012-03-15 09:42:54 CDT
(In reply to comment #1)

> low end GPU primary design decision is based on cost, and high end GPU design
> decision is based on performance. 

my decision to buy a HD2400 was based on both, the costs were low and the performance was good enough for me. Over the years my OS (CentOS5) got updates and some incompatibility with V9.3 appeared and the compatible V12.x behave to slow as discussed in [Bug 205].  

> as well, the low end of the market is shifting toward APU (fully integrated GPU
> inside the CPU).

don't like to follow the market (and buy every year new hardware) as long I can ask for support
Comment 3 pierre.boudier@amd.com 2012-03-15 09:48:36 CDT
I believe that hd2400 was rv610, and the performance was not a match to any high end GPU for the prior years :)

from the other thread, we verified that the performance was the same on windows/linux in "Heroes Of Newerth" which was the example given. Maybe your issue is different ...

I honestly don't know if there is any specific actionable request here.
Comment 4 dmischa 2012-03-15 10:07:00 CDT
(In reply to comment #3)

> I honestly don't know if there is any specific actionable request here.

I'd like to request to ensure the compatibility of V9.3 with RHEL5
Comment 5 pierre.boudier@amd.com 2012-03-15 10:16:59 CDT
this request is not really possible given our development structure; the work to support newer distribution is done in the latest internal driver, and it is not reasonable to backport to such an old branch. sorry
Comment 6 dmischa 2012-03-15 10:22:19 CDT
(In reply to comment #5)
> this request is not really possible given our development structure; the work
> to support newer distribution is done in the latest internal driver, and it is
> not reasonable to backport to such an old branch. sorry

disagreeable to hear this
Comment 7 dmischa 2012-03-16 09:31:08 CDT
(In reply to comment #5)
> the work
> to support newer distribution is done in the latest internal driver

RHEL5 is older than V9.3, only some point releases are newer
Comment 8 pierre.boudier@amd.com 2012-03-16 09:40:09 CDT
the point is that we don't go back to an older branch to do new development, because this means splitting the resource. btw, I still don't have a good understanding of what kind of performance regression you are seeing. 
is that in 3d ? is in that in 2d ? is that enabling some features like desktop compositing ? is that in video playback ?

at least on the 3d/compute side, we have lots of regression testing (daily) ...
Comment 9 dmischa 2012-03-16 12:00:39 CDT
(In reply to comment #8)
> the point is that we don't go back to an older branch to do new development,
> because this means splitting the resource.

may be good for you, not so good for someone who wants to use a radeon for years

> btw, I still don't have a good
> understanding of what kind of performance regression you are seeing. 
> is that in 3d ? 

yes

> is in that in 2d ?

yes

> is that enabling some features like desktop
> compositing ? 

no, don't use it

> is that in video playback ?

no, don't use it

> at least on the 3d/compute side, we have lots of regression testing (daily) 

you could easily reproduce this if you compare the behaviour of 9.3 and 12.x on a computer with an older radeon (e.g, HD2400) with RHEL5 or one of the clones as OS
Comment 10 pierre.boudier@amd.com 2012-03-16 12:20:03 CDT
per the other thread, the performance of that card was tested and was similar on windows/linux, and seems to correctly use the underlying HW.
Comment 11 dmischa 2012-03-16 12:40:46 CDT
(In reply to comment #10)
> per the other thread, the performance of that card was tested and was similar
> on windows/linux, and seems to correctly use the underlyi(In reply to comment #10)
> per the other thread, the performance of that card was tested and was similar
> on windows/linux, and seems to correctly use the underlying HW.

differences between windows and linux are not my problem (don't use windows on this computers), my problem are differences between 9.3 and 12.x under linux with my old radeon
Comment 12 dmischa 2012-03-19 03:48:16 CDT
can anyone confirm, that 9.3 performs also with windows better on low end GPU's?
Comment 13 Michael Cronenworth 2012-11-27 21:35:58 CST
This message is a reminder that your bug is marked as Catalyst 12.2.

The current Catalyst version is 12.10. A beta driver (12.11) is also available.

Approximately 7 days from now the Bugzilla administrator will be removing the
12.2 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla
administrator provides this as a unofficial, free service to AMD customers, and
I like to keep my systems neat and tidy. If you would like to keep your bug
from being closed, please try a new Catalyst version and update the 'version'
field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will
change it for you.
Comment 14 Michael Cronenworth 2013-01-05 02:07:35 CST
This bug is being closed due to the 'version' being 12.2 after 30+ days of the
previous closure notice.

Thank you for your bug report.

(Oops. Time got away with me.)