Bug 463 - FGLRX DPMS support totally broken, fails to wake up the monitor after putting it to sleep.
: FGLRX DPMS support totally broken, fails to wake up the monitor after putting...
Status: CLOSED WONTFIX
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: X11 Driver
: .archived
: Radeon HD 5000 Series Linux
: low major
Assigned To: nobody
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-17 20:29 CDT by Ryan Farmer
Modified: 2013-08-22 13:58 CDT (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Farmer 2012-03-17 20:29:26 CDT
For quite a while now, I've just turned DPMS off to keep anything from putting the monitor to sleep to work around this problem.

When DPMS support is on (which is the default setting), and something attempts to put the display to sleep (in this case, KDE's desktop power management daemon, but I've had this problem with XFCE and GNOME, and under Ubuntu's Unity desktop as well), the monitor cannot come back on when the user returns and moves the mouse or presses a button on the keyboard. The rest of the system is apparently still functional as I've left music playing before, and then when I've returned, the display is asleep and not responding to my attempts to wake it up, but the music is still playing.


Steps to reproduce:
1. I am assuming that for the purposes of reproducing this bug that the following is true, even though I've seen it on various distributions and several versions of Catalyst.

You are using Ubuntu 11.10 or 12.04 development branch.

You are using Catalyst 12.2 with FGLRX 8.95.

You are using a RadeonHD 5670.

You are using the Unity or KDE desktop environment. (Either one should provoke this problem.)

2. Wait for the display to be turned off/go into sleep mode. NOT dimmed! If you catch it while it is dimmed, but before it is turned off, you will end up back at your desktop.
 
3. After the display is off/asleep, attempt to move your mouse or press a button on the keyboard. Observe that the system is NOT responding and the monitor is stuck in sleep mode. 

Actual result: The display fails to resume, anything you left open is trashed, game over man, game over! :)

Expected result: The display mode should be resumed properly in the state that it was previously in. The open source radeon driver always manages to do this right. (Although I understand that since it is the kernel setting the display mode in that case instead of this crazy setting the video mode from X that you guys have going on in your proprietary driver, this might be easier for the open source driver to accomplish.)
Comment 1 Ryan Farmer 2012-03-17 20:34:04 CDT
I hit submit before I thought to document the work around steps:

Generate a xorg.conf file with this command:

sudo amdconfig --initial

Open the xorg.conf file:

sudo nano /etc/X11/xorg.conf

Find this line: (under Section "Monitor")

Option      "DPMS" "true"

change it to read

Option      "DPMS" "false"

Restart the X server.

Observe that your desktop is no longer able to put the display to sleep and that AMD's proprietary display driver is contributing to increased global warming and a higher electric bill. (But doesn't screw up the X server and cause all of user's open files to be lost)
Comment 2 icicimov 2012-06-11 23:56:47 CDT
Hi,

I can confirm the same problem with Catalyst 12.2 and Radeon HD3200 on Lucid 10.04. I have HDMI connection to my TV and after switching the TV off and on the driver fails to recover the desktop. The applications stay active in the background. Looks like the driver fails to probe or initiate the connected output and/or read the EDID data from the connected TV.

Have tried every possible solution/suggestion I could find for this problem including disabling DPMS and Composite extension to no avail.

Igor
Comment 3 russianneuromancer 2012-06-12 00:01:34 CDT
Can you confirm this problem with Catalyst 12.6?
Comment 4 Ryan Farmer 2012-07-01 00:40:05 CDT
Yes, this still affects 12.6. Updating bug to reflect this.
Comment 5 Ryan Farmer 2012-07-01 00:42:39 CDT
I have an Ubuntu Launchpad bug that is following this bug.

Some people have reported work arounds for this bug on Launchpad.

The Launchpad bug that is tracking this is:

https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/958279


My work around has been to just set KDE to not blank the screen for 5 hours.

Since I'm never away from a running system for that long, it effectively just keeps it from ever hitting this bug. I would prefer not to have to do that.
Comment 6 Michael Cronenworth 2013-08-14 11:06:16 CDT
This message is a reminder that your bug is marked as Catalyst 12.6.

The current legacy Catalyst version is 13.1.
The current Catalyst version is 13.4.
The current Catalyst beta version is 13.8.

Approximately 7 days from now the Bugzilla administrator will be removing the 12.6 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla administrator provides this as a unofficial, free service to AMD customers, and I like to keep my systems neat and tidy. If you would like to keep your bug from being closed, please try a new Catalyst version and update the 'version' field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will change it for you.
Comment 7 Michael Cronenworth 2013-08-22 13:57:42 CDT
This bug is being closed due to the 'version' being 12.6 after 7 days of the previous closure notice.

Thank you for your bug report.