Bug 48 - 11.1+wine1.2/1.3 Oblivion crashes after walking around.
: 11.1+wine1.2/1.3 Oblivion crashes after walking around.
Status: CLOSED WONTFIX
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: OpenGL Driver
: .archived
: All Linux
: low normal
Assigned To: nobody
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-07 23:29 CST by qaridarium
Modified: 2011-08-02 22:35 CDT (History)
0 users



Attachments
one exampel pc that was hitten by this bug i test it on 2 more systems (393.29 KB, text/plain)
2011-02-07 23:29 CST, qaridarium
Details

Note You need to log in before you can comment on or make changes to this bug.
Description qaridarium 2011-02-07 23:29:55 CST
Created attachment 45 [details]
one exampel pc that was hitten by this bug i test it on 2 more systems

Description of problem: Oblivion crashes after walking around for a few seconds 

After starting a new game and going through character creation, the game starts normally. But as you walk and turn around for the first time the game freezes.

and then: Uninstalled Catalyst 11.1 and installed 10.10. With this configuration the freeze doesn't happen anymore.

Steps to reproduce:
1. install a kubuntu 10-10 and catalyst 11.1 and wine 1.3.x
2. install and run Oblivion
3. select an character and start to move after 10 seconds the game crash.
4. downgrade the driver to 10.10
5. start the game again
6. game does not crash on 10-10


Actual result: the game crashes without an spezific error message in the console

Expected result: the game should run stable.
Comment 1 qaridarium 2011-02-07 23:36:31 CST
my bugreport on codewavers:
http://www.codeweavers.com/support/tickets/browse/?ticket_id=835043

and the wine error log:

fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
[...]
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #150:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
[...]
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #153:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
[...]
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #156:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
[...]
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #160:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
[...]
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #163:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
[...]
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #166:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
[...]
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #170:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
[...]
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #173:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #176:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #180:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #184:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #188:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #192:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #196:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
[...]
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
Comment 2 qaridarium 2011-02-15 20:13:28 CST
Installed the new Catalyst 11.2 and retested it, with about the same result.

fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
[...]
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #150:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
[...]
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #154:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
[...]
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #157:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #161:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
[...]
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #164:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
[...]
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #167:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
[...]
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #170:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
[...]
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #172:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
[...]
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #176:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #179:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #183:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #187:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #191:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #195:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #199:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #203:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
[...]
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #206:
fixme:d3d_shader:print_glsl_info_log     Vertex shader(s) linked, fragment shader(s) linked.
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
[...]
fixme:quartz:Parser_OutputPin_QueryInterface No interface for {56a868a5-0ad4-11ce-b03a-0020af0ba770}!
Beendet
Comment 3 Michael Cronenworth 2011-07-27 23:01:40 CDT
This message is a reminder that your bug is marked as Catalyst 11.1.

The current Catalyst version is 11.7.

Approximately 7 days from now the Bugzilla administrator will be removing the
11.1 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla
administrator provides this as a unofficial, free service to AMD customers, and
I like to keep my systems neat and tidy. If you would like to keep your bug
from being closed, please try a new Catalyst version and update the 'version'
field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will
change it for you.
Comment 4 Michael Cronenworth 2011-08-02 22:35:16 CDT
This bug is being closed due to the 'version' being 11.1 after 7 days of the
previous closure notice.

Thank you for your bug report.