Bug 481 - Display wont wake up from sleep AMD HD 6670 on Debian Squeeze
Summary: Display wont wake up from sleep AMD HD 6670 on Debian Squeeze
Status: CLOSED WONTFIX
Alias: None
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: X11 Driver (show other bugs)
Version: .archived
Hardware: Radeon HD 6000 Series Linux
: low major
Assignee: nobody
URL:
Depends on:
Blocks:
 
Reported: 2012-04-09 00:18 CDT by Chris
Modified: 2013-05-08 00:07 CDT (History)
1 user (show)



Attachments
ATI System Info (304.39 KB, text/plain)
2012-04-09 00:18 CDT, Chris
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris 2012-04-09 00:18:40 CDT
Created attachment 421 [details]
ATI System Info

Description of problem: When i enable the display to "sleep in X minutes" the display, once in sleep mode wont wake up.

I have tried disabling ACPI using "aticonfig --acpi-services=off", This would allow the display to wake up but caused a new intermittent problem where the display corrupted. causing the display to start in the middle of the screen (not from the far left) and finish in reverse back in the middle of the screen.

If i don’t set the monitor to sleep, everything works great.

Steps to reproduce:
1. Enable "put display to sleep when left for X minutes"
2. Leave display for X minutes
3. Try to wake display up buy moving mouse, keyboard etc.

Actual result: 
Display stays in sleep mode

Expected result: 
Display should wake up
Comment 1 Chris 2012-04-27 23:43:21 CDT
I just upgraded to the latest 12.4 driver and i'm still getting the same issues.

I have attached a link to a photo of the display corruption. This happens after the display wakes up from sleep and i will need to reboot my PC to fix it.

Link: http://dl.dropbox.com/u/9400754/cchtml/Image.jpg

Note how the display starts from the middle\right and ends in the middle\right of the LCD (Not starting from the left and ending at the right)
Comment 2 Chris 2012-06-01 08:49:03 CDT
Still having the same issue, if anyone has a solution please let me know.
Comment 3 Chris 2012-06-20 21:21:39 CDT
I fixed the issue, Below are steps if anyone is interested.

To provent this issue follow the steps below.

1: Ignore all ATI cards before buying a new graphics card.
2: Buy a Nvidia Card.
3: Install Nvidia Card and drivers.
done!

If you already have an ATI Card follow the steps below...

1: Remove ATI card from the system and throw the card in the closest bin!
2: Uninstall all ATI drivers\Software.
3: Go to shop and purchase a nice new Nvidia card.
4: Install the Nvidia Card and drivers.

That should fix any ATI issue you have!

I purchased the GTX560TI and am having no issues what so ever!

Maybe this should be in the Wiki?
Comment 4 Michael Cronenworth 2013-04-24 22:57:27 CDT
This message is a reminder that your bug is marked as Catalyst 12.4.

The current Catalyst version is 13.4.

Approximately 7 days from now the Bugzilla administrator will be removing the 12.4 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla administrator provides this as a unofficial, free service to AMD customers, and I like to keep my systems neat and tidy. If you would like to keep your bug from being closed, please try a new Catalyst version and update the 'version' field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will change it for you.
Comment 5 Michael Cronenworth 2013-05-08 00:04:13 CDT
This bug is being closed due to the 'version' being 12.4 after 14 days of the previous closure notice.

Thank you for your bug report.