Bug 499 - segmentation fault in fglrx_dri.so
: segmentation fault in fglrx_dri.so
Status: CLOSED WONTFIX
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: OpenGL Driver
: .archived
: Radeon HD 6000 Series Linux
: low major
Assigned To: nobody
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-08 09:05 CDT by Christophe Oosterlynck
Modified: 2013-05-08 00:06 CDT (History)
0 users



Attachments
backtrace (111.75 KB, text/plain)
2012-05-08 09:08 CDT, Christophe Oosterlynck
Details
hardware summary (67.83 KB, text/html)
2012-05-08 09:18 CDT, Christophe Oosterlynck
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christophe Oosterlynck 2012-05-08 09:05:35 CDT
Description of problem:

My Qt OpenGL application which shows some videos and flashes crashes with a segmentation fault in fglrx_dri.so. Attached is a simplified situation able to reproduce the crash.

Steps to reproduce:
Run my example and wait  for it to crash. Should happen in first few minutes after starting the application. Running the application right after a cold boot usually triggers the crash early after starting the example.

My system:
Platform based on AMD G-series T56N
Ubuntu 11.10 x86 with Catalyst 12.3 (shipped with ubuntu) or 12.4 (installed manually)
Comment 1 Christophe Oosterlynck 2012-05-08 09:08:16 CDT
Created attachment 447 [details]
backtrace

Full backtrace of when crash happens. When reproducing the bug a few times, the big constant is:

Thread 1 (Thread 0xb4b01720 (LWP 3684)):
#0  0xb309072d in ?? () from /usr/lib/i386-linux-gnu/dri/fglrx_dri.so
No symbol table info available.
#1  0x000020dc in ?? ()
No symbol table info available.
#2  0x000020d9 in ?? ()
No symbol table info available.
#3  0x00000000 in ?? ()
No symbol table info available.
Comment 2 Christophe Oosterlynck 2012-05-08 09:18:06 CDT
example program:
https://www.dropbox.com/s/us1j3rcerhv5icp/fglrxcrash.tar.gz
Comment 3 Christophe Oosterlynck 2012-05-08 09:18:52 CDT
Created attachment 448 [details]
hardware summary

lshw output of my development platform
Comment 4 Michael Cronenworth 2013-04-24 22:56:59 CDT
This message is a reminder that your bug is marked as Catalyst 12.4.

The current Catalyst version is 13.4.

Approximately 7 days from now the Bugzilla administrator will be removing the 12.4 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla administrator provides this as a unofficial, free service to AMD customers, and I like to keep my systems neat and tidy. If you would like to keep your bug from being closed, please try a new Catalyst version and update the 'version' field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will change it for you.
Comment 5 Michael Cronenworth 2013-05-08 00:03:49 CDT
This bug is being closed due to the 'version' being 12.4 after 14 days of the previous closure notice.

Thank you for your bug report.