Bug 528 - fglrx reports different uniform constant values to wine as well as any executable renamed to 'wine'
Summary: fglrx reports different uniform constant values to wine as well as any execut...
Status: CLOSED WONTFIX
Alias: None
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: OpenGL Driver (show other bugs)
Version: .archived
Hardware: All Linux
: low major
Assignee: nobody
URL:
Depends on:
Blocks:
 
Reported: 2012-06-05 06:19 CDT by zephiris
Modified: 2015-07-15 13:19 CDT (History)
3 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zephiris 2012-06-05 06:19:28 CDT
Description of problem: 
On wine, or glxinfo(32) named to 'wine', fglrx reports 1024 constants, whereas with normal glxinfo(32), and anything else, it appears to report 16384.
Steps to reproduce:
1. install wine
2. run WINEDEBUG="+d3d_caps" wine <d3d test program>exe
3. observe that the caps report only 256 components (1024/4)

OR
1. rename glxinfo (64-bit or 32-bit, doesn't matter) to 'wine' anywhere on your filesystem
2. execute ./wine -l
3. Notice that vertex and fragment components only list 1024.
4. Compare to 'normal' result of 16384.

Actual result: GL_MAX_VERTEX_UNIFORM_COMPONENTS_ARB reports 1024.

Expected result: GL_MAX_VERTEX_UNIFORM_COMPONENTS_ARB reports 16384.

I don't understand why, or precisely how, fglrx seems to be altering the value for wine, so wine miscompiles shaders and won't work correctly using Shader Model 3.0.

There seems to be no basis for this. r600g executes with 16384 correctly, and the 'varying' bug was fixed in a previous version.

Was this merely an oversight for that bug, or is fglrx intentionally doing something strange with wine?

--- glxinfo32.log       2012-06-05 03:53:56.678492805 -0700
+++ wine.log 2012-06-05 03:53:45.467444708 -0700
@@ -189,7 +189,7 @@
         GL_MAX_PROGRAM_NATIVE_TEX_INSTRUCTIONS_ARB = 2147483647
         GL_MAX_PROGRAM_NATIVE_TEX_INDIRECTIONS_ARB = 2147483647
     GL_VERTEX_SHADER_ARB:
-        GL_MAX_VERTEX_UNIFORM_COMPONENTS_ARB = 16384
+        GL_MAX_VERTEX_UNIFORM_COMPONENTS_ARB = 1024
         GL_MAX_VARYING_FLOATS_ARB = 128
         GL_MAX_VERTEX_ATTRIBS_ARB = 29
         GL_MAX_TEXTURE_IMAGE_UNITS_ARB = 16
@@ -197,7 +197,7 @@
         GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS_ARB = 32
         GL_MAX_TEXTURE_COORDS_ARB = 16
     GL_FRAGMENT_SHADER_ARB:
-        GL_MAX_FRAGMENT_UNIFORM_COMPONENTS_ARB = 16384
+        GL_MAX_FRAGMENT_UNIFORM_COMPONENTS_ARB = 1024
         GL_MAX_TEXTURE_COORDS_ARB = 16
         GL_MAX_TEXTURE_IMAGE_UNITS_ARB = 16
Comment 1 Commander 2012-06-29 15:28:11 CDT
Yup same issue, EVE-Online seems to have rendering issues with not enough uniforms error in the terminal.

Didn't find this before so here is my bugreport on this;
http://ati.cchtml.com/show_bug.cgi?id=549
Comment 2 Commander 2012-08-26 01:11:37 CDT
still an issue in 12.8
Comment 3 aaron 2012-10-10 03:43:10 CDT
[workaround] A possible patch for wine is at http://bugs.winehq.org/show_bug.cgi?id=31934 to work around this until it is resolved by Upstream
Comment 4 aaron 2012-10-12 06:15:24 CDT
(In reply to comment #3)
> [workaround] A possible patch for wine is at
> http://bugs.winehq.org/show_bug.cgi?id=31934 to work around this until it is
> resolved by Upstream

I've just been able to confirm that this is fixed in the 12.9 beta.
Comment 5 Commander 2012-10-13 07:08:21 CDT
(In reply to comment #4)
> (In reply to comment #3)
> > [workaround] A possible patch for wine is at
> > http://bugs.winehq.org/show_bug.cgi?id=31934 to work around this until it is
> > resolved by Upstream
> 
> I've just been able to confirm that this is fixed in the 12.9 beta.

Installed 12.9 beta and it seems that the constrains have been removed for now. Though the 12.9 beta got some more serious issues with rendering atm.
Comment 6 Michael Cronenworth 2013-08-14 11:05:55 CDT
This message is a reminder that your bug is marked as Catalyst 12.6.

The current legacy Catalyst version is 13.1.
The current Catalyst version is 13.4.
The current Catalyst beta version is 13.8.

Approximately 7 days from now the Bugzilla administrator will be removing the 12.6 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla administrator provides this as a unofficial, free service to AMD customers, and I like to keep my systems neat and tidy. If you would like to keep your bug from being closed, please try a new Catalyst version and update the 'version' field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will change it for you.
Comment 7 Michael Cronenworth 2013-08-22 13:57:24 CDT
This bug is being closed due to the 'version' being 12.6 after 7 days of the previous closure notice.

Thank you for your bug report.
Comment 8 Jarkko K 2014-04-13 14:44:19 CDT
This is still an issue with 7870, beta 14.3

Reports 1024 values, which are too low. Some games dont render humans, graphical errors also.
Comment 9 Michael Cronenworth 2015-07-09 11:52:14 CDT
This message is a reminder that your bug is marked as Catalyst 14.3.

The current legacy Catalyst version is 13.1.
The current Catalyst version is 15.7.

Approximately 7 days from now the Bugzilla administrator will be removing the 14.3 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla administrator provides this as a unofficial, free service to AMD customers, and I like to keep my systems neat and tidy. If you would like to keep your bug from being closed, please try a new Catalyst version and update the 'version' field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will change it for you.
Comment 10 Michael Cronenworth 2015-07-15 13:18:27 CDT
This bug is being closed due to the 'version' being 14.3 after 6 days of the previous closure notice.

Thank you for your bug report.