Bug 536 - Fglrx crashes X-org under Wine - HD 6xxxM
Summary: Fglrx crashes X-org under Wine - HD 6xxxM
Status: CLOSED WONTFIX
Alias: None
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: OpenGL Driver (show other bugs)
Version: .archived
Hardware: Radeon HD 6000 Series Linux
: low normal
Assignee: nobody
URL:
Depends on:
Blocks:
 
Reported: 2012-06-17 04:01 CDT by jaroslaw
Modified: 2014-12-20 21:50 CST (History)
0 users



Attachments
atigetsysteminfo.sh (355.95 KB, text/plain)
2012-06-17 04:01 CDT, jaroslaw
Details
Graphical glitches in fglrx (115.13 KB, image/jpeg)
2013-05-05 08:09 CDT, jaroslaw
Details
Proper display (61.65 KB, image/jpeg)
2013-05-05 08:13 CDT, jaroslaw
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jaroslaw 2012-06-17 04:01:06 CDT
Created attachment 498 [details]
atigetsysteminfo.sh

Description of problem: 
This bug most likely affects only HD 6xxxM 3D driver. My video card is HD 6850M.
During playing 3D games under Wine, after a while X-org crashes. One of the affected games is Jagged Alliance Back in Action
Steps to reproduce:
1. Download file: http://www.strategyinformer.com/pc/demos/jaggedalliancebackinaction/demo.html
2. Install under Wine
3. Start Demo - Tutorial
4. Move to the edge of the map, rotate camera view.

Actual result: 
X-org crashes
Expected result: 
No crash
Comment 1 Michael Cronenworth 2013-04-24 22:57:21 CDT
This message is a reminder that your bug is marked as Catalyst 12.4.

The current Catalyst version is 13.4.

Approximately 7 days from now the Bugzilla administrator will be removing the 12.4 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla administrator provides this as a unofficial, free service to AMD customers, and I like to keep my systems neat and tidy. If you would like to keep your bug from being closed, please try a new Catalyst version and update the 'version' field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will change it for you.
Comment 2 jaroslaw 2013-04-27 12:59:08 CDT
Still present in Catalyst 13.4. Open source driver does not crash X-org so the bug is only in fglrx.
Comment 3 jaroslaw 2013-05-05 08:09:13 CDT
Created attachment 764 [details]
Graphical glitches in fglrx

Graphical glitches observed in The Cave game with Catalyst 13.4
Comment 4 jaroslaw 2013-05-05 08:13:38 CDT
Created attachment 765 [details]
Proper display

No graphical glitches with open source driver in The Cave game.
Comment 5 Michael Cronenworth 2014-03-18 23:21:51 CDT
This message is a reminder that your bug is marked as Catalyst 13.4.

The current legacy Catalyst version is 13.1.
The current Catalyst version is 13.12.
The current Catalyst beta version is 14.2.

Approximately 7 days from now the Bugzilla administrator will be removing the 13.4 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla administrator provides this as a unofficial, free service to AMD customers, and I like to keep my systems neat and tidy. If you would like to keep your bug from being closed, please try a new Catalyst version and update the 'version' field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will change it for you.
Comment 6 jaroslaw 2014-03-23 12:58:00 CDT
Still present in catalyst 13.12. It also affects linux game Shadowrun Returns.
Comment 7 Michael Cronenworth 2014-12-10 19:30:05 CST
This message is a reminder that your bug is marked as Catalyst 13.12.

The current Catalyst version is 14.12.

Approximately 7 days from now the Bugzilla administrator will be removing the 13.12 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla administrator provides this as a unofficial, free service to AMD customers, and I like to keep my systems neat and tidy. If you would like to keep your bug from being closed, please try a new Catalyst version and update the 'version' field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will change it for you.
Comment 8 Michael Cronenworth 2014-12-20 21:49:41 CST
This bug is being closed due to the 'version' being 13.12 after 10 days of the previous closure notice.

Thank you for your bug report.