Bug 545 - FGLRX Fails and Crashes when running Piglet Open Source test Suite
Summary: FGLRX Fails and Crashes when running Piglet Open Source test Suite
Status: CLOSED WONTFIX
Alias: None
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: OpenGL Driver (show other bugs)
Version: .archived
Hardware: All Linux
: low major
Assignee: nobody
URL:
Depends on:
Blocks:
 
Reported: 2012-06-29 00:28 CDT by Ken P.
Modified: 2013-08-22 13:58 CDT (History)
0 users



Attachments
system log after crashing fglrx using piglet (31.23 KB, application/x-7z-compressed)
2012-06-29 03:39 CDT, Ken P.
Details
ati system information ( catalyst 12.4 - asus laptop ) (293.92 KB, text/plain)
2012-06-29 03:46 CDT, Ken P.
Details
System log for catalyst 12.4 (251.76 KB, text/plain)
2012-06-29 04:05 CDT, Ken P.
Details
atigensystemreport for Catalyst 12.6 release ( Radeon HD 5770 ) (327.92 KB, text/plain)
2012-06-29 05:04 CDT, Ken P.
Details
syslog for Catalyst 12.6 release ( Radeon HD 5770, Post crash ) (152.85 KB, text/plain)
2012-06-29 05:06 CDT, Ken P.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ken P. 2012-06-29 00:28:10 CDT
Description of problem: 
Numerous features of that the driver supports fail when checked by the piglit Opengl test suite 

Steps to reproduce:
1. Download latest piglet repository ( I used commit fd3a788baaea34eea0f2d1f0409a510cf545e216 )
http://cgit.freedesktop.org/piglit/
2. compile piglet tests ( see README for details )
3. run sanity tests:
./piglit-run.py tests/sanity.tests catalyst-12.6/sanity
4. Run one of the following tests:
4a. run Quick Driver tests:
./piglit-run.py tests/quick-driver.tests catalyst-12.6/quick-driver
4b. run r600 tests:
./piglit-run.py tests/quick-driver.tests catalyst-12.6/r600
4c. run all tests:
./piglit-run.py tests/all.tests catalyst-12.6/all

Actual result: 
At step 3, the read pixels test has a fails.
At step 4, Multiple tests will fail, and eventually the driver runs out of memory and never complete the tests. 


Expected result: 

The ability to run these tests, and not have the opengl driver hang during the middle of the tests.
Eventually, have the FGLRX driver pass all tests. 


Interesting note:
piglit supports windows, so it would stand to reason that overall test results on linux should mimic the results for windows.
Comment 1 Ken P. 2012-06-29 03:39:36 CDT
Created attachment 510 [details]
system log after crashing fglrx using piglet

The system log is using Catalyst 12.6 (Beta ) driver. I'll add the all of the test results using Catalyst 12.6 release and Catalyst 12.7 beta over the next couple of days to see if the driver still crashes, or the asic hangs. 


System Specification:
Athlon II x4 630
Gigabyte GA-MA790XT-UD4P
XFX Radeon HD5770
4GB DDR3 1600
Linux Mint 13 ( 64-bit )
Comment 2 Ken P. 2012-06-29 03:46:55 CDT
Created attachment 511 [details]
ati system information ( catalyst 12.4 - asus laptop )

Another System with a Radeon HD6520G
Comment 3 Ken P. 2012-06-29 04:05:09 CDT
Created attachment 512 [details]
System log for catalyst 12.4

I forgot to mention that the spec on the Catalyst 12.4 machine, so here it is:


System Information:
ASUS K53TA-BBR6
Sabayon Linux 9 ( 64-bit )
Comment 4 Ken P. 2012-06-29 05:04:01 CDT
Created attachment 513 [details]
atigensystemreport for Catalyst 12.6 release ( Radeon HD 5770 )
Comment 5 Ken P. 2012-06-29 05:06:59 CDT
Created attachment 514 [details]
syslog for Catalyst 12.6 release ( Radeon HD 5770, Post crash )

System log for crash running the exact sequence on the piglet ( after binaries where built):

./piglit-run.py tests/sanity.tests ~/catalyst-12.6/tests/sanity
./piglit-run.py tests/sanity.tests ~/catalyst-12.6/tests/sanity
./piglit-run.py tests/quick-driver.tests ~/catalyst-12.6/tests/quick-driver
Comment 6 Ken P. 2012-06-29 23:37:04 CDT
Finished the tests, and wound up creating a thread on devgurus since I am honestly wondering how other systems would respond to this non-biased test suite where the drivers can be tested.

http://devgurus.amd.com/message/1282297


Ultimately, two major bugs that directly effect the regression test suite where found.

Bug 1) The glsl compiler has multi-thread issues. It's possible to lock up the driver when running multiple based programs at the same time. Currently the best temporary fix is to disable concurrent tests ( add "-c 0" to the launch parameters.

Bug 2) The following set of tests will always crash the driver...

spec/EXT_framebuffer_multisample/turn-on-off

To run the tests with excluding this test, simply run the following command:
./piglit-run.py -c 0 -x spec/EXT_framebuffer_multisample/turn-on-off tests/quick-driver.tests catalyst-12.6/quick-driver

To run the tests using only this test, use the following command:
./piglit-run.py -c 0 -t spec/EXT_framebuffer_multisample/turn-on-off tests/quick-driver.tests catalyst-12.6/EXT_framebuffer_multisample-turn-on-off 

Count	Result
====================
6580	Passed
1864	Failed
53	Crashed
264	Skipped
8764	Total ( 3 missing due to excluded tests)
8767	Total Possible ( via a dry run )
Comment 7 Michael Cronenworth 2013-08-14 11:05:43 CDT
This message is a reminder that your bug is marked as Catalyst 12.6.

The current legacy Catalyst version is 13.1.
The current Catalyst version is 13.4.
The current Catalyst beta version is 13.8.

Approximately 7 days from now the Bugzilla administrator will be removing the 12.6 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla administrator provides this as a unofficial, free service to AMD customers, and I like to keep my systems neat and tidy. If you would like to keep your bug from being closed, please try a new Catalyst version and update the 'version' field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will change it for you.
Comment 8 Michael Cronenworth 2013-08-22 13:57:18 CDT
This bug is being closed due to the 'version' being 12.6 after 7 days of the previous closure notice.

Thank you for your bug report.