Bug 551 - Watermark "Unsupported hardware" on HD6310 (E-350 APU)
: Watermark "Unsupported hardware" on HD6310 (E-350 APU)
Status: CLOSED FIXED
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: X11 Driver
: .archived
: Radeon HD 6000 Series Linux
: low normal
Assigned To: nobody
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-30 04:09 CDT by Kozinov Ivan
Modified: 2013-08-22 13:58 CDT (History)
6 users (show)



Attachments
amd_remove_unsupported_watermark (393 bytes, application/x-shellscript)
2012-07-11 01:17 CDT, Slice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kozinov Ivan 2012-06-30 04:09:34 CDT
Description of problem: 
Watermark "Unsupported hardware" on notebook with E-350 (hd6310)

Steps to reproduce:
0. Install Ubuntu 12.04
1. Go to http://support.amd.com/us/Pages/AMDSupportHub.aspx, select Notebook graphics -> E-series APU -> E-350 APU -> Linux x86 and got link to http://www2.ati.com/drivers/linux/amd-driver-installer-12-6-x86.x86_64.run
2. Install driver via ./amd-driver-installer-12-6-x86.x86_64.run --buildpkg Ubuntu/precise and installing generated fglrx_8.980-0ubuntu1_i386.deb, fglrx-amdcccle_8.980-0ubuntu1_i386.deb and fglrx-dev_8.980-0ubuntu1_i386.deb, reboot
3. Enjoy 3D and xvba.

Actual result: 
Everything works like a charm except of watermark in rigth bottom corner: "Unsupported hardware"

Expected result: 
Same, but without watermark.
Comment 1 Widya Walesa 2012-07-01 09:52:53 CDT
This bug confirmed in my laptop with same spec with Kozinov Ivan, E-350 (Radeon HD 6310). I have "Unsupported hardware" watermark on my screen. I also got this when I try to regenerate my xorg.conf:

# aticonfig --initial
aticonfig: No supported adapters detected

Other than that, the driver is working fine.
Comment 2 Widya Walesa 2012-07-01 09:55:30 CDT
(In reply to comment #1)
> This bug confirmed in my laptop with same spec with Kozinov Ivan, E-350 (Radeon
> HD 6310). I have "Unsupported hardware" watermark on my screen. I also got this
> when I try to regenerate my xorg.conf:
> 
> # aticonfig --initial
> aticonfig: No supported adapters detected
> 
> Other than that, the driver is working fine.

Just additional info of my system:
Slackware Linux Current, kernel 3.2.21-smp
Xorg 1.12.2
Comment 4 Anonym 2012-07-04 00:08:09 CDT
I have "Unsupported hardware" watermark on my screen.
My system: E-350, Xubuntu 11.10

Driver does not work good. I have black frame on display and amdcccle does not save scale configuration.
Comment 5 Slice 2012-07-11 01:17:56 CDT
Created attachment 533 [details]
amd_remove_unsupported_watermark

Here's a little script to remove that nasty watermark. I really wished AMD/ATI would test there drivers before leaving the shop. 

oh well,

Enjoy
Comment 6 pierre.boudier@amd.com 2012-07-11 13:18:37 CDT
afaik, the watermark is the result of your device not being in the list of the specific installer, wether or not the device is actually supported by the driver itself. that is the reason why you can just run the script to remove the watermark.
I am not entirely sure why some of those devices got removed from that list; I have asked the relevant team to try and clean it up and include the missing ASIC.
Comment 7 Randy 2012-07-14 15:52:43 CDT
(In reply to comment #6)
> I am not entirely sure why some of those devices got removed from that list; I
> have asked the relevant team to try and clean it up and include the missing
> ASIC.

Please do! This problem also occurs with the E-450 / HD6320. Not surprising, as they are near identical.

This is my first Linux setup, for use as a media PC, and I've explicitly chosen for AMD for their more powerful GPUs. Getting a "not supported" banner is not a good start.

In the mean time, update the Catalyst driver selector on the website. Currently, when one selects the E-350/450 and Linux, the 12.6 driver is presented.
Comment 8 pdknsk 2012-07-18 21:19:13 CDT
Who at AMD had the idea for the watermark in the first place, I wonder. Even if someone uses an older unsupported card with newer drivers, why should AMD pester the user with it, when the driver works. If it doesn't it'll be uninstalled anyway.
Comment 9 pierre.boudier@amd.com 2012-07-19 02:54:55 CDT
(In reply to comment #8)
> Who at AMD had the idea for the watermark in the first place, I wonder. Even if
> someone uses an older unsupported card with newer drivers, why should AMD
> pester the user with it, when the driver works. If it doesn't it'll be
> uninstalled anyway.


All I can say is that it was not me ;)
More seriously, the rationale was to give clear report to QA when a release is not meant for specific products.
Comment 10 pdknsk 2012-07-19 12:47:02 CDT
Well it didn't quite work as intended. If QA was any good, it would've been concerned by this suspicious watermark on relatively new hardware. The honest answer is probably that AMD has no Linux QA whatsoever, other than automated tests, and relies on the community to do the job. Which is fair enough. Maybe it'll take Valve ruffling some feathers to improve this, on Ubuntu anyway.
Comment 11 pierre.boudier@amd.com 2012-07-19 13:02:53 CDT
I feel that your comments are unfair. the issue with the "new HW" is mostly because the actual ASIC are rebranded by OEM, which are the ones who are supposed to provide the drivers. It happens that most OEM won't care and release anything on linux. I do agree that improvements are needed regardless.

fyi, AMD has been working with valve on their linux port since day one.
Comment 12 pdknsk 2012-07-19 13:17:31 CDT
Sorry, it wasn't meant to be unfair. With "fair enough" I meant to acknowledge that Linux is obviously a low priority for AMD, given the market share. How do I know if I have rebranded or "official" AMD hardware? It's a Lenovo machine.
Comment 13 pierre.boudier@amd.com 2012-07-19 13:24:02 CDT
I contacted the guys maintaining the list, and the "rebranded HW" should be in the next catalyst.

it is official HW in either case, but sometimes the OEM require special SKU (special clocks, special memory configuration), so a special name is created to differentiate from similar SKU but with different configuration. in most cases, the driver team won't even seen those HW unless a bug is filed.

using the script to remove the watermark is a perfectly valid approach; afaik, it should not remove/add any issue other than the watermark.
Comment 14 pdknsk 2012-07-19 13:35:46 CDT
Maybe this could be made an option in CCC, to disable the watermark. This is where I first tried anyway. Hadn't seen a watermark since Voodoo Glide! :) Which was configurable.
Comment 15 anomaly256 2012-07-19 18:42:38 CDT
Sorry but this excuse doesn't *quite* pass mustard.

Normally, this would be entirely plausible with actually-new hardware, but the devices we're talking about are completely recognised and show no watermark in the 12.4 driver.  The SKUs and clocks and config and what-not were clearly known BEFORE 12.6 was released.

Bottom line is someone dropped the ball and forgot to maintain the list correctly within the driver before clicking the 'promote from beta to release' button.

Which, y'know, happens sometimes.  No one's perfect.  We all make mistakes and that is a normal part of life.  But please, be honest about it, ok?  AMD's reputation is eroding pretty fast lately.  You shouldn't make it worse by lying to the community.

Cheers



(In reply to comment #13)
> I contacted the guys maintaining the list, and the "rebranded HW" should be in
> the next catalyst.
> 
> it is official HW in either case, but sometimes the OEM require special SKU
> (special clocks, special memory configuration), so a special name is created to
> differentiate from similar SKU but with different configuration. in most cases,
> the driver team won't even seen those HW unless a bug is filed.
> 
> using the script to remove the watermark is a perfectly valid approach; afaik,
> it should not remove/add any issue other than the watermark.
Comment 16 anomaly256 2012-07-19 18:49:24 CDT
Just to clarify, the previously-known-but-now-not-recognised hardware I'm specifically referring to is an ASUS E35MM1-I-DELUXE motherboard with an e350 apu.  In 12.4, no watermark and everything was recognised just fine.  In 12.6, suddenly not recognised any more.



(In reply to comment #15)
> Sorry but this excuse doesn't *quite* pass mustard.
> 
> Normally, this would be entirely plausible with actually-new hardware, but the
> devices we're talking about are completely recognised and show no watermark in
> the 12.4 driver.  The SKUs and clocks and config and what-not were clearly
> known BEFORE 12.6 was released.
> 
> Bottom line is someone dropped the ball and forgot to maintain the list
> correctly within the driver before clicking the 'promote from beta to release'
> button.
> 
> Which, y'know, happens sometimes.  No one's perfect.  We all make mistakes and
> that is a normal part of life.  But please, be honest about it, ok?  AMD's
> reputation is eroding pretty fast lately.  You shouldn't make it worse by lying
> to the community.
> 
> Cheers
>
Comment 17 anomaly256 2012-07-19 19:22:07 CDT
(In reply to comment #13)
> I contacted the guys maintaining the list, and the "rebranded HW" should be in
> the next catalyst.

This statement brings another thought to mind as well:

I would wager money that the *majority* of your E-series APU customers outside of the ultraportable laptop market consists entirely of users wishing to run, explicitly, XBMC on Linux.  And a decent chunk of the ultraportable laptop market would be linux users as well.

Are you really going to make this *significant* and *crucial* market segment wait an *entire* catalyst release cycle to fix such a trivial-but-show-stopping mistake AMD has made?  If you guys lose this very important market segment to Tegra and ION, *THIS* will be the reason why.
Comment 18 pierre.boudier@amd.com 2012-07-20 01:30:19 CDT
(In reply to comment #15)

> Which, y'know, happens sometimes.  No one's perfect.  We all make mistakes and
> that is a normal part of life.  But please, be honest about it, ok?  AMD's
> reputation is eroding pretty fast lately.  You shouldn't make it worse by lying
> to the community.


I am not sure where you find that AMD has been lying about this issue.

Pierre B.
Comment 19 anomaly256 2012-07-20 01:34:58 CDT
Really?  You don't see how yourself (I assume an AMD rep given your @amd.com email address) claiming the watermark we're seeing on e350 and e450 apu hardware in the 12.6 driver is due to the hw being 'too new' to be in the list of supported hardware within the driver, BUT, somehow magically being recognised by the OLDER 12.4 driver isn't an obvious and bold-faced lie?

<amd driver v12.6> sorry I don't recognise this hardware
<amd driver v12.4> e350 apu radeon, yep no worries
<amd rep> hw is too new for the 12.6 driver to recognise

Unless you're a time traveller destined to take the e350 and e450 apu hardware from the future and deposit it into the past, you're lying about the explanation for this pretty epic mistake.

How else can you explain this clear discrepancy?


(In reply to comment #18)
> (In reply to comment #15)
> 
> > Which, y'know, happens sometimes.  No one's perfect.  We all make mistakes and
> > that is a normal part of life.  But please, be honest about it, ok?  AMD's
> > reputation is eroding pretty fast lately.  You shouldn't make it worse by lying
> > to the community.
> 
> 
> I am not sure where you find that AMD has been lying about this issue.
> 
> Pierre B.
Comment 20 pierre.boudier@amd.com 2012-07-20 01:41:32 CDT
(In reply to comment #19)
> Really?  You don't see how yourself (I assume an AMD rep given your @amd.com
> email address) claiming the watermark we're seeing on e350 and e450 apu
> hardware in the 12.6 driver is due to the hw being 'too new' to be in the list
> of supported hardware within the driver, BUT, somehow magically being
> recognised by the OLDER 12.4 driver isn't an obvious and bold-faced lie?
> 
> <amd driver v12.6> sorry I don't recognise this hardware
> <amd driver v12.4> e350 apu radeon, yep no worries
> <amd rep> hw is too new for the 12.6 driver to recognise
> 
> Unless you're a time traveller destined to take the e350 and e450 apu hardware
> from the future and deposit it into the past, you're lying about the
> explanation for this pretty epic mistake.
> 
> How else can you explain this clear discrepancy?

I am an engineer an AMD, indeed, although not working on linux specifically. I don't think that you will find any of the statements above in any of my answers. I indicated that there was an error with the list managed by the installer (for both rebranded GPU and for APU), and that this was being looked into.

Pierre B.
Comment 21 anomaly256 2012-07-20 01:58:50 CDT
quote: "it is official HW in either case, but sometimes the OEM require special SKU (special clocks, special memory configuration), so a special name is created to differentiate from similar SKU but with different configuration. in most cases, the driver team won't even seen those HW unless a bug is filed."

Sure, maybe this isn't *directly* a lie per se, maybe I did read too much into it and assumed you meant the entire problem instead of a portion of it, but it most certainly does try to skirt around the fact that this problem is on AMD and not the OEMs.  It's with existing known hardware too that has been supported by catalyst for a while now.  This is further compounded by the fact that, apparently, you say we won't be seeing a fix until the end of the next catalyst release cycle!

Asking your users to run some 3rd party script by an untrusted source as root to hexedit out the watermark function in the driver library instead of pushing an emergency driver update is the entire reason your bottom dollar is hurting so bad right now.  Not all your linux users are hackers and geeks.  Many are home users who want a better PVR/HTPC experience than Windows can offer them, and know XBMC is that solution.  For some reason they've been told that the AMD Fusion series is awesome for this purpose (at least your marketing department is functional) and go out to buy an APU system only to discover the drivers don't work as advertised.  Or worse, that their brand new hardware without any oem specific modifications isn't supported at all!

If this mistake happened to the windows catalyst drivers, we would see an update within 24 hours!

Stop treating us like second-class citizens and MAYBE you'll regain some of your slumping market share and recover that $553 million drop in revenue for Q2 ( http://phx.corporate-ir.net/phoenix.zhtml?c=74093&p=irol-newsArticle&ID=1716633 )

> I am an engineer an AMD, indeed, although not working on linux specifically. I
> don't think that you will find any of the statements above in any of my
> answers. I indicated that there was an error with the list managed by the
> installer (for both rebranded GPU and for APU), and that this was being looked
> into.
> 
> Pierre B.
Comment 22 russianneuromancer 2012-07-20 02:12:25 CDT
> Asking your users to run some 3rd party script by an untrusted source as root
to hexedit out the watermark function in the driver library instead of pushing
an emergency driver update is the entire reason your bottom dollar is hurting
so bad right now.

cchtml.com - is not official AMD web-site. Pierre Boudier give not official answer.

If you ask AMD tech. support for official answer, they probably advice you install 12.4 and wait for 12.7 release (or use control file from 12.4 release or 12.6 beta).

On other hand, I partially agree with you: I can't understand how such bug may pass internal QA process. If such bug appear it's a clear indicator for AMD - they need to improve internal QA process of Linux drivers.
Comment 23 anomaly256 2012-07-20 02:20:31 CDT
I understand that.

Just wanted make sure at least 1 person at AMD heard this.  Filling out the linux team feedback form and sending them emails results in silence and nothing happening.

Just wanted to make sure at least 1 person over there knew how ridiculous the linux support situation is.  And maybe, just maybe, they'll have the courage to get more vocal about it internally and make things happen.

I'll pray, but I won't hold my breath.

I'll stop ranting about it in this thread now and let everyone get back to work.


(In reply to comment #22)
> cchtml.com - is not official AMD web-site. Pierre Boudier give not official
> answer.
> 
> If you ask AMD tech. support for official answer, they probably advice you
> install 12.4 and wait for 12.7 release (or use control file from 12.4 release
> or 12.6 beta).
> 
> On other hand, I partially agree with you: I can't understand how such bug may
> pass internal QA process. If such bug appear it's a clear indicator for AMD -
> they need to improve internal QA process of Linux drivers.
Comment 24 Guilmxm 2012-07-24 14:22:20 CDT
Hi,

I installed for testing purposes 12.6 on AMD E350 (HD6310) with same issue as anyone, provided script successfully dropped the unsupported watermarck.

Still i have 2 questions:

1. Is there a workaround to be able to use aticonfig command ? (to initiate xorg config, enable 5.1 and so on)

2. I see in catalyst information panel that catalyst version is still shown as 12.4, i've redone the installation by suppression any fglrx package but still the same.

The only thing i haven't done would to delete /etc/ati and search for other ati installation rests...

For information, i use the ati installator to build ubuntu packages (running on 12.04) and finally use dpkg to install

There is no doubts the 12.6 is the one installed and not 12.4 (confirmed by dpkg packages installed, watermarck existence and screen resolution initialization)

Thanks in advance for your answer!

Guilmxm
Comment 25 russianneuromancer 2012-07-24 22:24:27 CDT
> Is there a workaround to be able to use aticonfig command ?
http://ati.cchtml.com/show_bug.cgi?id=551#c3
> I see in catalyst information panel that catalyst version is still shown as
12.4
http://ati.cchtml.com/show_bug.cgi?id=122
Comment 26 Guilmxm 2012-07-27 05:42:53 CDT
Hi,

Thanks, workaround worked for me.

Last question, i'm wondering if it would not be better to take /etc/ati/control from 12.6 beta than from 12.4 ?

i noticed that while installing 12.6 and restoring /etc/ati/control from 12.4, resolutions changes using amdcccle were not being kept over the current X session (even if mtime of /etc/ati/amdpcsdb was updated)
At the contrary, changing brightness (as for an example) using amdcccle is being kept over the current session...strange

I'll re-test...
Comment 27 Randy 2012-08-16 16:43:16 CDT
Catalyst 12.8 is available. (http://www2.ati.com/drivers/linux/amd-driver-installer-12.8-x86.x86_64.zip) This fixes the issue for me on the E-450.
Comment 28 Michael Cronenworth 2013-08-14 11:06:09 CDT
This message is a reminder that your bug is marked as Catalyst 12.6.

The current legacy Catalyst version is 13.1.
The current Catalyst version is 13.4.
The current Catalyst beta version is 13.8.

Approximately 7 days from now the Bugzilla administrator will be removing the 12.6 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla administrator provides this as a unofficial, free service to AMD customers, and I like to keep my systems neat and tidy. If you would like to keep your bug from being closed, please try a new Catalyst version and update the 'version' field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will change it for you.
Comment 29 Kozinov Ivan 2013-08-14 11:46:58 CDT
I'm not using AMD devices anymore.
Closing bug due to Randy report.