Bug 560 - Drivers for AMD (ATI) Radeon HD 5670 in 32-bit Ubuntu 12.04 LTS (Precise Pangolin).
: Drivers for AMD (ATI) Radeon HD 5670 in 32-bit Ubuntu 12.04 LTS (Precise Pang...
Status: CLOSED INVALID
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: X11 Driver
: .archived
: Radeon HD 5000 Series Linux
: low normal
Assigned To: nobody
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-07 08:08 CDT by przemnet
Modified: 2013-08-22 13:58 CDT (History)
2 users (show)



Attachments
atisysteminfo-report.txt (215.10 KB, text/plain)
2012-07-07 08:08 CDT, przemnet
Details
Information displayed when splash screen is not in use. (361.37 KB, image/jpeg)
2012-07-09 03:12 CDT, przemnet
Details
Information displayed during installation. (369.37 KB, image/jpeg)
2012-07-09 03:13 CDT, przemnet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description przemnet 2012-07-07 08:08:36 CDT
Created attachment 527 [details]
atisysteminfo-report.txt

Description of problem: 
I had 2GB of RAM (DDR2, PC6400, 800MHz), I added another 2GB so now I have 4GB (2x2GB) and I'm not able to use fglrx drivers. After system reboot and Xserver startup, screen becomes violet or black  and I'm not even able to switch to other virtual console with Ctrl+Alt+F1...F6. When I remove 2GB (only 2GB left) system starts normally and everything works fine.

It's not RAM issue, because I've got Windows 7 installed as well and it works fine, 4GB of memory are visible in the system. Besides when I installed Backtrack 5 which is based on Ubuntu 10.04 LTS, catalyst drivers were working correctly with 4GB RAM inserted. I borrowed 1GB of RAM and tested configuration with 3GB and it was working fine! Problem is present only when 4GB are inserted...

Steps to reproduce:
1. Download and Install catalyst dirvers according to WIKI http://wiki.cchtml.com/index.php/Ubuntu_Precise_Installation_Guide#Installing_Catalyst_Manually_.28from_AMD.2FATI.27s_site.29
2. Reboot system

DETAILED description and discussion: http://phoronix.com/forums/showthread.php?71848-Drivers-for-AMD-(ATI)-Radeon-HD-5670-in-Ubuntu-12-04-LTS-(Precise-Pangolin)&p=271419


Actual result: 
Violet or black screen

Expected result: 
Normal Desktop
Comment 1 john.bridgman 2012-07-07 08:36:09 CDT
Can you check for a system BIOS update from your mobo vendor ? That frequently fixes 4GB problems.
Comment 2 przemnet 2012-07-07 10:41:31 CDT
Hello John,

unfortunatelly I have the latest version of BIOS installed...

Looking forward,
Przemek.
Comment 3 Ken P. 2012-07-07 23:30:35 CDT
There's not a lot that can be done... how about trying to boot after disabling the ubuntu splash screen?

http://askubuntu.com/questions/129738/can-i-disable-the-ubuntu-splashscreen


also, if you can boot into the pae kernel using using the console, run the commands

dkms -m fglrx v8.980 -k 3.2.0-26-generic-pae remove
dkms -m fglrx v8.980 -k 3.2.0-26-generic-pae build
dkms -m fglrx v8.980 -k 3.2.0-26-generic-pae install


also, even though you have not ran memtest yet, please give it a try.

and as for the two sticks of ram, have you tried testing one set then the other? or vise versa? also, have you checked the memory timings and complete details between the two memory sticks. It's possible that windows works fine because it's only using one of the sticks of ram to boot.
Comment 4 przemnet 2012-07-09 03:12:38 CDT
Created attachment 529 [details]
Information displayed when splash screen is not in use.
Comment 5 przemnet 2012-07-09 03:13:14 CDT
Created attachment 530 [details]
Information displayed during installation.
Comment 6 przemnet 2012-07-09 03:13:55 CDT
Hello Ken,

when I disabled splash screen, unfortunatelly system did not boot up, there were only some displays as in attachment no_sploash_screen.JPG

Removeing, building and installing fglrx module also did not help... I had to modify a little bit provided commands to loook like this:

dkms -m fglrx/8.980 -k 3.2.0-26-generic-pae remove

Regarding the sticks, I've tested configuration when each single 2GB is insert and everything is working fine. Even when 3GB are inserted it is OK- the problem is only with 4GB of RAM. It is a new set of 2GB sticks which is working in Dual Channel- I removed old 2GB stick. In Windows 7, 4GB of RAM are visible in the system.

I made today a fresh install to capture things that were displayed when I launched Live CD with Ubuntu (they also appear during system shutdown)- please see attachment fresh_install.JPG- maybe this will help to identify the root cause.

Looking forward,
Przemek.
Comment 7 russianneuromancer 2012-07-12 13:15:36 CDT
> unfortunatelly I have the latest version of BIOS installed...
According to your atisysteminfo-report.txt, motherboard model is GA-MA69G-S3H, and BIOS version is F4a. Latest BIOS for this motherboard is F8E:
http://www.gigabyte.com/products/product-page.aspx?pid=2554&dl=1#bios
May you please try update BIOS, as John Bridgman recommends?
Comment 8 przemnet 2012-07-20 03:52:17 CDT
Hello Everyone!

Problem is SOLVED!

As per your recommendation- BIOS upgrade on my motherboard (Gigabyte GA-MA69G-S3H) was the solution! I upgraded to the newest version which is F8E. I was able to install latest Catalyst 12.6 drivers succesfully.

I had problems with upgradeing BIOS from Windows XP and Windows 7, but upgrade directly from BIOS with Q FLASH worked perfectly! To do it, just download BIOS from Gigabyte site, extract the archive, copy BIOS file to USB stick, plug USB stick into computer, reboot system, hit "End" button during startup and select BIOS upgrade from HDD- you can find lots of videos on YouTube about that.

Many thanks for your help and support!

Looking forward,
Przemek.
Comment 9 russianneuromancer 2012-07-20 04:29:19 CDT
Please don't forget to change bugreport status (which probably should be INVALID in this case, as this is not fglrx bug).
Comment 10 przemnet 2012-07-20 04:45:36 CDT
Hi,

status changed to CLOSED INVALID.

Looking forward,
Przemek.
Comment 11 john.bridgman 2012-07-20 07:14:32 CDT
Glad to hear that it's working now.