Bug 570 - Missing HD-audio passthrough in linux
: Missing HD-audio passthrough in linux
Status: CLOSED WONTFIX
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: XvBA Driver
: .archived
: All Linux
: low major
Assigned To: nobody
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-13 14:12 CDT by Haakon Ramsland
Modified: 2014-04-28 09:28 CDT (History)
15 users (show)



Attachments
Ati system info. (377.37 KB, text/plain)
2012-07-13 14:12 CDT, Haakon Ramsland
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Haakon Ramsland 2012-07-13 14:12:11 CDT
Created attachment 543 [details]
Ati system info.

Description of problem: 

Steps to reproduce:
1. Install linux, any flavor, though i prefer Ubuntu 12.04 64 bit. 
2. AMD 12.6
3. XBMC or any other video/audio player.  
4. Have computer connected via HDMI to a HD-Audio capable receiver. 

Actual result: 
No HD-Audio passthrough. 

Expected result: 
HD-Audio pass-through. 
Esp. with Fusion series being pushed as a multimedia smart choice. And most who get a small itx computer with Fusion cpu/gpu would like to get HD-DTS or other HD audio pass through to the receiver.
Comment 1 Andy 2012-08-28 14:08:28 CDT
I am using a E350IA-E45, which has AMD's E350 APU, as media streamer running XBMC in archlinux.

Currently the system can not do HD audio in this configuration.

In windows, or with another graphics card (NVIDIA) it works.


Currently this is a feature that I believe would clearly separate AMD as the better choice from Nvidia ION2 and Apple TV who's hardware (as I understand) does not support this feature.

The AMD hardware is great on paper, but without the drivers the reality is lacking. 

Windows is a solution, and a great solution for a vast multimedia experience. But what I am looking for, and many many others is a home theatre PC that is tailored for its task. This is why Linux must be taken seriously. 

So far the FGLRX drivers combined with a tailored linux setup has proved it self to be faster, snappier than windows in all respects. 

Please look at multichannel support over HDMI. If it's not appropriate for this bug tracker, please let me know where is appropriate.

it's the biggest feature missing from what could be the very best home theatre system.
Comment 2 RogerS 2012-10-29 01:39:22 CDT
It is really a major disappointment that the driver doesn't support bitstreaming of DTS-MA, Dolby Digital HD or multi-channel LPCM. The E-series are perfect to be used for cheap low-power HTPC systems in conbination with OpenElec (streamlined Linux with XBMC). But this shortcoming makes them for audio enthusiasts of high quality surround audio useless. 
I've currently running a passively cooled E450 as HTPC but all people who ask me which system to buy for a HTPC I do not recommend AMD.

How hard can it be to implement this as the windows drivers already support this........
Comment 3 John R. Sugen 2012-11-26 16:04:07 CST
There is still no HD-Audio for neither the A10-5800K nor the HD7770.
This is with 12.11 beta. and Ubuntu 12.10.
Just AC3. This is very disappointing.  And I ended up using a nvidia card in my mediasenter due to this for the sole purpose of getting HD audio. Even though the A10 is more then enough gfx wise. 

Please fix this. 

John.
Comment 4 nsalvador 2013-01-10 10:40:36 CST
For the record, one more unhappy user with an APU AMD E-450.
Comment 5 Jerome 2013-01-11 16:43:40 CST
Why it is so hard to fix this problem?
Germany is also waiting for an update.
With nvidia cards it works fine but why not with ati?
Please do something!!!!!!!
Comment 6 ulu kay 2013-01-24 01:57:32 CST
any updates? is amd even using this bugtracker? it's open since half a year, and we didn't even get a reply? i think i'll just switch to a 20 dollar nvidia card, since it works flawless with a gt610!
Comment 7 griddy 2013-03-17 08:35:06 CDT
One more for the long line of people still waiting for HD audio to be enabled in linux. No-one answering. Getting pretty annoyed now.
Comment 8 John Morey 2013-03-25 12:30:14 CDT
I'll also add my voice to those requesting this feature be implemented. Not having it is only hurting AMD. The world is changed and many more folks are requiring able to bit-stream HD audio. Many are passing on purchasing AMD based equipment because of this limitation. I just passed on two E450 based boxes that would have been perfect for the application except for not being able to bit-stream HD audio.
Comment 9 gabel 2013-04-08 15:34:05 CDT
The only way to solve it is to plug off/in hdmi cable or to SSH into box and enter the following.

$ xrandr --output DFP1 --off
$ xrandr --auto

Taping the 19th pin does not work either. The Windows driver got it fixed so please fix it as well. Any information needed can asked here.
Comment 10 Manfred Pürro 2013-06-10 01:46:18 CDT
One more very, very disapointed User.

i Made an account solely to complain about missing HD Audio Bitstream in the AMD Driver.

We sell Boxes with preinstalled openelec linux mediacenter.

We HAVE to choose Intel/Nvidia as with AMD we cannot deliver the TopNotch Product we want...

Very sad, because your new E450 APU All integrated Boards are apart from that "Bug 570" PERFECT for silent media centers...


If you could FIX that one... a HUGE portion of htpc Builders will start buying AMD Boards, and not Intel/NVidia/ION/NUC Things... Opportunity missed AMD... sad, sad

as you should know... Linux rulez the embeded market...
Comment 11 hoek53 2013-06-27 23:28:45 CDT
Almost at the 1 year mark since the bug was opened.

Congratulations AMD

ION anyone?
Comment 12 Jonas Lie 2013-07-21 02:10:14 CDT
Still not working on ubuntu 13.04 and Catalyst 13.6 beta. 

Hardware:
Amd FX 8350
Asus 990fx Sabertooth 2gen.
Asus 6950 2 gb. 

Reciever Denon x4000


Please fix this. It's vital if you want XBMC fans to continue with AMD gfx. Nvidia atleast have support for bitstreaming.
Comment 13 Stefan Odermeier 2013-07-29 15:54:02 CDT
Hardware: 
Mediasenter AMD APU-6800k.
NAD t275 HD Upgraded reciever.
 
HDMI cable between receiever and motherboard.
No HD AUDIO in Ubuntu 12.10, with the newest 12.6b AMD Driver. 


Even the XBMC guys previously using AMD cards, are going to intel or NVIDIA. Come on give us HD SOUND. 



Stedan.
Comment 14 Michael Cronenworth 2013-08-14 11:05:52 CDT
This message is a reminder that your bug is marked as Catalyst 12.6.

The current legacy Catalyst version is 13.1.
The current Catalyst version is 13.4.
The current Catalyst beta version is 13.8.

Approximately 7 days from now the Bugzilla administrator will be removing the 12.6 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla administrator provides this as a unofficial, free service to AMD customers, and I like to keep my systems neat and tidy. If you would like to keep your bug from being closed, please try a new Catalyst version and update the 'version' field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will change it for you.
Comment 15 Andy 2013-08-14 11:23:53 CDT
(In reply to comment #14)
> This message is a reminder that your bug is marked as Catalyst 12.6.
> 
> The current legacy Catalyst version is 13.1.
> The current Catalyst version is 13.4.
> The current Catalyst beta version is 13.8.
> 
> Approximately 7 days from now the Bugzilla administrator will be removing
> the 12.6 version. At that time your bug will be CLOSED as WONTFIX.
> 
> Bug Reporter: Thank you for reporting this issue. However, the Bugzilla
> administrator provides this as a unofficial, free service to AMD customers,
> and I like to keep my systems neat and tidy. If you would like to keep your
> bug from being closed, please try a new Catalyst version and update the
> 'version' field if the issue still occurs.
> 
> If you are unable to update the version, please make a comment and someone
> will change it for you.

Michael Cronenworth,
Thank you for replying to this old bug but still very current bug.

Please update the version to 13.4 - this is a still a current bug. 

Please could you also up the importance level. This is a significant failing, luckily for AMD/ATi when I paid for this system I thought HDMI multi-channel audio was on its way... I won't be making that mistake again. and neither will many other people. This bug is difference of a sale for anyone considering a home theatre PC, which is most people considering a low-powered small system with comparatively good graphics.

Please could you also assign someone to this bug. 
I used to love AMD/ATi, routing for the underdog and so many times (in the last decade) they'd come up trumps over Intel. but it's stuff like this that makes Intel the choice for the future. Stuff like not assigning someone to a bug!

Best Regards
Comment 16 Stefan Odermeier 2013-08-16 17:28:10 CDT
Still not working on 13.8b1. 

Stefan Odermeier.
Comment 17 I 2013-08-22 15:21:08 CDT
i bought all my hardware for my first htpc ever and just found out the hard way that this doesn't work on linux. how terrible! and even worse that AMD hasn't even bothered to look at this bug report. if only i would have known, i wouldn't have bought this damn thing. 

i've been a loyal AMD fan for many years; the last intel chip i bought was a pentium 3! however, i am not going to continue to support AMD like i have if they can't get stuff like this sorted. like another person mentioned, things like this determine a sale especially when it comes to an htpc. 

so, i've already left reviews on major online stores like amazon so others don't make the same mistake as i did. judging from the latest comments, it wouldn't surprise me if this bug gets closed any day now.
Comment 18 Michael Cronenworth 2014-04-21 14:06:26 CDT
This message is a reminder that your bug is marked as Catalyst 13.8.

The current legacy Catalyst version is 13.1.
The current Catalyst version is 13.12.
The current Catalyst beta version is 14.4.

Approximately 7 days from now the Bugzilla administrator will be removing the 13.8 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla administrator provides this as a unofficial, free service to AMD customers, and I like to keep my systems neat and tidy. If you would like to keep your bug from being closed, please try a new Catalyst version and update the 'version' field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will change it for you.
Comment 19 Michael Cronenworth 2014-04-28 09:27:28 CDT
This bug is being closed due to the 'version' being 13.8 after 7 days of the previous closure notice.

Thank you for your bug report.