Bug 590 - arma2 segfaults on hd7750 (ubuntu 12.04 playonlinux 4.1.6 cat 12.4 12.6 12.8)
: arma2 segfaults on hd7750 (ubuntu 12.04 playonlinux 4.1.6 cat 12.4 12.6 12.8)
Status: CLOSED WONTFIX
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: OpenGL Driver
: .archived
: Radeon HD 7000 Series Linux
: low normal
Assigned To: nobody
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-17 18:40 CDT by if04
Modified: 2013-10-30 15:36 CDT (History)
1 user (show)



Attachments
ATI System configuration report (290.82 KB, text/plain)
2012-08-17 20:51 CDT, if04
Details

Note You need to log in before you can comment on or make changes to this bug.
Description if04 2012-08-17 18:40:57 CDT
Description of problem: 

arma2 segfaults in playonlinux(wine) with hd7750
when 3d is to be rendered

ubuntu 12.04 64bit
playonlinux 4.1.6 game installed in 32bit prefix
crashes with all testet playonlinux-versions of wine
crashes with cat 12.4 12.6 and 12.8

it doasnt segfault with hd3300 onboard
with that card it works but is to slow :) 


wine settings: 
StrictDrawOrdering enabled in registry
xact and dsound and d3dx9 from playonlinux

Unhandled exception: page fault on write access to 0x20000004 in 32-bit code (0xf6534002)
Register dump:
 CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
 EIP:f6534002 ESP:0e32c9fc EBP:f0edcd14 EFLAGS:00210a96(  R- --O I S -A-P- )
 EAX:00000000 EBX:7fffffff ECX:ffffffff EDX:07ffffff
 ESI:f087fb84 EDI:f087ceb8
Stack dump:
0x0e32c9fc:  00000004 00000f22 00000000 00000000
0x0e32ca0c:  f0edcc74 00000001 00000020 00000002
0x0e32ca1c:  0000010c f0edd128 00000f28 f0306910
0x0e32ca2c:  00000001 00000001 f0edcccc 00000001
0x0e32ca3c:  00000007 0000002c f0edcca0 f0edcc70
0x0e32ca4c:  00000008 f0edca80 f0edca7c 00000100
Backtrace:
=>0 0xf6534002 in fglrx_dri.so (+0x1948002) (0xf0edcd14)
  1 0xf6525487 in fglrx_dri.so (+0x1939486) (0x00000001)
  2 0xf6523824 in fglrx_dri.so (+0x1937823) (0xf0306910)
  3 0xf633a3e0 in fglrx_dri.so (+0x174e3df) (0xf11aeb20)
  4 0xf633b308 in fglrx_dri.so (+0x174f307) (0xf0f9edec)
  5 0xf633a9c0 in fglrx_dri.so (+0x174e9bf) (0x0e32cb70)
  6 0xf633f8fc in fglrx_dri.so (+0x17538fb) (0xf11adc20)
  7 0xf66bef92 in fglrx_dri.so (+0x1ad2f91) (0xf11aeb50)
  8 0xf5fa6329 in fglrx_dri.so (+0x13ba328) (0xf11aeb50)
  9 0x00000000 (0xf70270e8)
  10 0xf5fa610e in fglrx_dri.so (+0x13ba10d) (0xf5fa6048)
  11 0x60838b08 (0x245c8b53)
0xf6534002: andl	%ebx,0x8(%eax,%edx,4)
Modules:
Module	Address			Debug info	Name (134 modules)
PE	  230000-  237000	Deferred        x3daudio1_6
PE	  240000-  256000	Deferred        xinput1_3
PE	  400000-  f15000	Deferred        arma2
PE	 a410000- a49c000	Deferred        xaudio2_4
PE	10000000-1041a000	Deferred        d3dx9_41
PE	51080000-510e1000	Deferred        dsound
ELF	7b800000-7b8fd000	Deferred        kernel32<elf>
  \-PE	7b810000-7b8fd000	\               kernel32
ELF	7bc00000-7bcc1000	Deferred        ntdll<elf>
  \-PE	7bc10000-7bcc1000	\               ntdll
ELF	7bf00000-7bf03000	Deferred        <wine-loader>
ELF	7d760000-7d769000	Deferred        librt.so.1
ELF	7d769000-7d76e000	Deferred        libgpg-error.so.0
ELF	7d76e000-7d786000	Deferred        libresolv.so.2
ELF	7d786000-7d78a000	Deferred        libkeyutils.so.1
ELF	7d78a000-7d7d3000	Deferred        libdbus-1.so.3
ELF	7d7d3000-7d7e5000	Deferred        libp11-kit.so.0
ELF	7d7e5000-7d86a000	Deferred        libgcrypt.so.11
ELF	7d86a000-7d87c000	Deferred        libtasn1.so.3
ELF	7d87c000-7d885000	Deferred        libkrb5support.so.0
ELF	7d885000-7d88a000	Deferred        libcom_err.so.2
ELF	7d88a000-7d8b2000	Deferred        libk5crypto.so.3
ELF	7d8b2000-7d981000	Deferred        libkrb5.so.3
ELF	7d981000-7d993000	Deferred        libavahi-client.so.3
ELF	7d993000-7da57000	Deferred        libgnutls.so.26
ELF	7da57000-7da95000	Deferred        libgssapi_krb5.so.2
ELF	7da95000-7dae8000	Deferred        libcups.so.2
ELF	7db12000-7db45000	Deferred        uxtheme<elf>
  \-PE	7db20000-7db45000	\               uxtheme
ELF	7db5b000-7db61000	Deferred        libxfixes.so.3
ELF	7db61000-7db6c000	Deferred        libxcursor.so.1
ELF	7db6e000-7db7c000	Deferred        libavahi-common.so.3
ELF	7dc2e000-7dc58000	Deferred        libexpat.so.1
ELF	7dc58000-7dc8c000	Deferred        libfontconfig.so.1
ELF	7dc8c000-7dc9c000	Deferred        libxi.so.6
ELF	7dc9c000-7dca0000	Deferred        libxcomposite.so.1
ELF	7dca0000-7dca9000	Deferred        libxrandr.so.2
ELF	7dca9000-7dcb3000	Deferred        libxrender.so.1
ELF	7dcb3000-7dcb9000	Deferred        libxxf86vm.so.1
ELF	7dcb9000-7dcbd000	Deferred        libxinerama.so.1
ELF	7dcbd000-7dcde000	Deferred        imm32<elf>
  \-PE	7dcc0000-7dcde000	\               imm32
ELF	7dcde000-7dce5000	Deferred        libxdmcp.so.6
ELF	7dce5000-7dd06000	Deferred        libxcb.so.1
ELF	7dd06000-7de3a000	Deferred        libx11.so.6
ELF	7de3a000-7de4c000	Deferred        libxext.so.6
ELF	7de4c000-7de66000	Deferred        libice.so.6
ELF	7de66000-7deee000	Deferred        winex11<elf>
  \-PE	7de70000-7deee000	\               winex11
ELF	7deee000-7df04000	Deferred        libz.so.1
ELF	7df04000-7df9e000	Deferred        libfreetype.so.6
ELF	7dfed000-7e022000	Deferred        d3d9<elf>
  \-PE	7dff0000-7e022000	\               d3d9
ELF	7e022000-7e05e000	Deferred        winspool<elf>
  \-PE	7e030000-7e05e000	\               winspool
ELF	7e05e000-7e0c5000	Deferred        setupapi<elf>
  \-PE	7e070000-7e0c5000	\               setupapi
ELF	7e0c5000-7e154000	Deferred        msvcrt<elf>
  \-PE	7e0e0000-7e154000	\               msvcrt
ELF	7e154000-7e183000	Deferred        ws2_32<elf>
  \-PE	7e160000-7e183000	\               ws2_32
ELF	7e183000-7e19e000	Deferred        dinput8<elf>
  \-PE	7e190000-7e19e000	\               dinput8
ELF	7e19e000-7e2ac000	Deferred        oleaut32<elf>
  \-PE	7e1c0000-7e2ac000	\               oleaut32
ELF	7e2ac000-7e39f000	Deferred        comctl32<elf>
  \-PE	7e2b0000-7e39f000	\               comctl32
ELF	7e39f000-7e40a000	Deferred        shlwapi<elf>
  \-PE	7e3b0000-7e40a000	\               shlwapi
ELF	7e40a000-7e61b000	Deferred        shell32<elf>
  \-PE	7e420000-7e61b000	\               shell32
ELF	7e61b000-7e643000	Deferred        msacm32<elf>
  \-PE	7e620000-7e643000	\               msacm32
ELF	7e643000-7e6b9000	Deferred        rpcrt4<elf>
  \-PE	7e650000-7e6b9000	\               rpcrt4
ELF	7e6b9000-7e7bf000	Deferred        ole32<elf>
  \-PE	7e6d0000-7e7bf000	\               ole32
ELF	7e7bf000-7e86c000	Deferred        winmm<elf>
  \-PE	7e7d0000-7e86c000	\               winmm
ELF	7e86c000-7e8ce000	Deferred        advapi32<elf>
  \-PE	7e880000-7e8ce000	\               advapi32
ELF	7e8ce000-7e98c000	Deferred        gdi32<elf>
  \-PE	7e8e0000-7e98c000	\               gdi32
ELF	7e98c000-7eaca000	Deferred        user32<elf>
  \-PE	7e9a0000-7eaca000	\               user32
ELF	7eaca000-7ebf3000	Deferred        wined3d<elf>
  \-PE	7eae0000-7ebf3000	\               wined3d
ELF	7ebf3000-7ec57000	Deferred        ddraw<elf>
  \-PE	7ec00000-7ec57000	\               ddraw
ELF	7ef90000-7efaa000	Deferred        libnsl.so.1
ELF	7efaa000-7efd6000	Deferred        libm.so.6
ELF	7efd9000-7efdf000	Deferred        libuuid.so.1
ELF	7efdf000-7efe8000	Deferred        libsm.so.6
ELF	7efe8000-7f000000	Deferred        version<elf>
  \-PE	7eff0000-7f000000	\               version
ELF	f3766000-f377f000	Deferred        libspeexdsp.so.1
ELF	f37a9000-f37b1000	Deferred        libogg.so.0
ELF	f37b1000-f37dc000	Deferred        libvorbis.so.0
ELF	f37dc000-f3954000	Deferred        libvorbisenc.so.2
ELF	f3954000-f39a2000	Deferred        libflac.so.8
ELF	f39a2000-f39a9000	Deferred        libasyncns.so.0
ELF	f39a9000-f3a1b000	Deferred        libsndfile.so.1
ELF	f3a1b000-f3a25000	Deferred        libwrap.so.0
ELF	f3a25000-f3a8a000	Deferred        libpulsecommon-1.1.so
ELF	f3a8a000-f3ad8000	Deferred        libpulse.so.0
ELF	f3ad8000-f3bca000	Deferred        libasound.so.2
ELF	f3bdd000-f3be4000	Deferred        libasound_module_pcm_pulse.so
ELF	f3bf4000-f3c20000	Deferred        winealsa<elf>
  \-PE	f3c00000-f3c20000	\               winealsa
ELF	f3c20000-f3c62000	Deferred        dinput<elf>
  \-PE	f3c30000-f3c62000	\               dinput
ELF	f4b62000-f4bc2000	Deferred        libatiadlxx.so
ELF	f4bc2000-f4bca000	Deferred        libjson.so.0
ELF	f4bca000-f4bec000	Deferred        mmdevapi<elf>
  \-PE	f4bd0000-f4bec000	\               mmdevapi
ELF	f4bec000-f713a000	Dwarf           fglrx_dri.so
ELF	f713a000-f7158000	Deferred        libgcc_s.so.1
ELF	f7158000-f7240000	Deferred        libgl.so.1
ELF	f7240000-f7300000	Deferred        opengl32<elf>
  \-PE	f7260000-f7300000	\               opengl32
PE	f7400000-f7403000	Deferred        libasound_module_rate_speexrate.
ELF	f747d000-f7490000	Deferred        psapi<elf>
  \-PE	f7480000-f7490000	\               psapi
ELF	f7490000-f749d000	Deferred        libnss_files.so.2
ELF	f749e000-f74a3000	Deferred        libdl.so.2
ELF	f74a3000-f7648000	Deferred        libc.so.6
ELF	f7648000-f7663000	Deferred        libpthread.so.0
ELF	f7664000-f7670000	Deferred        libnss_nis.so.2
ELF	f7673000-f767b000	Deferred        libatiuki.so.1
ELF	f7681000-f7685000	Deferred        libxau.so.6
ELF	f7685000-f768e000	Deferred        libnss_compat.so.2
ELF	f768e000-f77cf000	Dwarf           libwine.so.1
ELF	f77d1000-f77f3000	Deferred        ld-linux.so.2
ELF	f77f3000-f77f4000	Deferred        [vdso].so
Threads:
process  tid      prio (all id:s are in hex)
00000008 (D) C:\Program Files\Bohemia Interactive\ArmA 2\arma2.exe
	00000033    2
	00000032   -1
	00000031   -1 <==
	00000030   15
	0000002f   15
	0000002e   15
	0000002d    0
	0000002c    0
	0000002a    0
	00000029   -2
	00000028   -2
	00000027    0
	00000026    0
	00000023    0
	00000022    0
	00000021    1
	00000009    0
0000000e services.exe
	0000001f    0
	0000001e    0
	00000015    0
	00000010    0
	0000000f    0
00000012 winedevice.exe
	0000001c    0
	00000019    0
	00000014    0
	00000013    0
0000001a plugplay.exe
	00000020    0
	0000001d    0
	0000001b    0
00000024 explorer.exe
	00000025    0
System information:
    Wine build: wine-1.5.11
    Platform: i386
    Host system: Linux
    Host version: 3.2.0-29-generic
Comment 1 if04 2012-08-17 18:48:17 CDT
forgot to mention other wine games run well
tried both with arma2 1.11
and beta-patch 86734
Comment 2 if04 2012-08-17 20:51:21 CDT
Created attachment 560 [details]
ATI System configuration report
Comment 3 amigo_zhen 2012-08-23 02:19:49 CDT
I got an error message "Bad serial number given in Setup" when I'm trying to play it with wine on ubuntu 12.04 64bit.

What's your steps to reproduce?

I've installed the game on windows and ran it well.
After that, I putted the whole installed folder into linux and tried to play it with wine.
Comment 4 if04 2012-08-23 16:09:28 CDT
howto:

what i did in ubuntu(i hope it is the same in playonmac):

got playonlinux

startet playonlinux

under tools--organize wine versions or similar:

download a 32bit wine version 1.5.0-raw and/or 1.5.9-raw3 or a other raw3 wine version

further in playonlinux you have a install button

when you click it there are all sorts of software allready supportet but arma2 wasnt.. but theres also a possibility "install a nonlisted program" or similar

install in new virtual drive

then activate all 3 possibilities :

x use different wine version

x configure wine

x install bibs

next use one of your downloaded raw3 wines

after that winecfg starts go to audio->all standards to analog(maybe only needed in linux)-->ok

then libary installer starts:

x d3dx9

x xact

x dsound

after that he askes for the install file ( i took the one from the amra2 disc)

install arma2 in default folder

after install is finished he asks for shortcuts to be made do one for arma2.exe

go back to playonlinux --> configure-->your arma2 link-->display or similar(different language here :)

and enable strict draw ordering

i think i did also playonlinux->configure->configure wine-->libarys-->

dsound to native,builtin

x3daudio1_6 to native buildin

(if those are not there you can insert them yourself on the same page

only needed if you encounter  sound problems:

get a program called pasuspenser and
open the propertys of your desktop arma2 playonlinux link and put a "pasuspender --" before that

pasuspender -- /usr/share/playonlinux/playonlinux --run "arma2"

i hope i didnt forget something

good luck
Comment 5 if04 2012-09-04 09:06:22 CDT
 amigo_zhen 

did the install work for you ?


if not
maybe heres a way to get your copied install working

maybe it works when you copy your arma2-windows registry keys in the wine registry  manually

"wine regedit"

it seems you need the stuff that is in:

WinXP Pro 32bit
HKEY_LOCAL_MACHINE\SOFTWARE\Bohemia Interactive Studio\ArmA 2

Win7 Pro 64bit
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Bohemia Interactive Studio\ArmA 2

hope that helps

btw i also tried to install in a 64bit prefix the same page faults occure
Comment 6 Michael Cronenworth 2013-10-23 13:47:32 CDT
This message is a reminder that your bug is marked as Catalyst 12.8.

The current legacy Catalyst version is 13.1.
The current Catalyst version is 13.4.
The current Catalyst beta version is 13.11.

Approximately 7 days from now the Bugzilla administrator will be removing the 12.8 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla administrator provides this as a unofficial, free service to AMD customers, and I like to keep my systems neat and tidy. If you would like to keep your bug from being closed, please try a new Catalyst version and update the 'version' field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will change it for you.
Comment 7 Michael Cronenworth 2013-10-30 15:34:50 CDT
This bug is being closed due to the 'version' being 12.8 after 7 days of the previous closure notice.

Thank you for your bug report.