Bug 620 - 12.9 Beta fglrx module fails to load with error message "KCL_AGP_FindCapsRegisters"
: 12.9 Beta fglrx module fails to load with error message "KCL_AGP_FindCapsRegi...
Status: CLOSED WONTFIX
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: Kernel Module
: .archived
: Radeon HD 5000 Series Linux
: low normal
Assigned To: nobody
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-05 20:14 CDT by Arrxa
Modified: 2013-10-30 15:36 CDT (History)
1 user (show)



Attachments
Kernel Config (80.18 KB, application/octet-stream)
2012-10-05 20:14 CDT, Arrxa
Details
patch for fglrx driver (799 bytes, patch)
2012-11-04 15:55 CST, Vasiliy Yeremeyev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Arrxa 2012-10-05 20:14:40 CDT
Created attachment 587 [details]
Kernel Config

Description of problem: 

12.9 BETA FGLRX module fails to load. 

I get this error message with kernels 3.4.11 and 3.5.4

fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
Disabling lock debugging due to kernel taint
fglrx: Unknown symbol KCL_AGP_FindCapsRegisters (err 0)

first time ever seeing this error message, it does not even show up in any google/bing/yahoo search results. 

 

Steps to reproduce:
1. Build Catalyst package
2. Install Package
3. try to and failed to load fglrx module

Actual result: 


fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
Disabling lock debugging due to kernel taint
fglrx: Unknown symbol KCL_AGP_FindCapsRegisters (err 0)

Expected result: 

To be able to load the module and have fun :-)
Comment 1 Vasiliy Yeremeyev 2012-11-04 15:55:06 CST
Created attachment 603 [details]
patch for fglrx driver

There is no stub for KCL_AGP_FindCapsRegisters in fglrx driver if it is compiled for AGP-less kernel.
Comment 2 Michael Cronenworth 2013-10-23 13:47:35 CDT
This message is a reminder that your bug is marked as Catalyst 12.8.

The current legacy Catalyst version is 13.1.
The current Catalyst version is 13.4.
The current Catalyst beta version is 13.11.

Approximately 7 days from now the Bugzilla administrator will be removing the 12.8 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla administrator provides this as a unofficial, free service to AMD customers, and I like to keep my systems neat and tidy. If you would like to keep your bug from being closed, please try a new Catalyst version and update the 'version' field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will change it for you.
Comment 3 Michael Cronenworth 2013-10-30 15:34:54 CDT
This bug is being closed due to the 'version' being 12.8 after 7 days of the previous closure notice.

Thank you for your bug report.