Bug 634 - PowerXpress doesn't work with Radeon HD 6550M / Intel Core i5-480M IGP [MUXLESS platform]
Summary: PowerXpress doesn't work with Radeon HD 6550M / Intel Core i5-480M IGP [MUXLE...
Status: CLOSED WONTFIX
Alias: None
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: X11 Driver (show other bugs)
Version: .archived
Hardware: Radeon HD 6000 Series Linux
: low normal
Assignee: nobody
URL:
Depends on:
Blocks:
 
Reported: 2012-10-27 14:51 CDT by sfievet
Modified: 2014-01-13 15:31 CST (History)
0 users



Attachments
Xorg log when unsupported muxless platform is reported (7.57 KB, application/octet-stream)
2012-10-27 14:51 CDT, sfievet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sfievet 2012-10-27 14:51:24 CDT
Created attachment 599 [details]
Xorg log when unsupported muxless platform is reported

Description of problem: 

I am the owner of an ACER Aspire TimelineX 3820 TG featuring a core i5-480M +
Radeon HD6550M.
Configuration (32 bits ONLY installation) :
- kernel 3.4.14
- glibc 2.14.1
- gcc 4.6.1
- Xorg 7.7 with xorg-server 1.12.1 / xf86-video-intel 2.20.10
- Slim 1.3.2
- fglrx 12.10 or 12.11 beta

X works fine with :
- the dGPU only ("discrete" selected in the bios)
- the IGP only ("switchable" selected in the bios and dGPU NOT declared in the ServerLayout section).

X crashes at startup when :
- "switchable graphics" is selected in the bios
- only the dGPU is declared in the ServerLayout :
excerpt of Xorg.0.log
... snip ...
[    20.778] (==) ServerLayout "laptop"
[    20.778] (**) |-->Screen "high performance" (1)
[    20.778] (**) |   |-->Monitor "Acer 3820TG"
[    20.778] (**) |   |-->Device "Radeon HD 6550M"
... snip ...
[    20.780] (--) PCI:*(0:0:2:0) 8086:0046:1025:051b rev 24, Mem @ 0xf0000000/4194304, 0xd0000000/268435456, I/O @ 0x00001800/8
[    20.780] (--) PCI: (0:2:0:0) 1002:68c1:1025:051b rev 0, Mem @ 0xb0000000/268435456, 0xafee0000/131072, I/O @ 0x00002000/256, BIOS @ 0x????????/131072
... snip ...
[    20.865] (--) Chipset Supported AMD Graphics Processor (0x68C1) found
[    20.866] (WW) fglrx: No matching Device section for instance (BusID PCI:0@2:0:1) found
[    20.866] (II) fglrx: intel VGA device detected, load intel driver.
[    20.866] (II) LoadModule: "intel"
[    20.866] (II) Loading /opt/X11/lib/xorg/modules/drivers/intel_drv.so
[    20.866] (II) Module intel: vendor="X.Org Foundation"
[    20.866]    compiled for 1.12.2, module version = 2.20.10
[    20.866]    Module class: X.Org Video Driver
[    20.866]    ABI class: X.Org Video Driver, version 12.0
[    20.866] (WW) PowerXpress feature is not supported on A+I Mux platform. Please uninstall fglrx driver.
[    20.866] (EE) this is a Muxless PX A+I platform, we doesn't supported it
[    20.866] (EE) No devices detected.
[    20.866] 
Fatal server error:
[    20.866] no screens found

I am a bit puzzled by :
"this is a Muxless PX A+I platform, we doesn't supported it"

X crashes at startup when :
- "switchable graphics" is selected in the bios
- both dGPU (Radeon HD 6550M) and iGPU (Core i5 IGP) are declared in the ServerLayout section :

excerpt of Xorg.0.log
... snip ...
[   205.098] (==) ServerLayout "laptop"
[   205.098] (**) |-->Screen "low power" (0)
[   205.098] (**) |   |-->Monitor "Acer 3820TG"
[   205.098] (**) |   |-->Device "Intel HD Graphics"
[   205.098] (**) |-->Screen "high performance" (1)
[   205.099] (**) |   |-->Monitor "Acer 3820TG"
[   205.099] (**) |   |-->Device "Radeon HD 6550M"
... snip ...
[   142.387] (--) PCI:*(0:0:2:0) 8086:0046:1025:051b rev 24, Mem @ 0xf0000000/4194304, 0xd0000000/268435456, I/O @ 0x00001800/8
[   142.387] (--) PCI: (0:2:0:0) 1002:68c1:1025:051b rev 0, Mem @ 0xb0000000/268435456, 0xafee0000/131072, I/O @ 0x00002000/256, BIOS @ 0x????????/131072
... snip ...
[   142.490] (II) fglrx(1): === [xdl_xs112_atiddxPreInit] === begin
[   142.491] 
[   142.491] Backtrace:
[   142.491] 0: /opt/X11/bin/X (xorg_backtrace+0x49) [0x81c3f59]
[   142.491] 1: /opt/X11/bin/X (0x8048000+0x17f83a) [0x81c783a]
[   142.491] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb771540c]
[   142.491] 3: /opt/X11/lib/xorg/modules/drivers/fglrx_drv.so (xdl_xs112_atiddxPxPreInit+0xa9) [0xb6893409]
[   142.491] 4: /opt/X11/lib/xorg/modules/drivers/fglrx_drv.so (xdl_xs112_atiddxPreInit+0x2282) [0xb686cd52]
[   142.491] 5: /opt/X11/bin/X (InitOutput+0x85b) [0x80bcd8b]
[   142.491] 
[   142.491] Segmentation fault at address 0x62
[   142.491] 
Fatal server error:
[   142.491] Caught signal 11 (Segmentation fault). Server aborting

Steps to reproduce:
1. select "switchable graphics" from the bios
2. launch X via Slim

Actual result: 
X refuses to start

Expected result: 
X starts up...
Comment 1 sfievet 2012-10-30 15:54:28 CDT
I also reported this bug to Xorg's bugzilla :
https://bugs.freedesktop.org/show_bug.cgi?id=56494

Chris Wilson closed the bug stating that :
"There is nothing [he] can do about this since fglrx plays tricks with the intel hardware without knowledge of the driver."
Comment 2 Michael Cronenworth 2014-01-06 10:31:40 CST
This message is a reminder that your bug is marked as Catalyst 12.10.

The current legacy Catalyst version is 13.1.
The current Catalyst version is 13.12.
The current Catalyst beta version is 13.11.

Approximately 7 days from now the Bugzilla administrator will be removing the 12.10 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla administrator provides this as a unofficial, free service to AMD customers, and I like to keep my systems neat and tidy. If you would like to keep your bug from being closed, please try a new Catalyst version and update the 'version' field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will change it for you.
Comment 3 Michael Cronenworth 2014-01-13 15:30:27 CST
This bug is being closed due to the 'version' being 12.10 after 7 days of the previous closure notice.

Thank you for your bug report.