Bug 672 - Segmentation fault on X start, X fails to start -- with xorg-x11-server-Xorg-1.10.6-1.el6.centos.x86_64
: Segmentation fault on X start, X fails to start -- with xorg-x11-server-Xorg-...
Status: CLOSED WONTFIX
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: X11 Driver
: .archived
: Radeon HD 7000 Series Linux
: low major
Assigned To: nobody
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-13 20:19 CST by quint.vandeman
Modified: 2014-01-13 15:31 CST (History)
0 users



Attachments
Files described in the description (78.13 KB, application/x-gzip)
2012-12-13 20:19 CST, quint.vandeman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description quint.vandeman 2012-12-13 20:19:39 CST
Created attachment 640 [details]
Files described in the description

Description of problem: X segfaults at address 0x10.

HW: Inspiron 15R Notebook (Inspiron 7520)
Card: AMD Radeon HD 7730M 2GB
OS: CentOS 6.3 x86_64 (2.6.32-279.14.1.el6.x86_64)

Steps to reproduce:
1. Install Catalyst driver 12.10 (also tried 12.11 & 12.8 with same result)
2. Modify xorg.conf appropriately.
3. Start X

Actual result: Seg fault (see attached log)
Expected result: A beautiful desktop.

Attachments:
1. atigetsysteminfo.sh
2. Xorg log file showing seg fault
3. xorg.conf file that was used
4. Full listing of all packages on the machine
Comment 1 quint.vandeman 2012-12-13 20:21:03 CST
Key section of the log for easier viewing (full file contained in attachment):
[   126.195] (--) Chipset Supported AMD Graphics Processor (0x682F) found
[   126.195] (II) fglrx: intel VGA device detected, load intel driver.
[   126.195] (II) LoadModule: "intel"
[   126.196] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[   126.199] (II) Module intel: vendor="X.Org Foundation"
[   126.199] 	compiled for 1.10.4, module version = 2.16.0
[   126.199] 	Module class: X.Org Video Driver
[   126.199] 	ABI class: X.Org Video Driver, version 10.0
[   126.199] (II) AMD Video driver is running on a device belonging to a group targeted for this release
[   126.200] (II) AMD Video driver is signed
[   126.200] (II) Loading /usr/lib64/xorg/modules/drivers/fglrx_drv.so
[   126.200] (II) Loading /usr/lib64/xorg/modules/linux/libfglrxdrm.so
[   126.200] (II) fglrx(0): pEnt->device->identifier=0x127c730
[   126.202] (II) pEnt->device->identifier=(nil)
[   126.202] (II) fglrx(0): === [xdl_xs110_atiddxPreInit] === begin
[   126.202] (II) fglrx(0): PowerXpress: Discrete GPU is selected.
[   126.258] 
Backtrace:
[   126.259] 0: /usr/bin/Xorg (xorg_backtrace+0x28) [0x458908]
[   126.259] 1: /usr/bin/Xorg (0x400000+0x5f629) [0x45f629]
[   126.259] 2: /lib64/libpthread.so.0 (0x3139c00000+0xf500) [0x3139c0f500]
[   126.259] 3: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xdl_xs110_atiddxPxPreInit+0x121) [0x7f8f6f0e18a1]
[   126.259] 4: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xdl_xs110_atiddxPreInit+0x1f4b) [0x7f8f6f0be11b]
[   126.260] 5: /usr/bin/Xorg (InitOutput+0x862) [0x46e582]
[   126.260] 6: /usr/bin/Xorg (0x400000+0x21c8d) [0x421c8d]
[   126.260] 7: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x313981ecdd]
[   126.260] 8: /usr/bin/Xorg (0x400000+0x219d9) [0x4219d9]
[   126.260] Segmentation fault at address 0x10
[   126.260] 
Fatal server error:
[   126.260] Caught signal 11 (Segmentation fault). Server aborting
Comment 2 Michael Cronenworth 2014-01-06 10:31:58 CST
This message is a reminder that your bug is marked as Catalyst 12.10.

The current legacy Catalyst version is 13.1.
The current Catalyst version is 13.12.
The current Catalyst beta version is 13.11.

Approximately 7 days from now the Bugzilla administrator will be removing the 12.10 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla administrator provides this as a unofficial, free service to AMD customers, and I like to keep my systems neat and tidy. If you would like to keep your bug from being closed, please try a new Catalyst version and update the 'version' field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will change it for you.
Comment 3 Michael Cronenworth 2014-01-13 15:30:42 CST
This bug is being closed due to the 'version' being 12.10 after 7 days of the previous closure notice.

Thank you for your bug report.