Bug 807 - AMD Catalyst driver 13.4 does not work properly.
: AMD Catalyst driver 13.4 does not work properly.
Status: CLOSED WONTFIX
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: OpenGL Driver
: .archived
: Radeon HD 7000 Series Linux
: low major
Assigned To: nobody
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-22 14:26 CDT by Álvaro Castillo
Modified: 2014-03-31 12:13 CDT (History)
2 users (show)



Attachments
atigetsysteminfo-report.txt (299.06 KB, text/plain)
2013-05-22 14:26 CDT, Álvaro Castillo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Álvaro Castillo 2013-05-22 14:26:52 CDT
Created attachment 770 [details]
atigetsysteminfo-report.txt

I have installed Fedora 19 Alpha and it's includes X.org server 1.14.1-2.

I cannot launch aticonfig program or run LibreOffice, Firefox...etc because I see this message:

============================
$ glxinfo
name of display: :0.0
[xcb] Extra reply data still left in queue
[xcb] This is most likely caused by a broken X extension library
[xcb] Aborting, sorry about that.
glxinfo: xcb_io.c:575: _XReply: Assertion `!xcb_xlib_extra_reply_data_left' failed.
Aborted
=============================

$ firefox

(process:5113): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed

(process:5113): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
=============================

$ libreoffice 
X Error of failed request:  BadLength (poly request too large or internal Xlib length error)
  Major opcode of failed request:  128 (XINERAMA)
  Minor opcode of failed request:  5 (XINERAMAQueryScreens)
  Serial number of failed request:  10
  Current serial number in output stream:  10

=============================

$ dmesg
[   28.428547] fglrx_pci 0000:00:01.0: irq 50 for MSI/MSI-X
[   28.429784] <6>[fglrx] Firegl kernel thread PID: 961
[   28.429971] <6>[fglrx] Firegl kernel thread PID: 962
[   28.430160] <6>[fglrx] Firegl kernel thread PID: 963
[   28.430271] <6>[fglrx] IRQ 50 Enabled
[   28.433785] <6>[fglrx] Reserved FB block: Shared offset:0, size:1000000 
[   28.433789] <6>[fglrx] Reserved FB block: Unshared offset:fb7c000, size:484000 
[   28.433791] <6>[fglrx] Reserved FB block: Unshared offset:1ffee000, size:12000 
[   28.572420] <6>[fglrx] ATIF platform detected with notification ID: 0x81
[   28.714843] <3>[fglrx:firegl_get_console_mode_info] *ERROR* Get Console Mode failed

===============================

$ lspci
VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Trinity [Radeon HD 7520G]

===============================

$ Xorg -version
X.Org X Server 1.14.1
Release Date: 2013-04-17
X Protocol Version 11, Revision 0
Build Operating System:  2.6.32-358.2.1.el6.x86_64 
Current Operating System: Linux localhost.localdomain 3.9.3-301.fc19.x86_64 #1 SMP Mon May 20 12:50:56 UTC 2013 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-3.9.3-301.fc19.x86_64 root=UUID=450b204f-0803-40f0-86f7-ce22408d82b4 ro rd.md=0 rd.lvm=0 rd.dm=0 vconsole.keymap=es rd.luks=0 vconsole.font=latarcyrheb-sun16 elevator=deadline amd_iommu=yes radeon.modeset=0 LANG=es_ES.UTF-8 rd.driver.blacklist=radeon
Build Date: 14 May 2013  06:38:28AM
Build ID: xorg-x11-server 1.14.1-2.fc19 
Current version of pixman: 0.30.0
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.


However, on F18 works properly but it's another X.org server version.

I've attached an atigetsysteminfo.sh output file too.
Comment 1 Jammy 2013-05-22 23:52:07 CDT
Please note that Catalyst 13.4 doesn't support Xserver 1.14. And Xserver 1.14 support will be available in Catalyst 13.6.
Comment 3 Pavel 2013-06-20 07:55:33 CDT
Unfortunately no one of AMD drivers works properly
Comment 4 Michael Cronenworth 2014-03-18 23:21:37 CDT
This message is a reminder that your bug is marked as Catalyst 13.4.

The current legacy Catalyst version is 13.1.
The current Catalyst version is 13.12.
The current Catalyst beta version is 14.2.

Approximately 7 days from now the Bugzilla administrator will be removing the 13.4 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla administrator provides this as a unofficial, free service to AMD customers, and I like to keep my systems neat and tidy. If you would like to keep your bug from being closed, please try a new Catalyst version and update the 'version' field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will change it for you.
Comment 5 Michael Cronenworth 2014-03-31 12:12:20 CDT
This bug is being closed due to the 'version' being 13.4 after 13 days of the previous closure notice.

Thank you for your bug report.