Bug 831 - segfault at Xorg starting from 13.4
Summary: segfault at Xorg starting from 13.4
Status: CLOSED WONTFIX
Alias: None
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: X11 Driver (show other bugs)
Version: .archived
Hardware: Radeon HD 5000 Series Linux
: low major
Assignee: nobody
URL:
Depends on:
Blocks:
 
Reported: 2013-06-06 17:37 CDT by nikoamia
Modified: 2016-11-09 16:18 CST (History)
20 users (show)



Attachments
Xorg.0.log (25.16 KB, text/plain)
2013-06-06 17:37 CDT, nikoamia
Details
lspci -vv (29.18 KB, text/plain)
2013-06-06 17:38 CDT, nikoamia
Details
Xorg.0.log (21.69 KB, application/octet-stream)
2014-01-19 08:20 CST, linuxguru
Details
xorg.log (20.52 KB, application/octet-stream)
2014-06-01 19:54 CDT, smiler2505
Details
xorg server log with catalyst 14.9; failed to open CMMQS connection; segfault; (18.87 KB, text/x-log)
2014-09-30 03:34 CDT, staffe
Details
AMD AM1 Kabini rig - Xorg failsafe log with segfault on Ubuntu 14.04 with C 14.12 OMEGA (60.38 KB, application/octet-stream)
2014-12-13 17:55 CST, Maciej
Details
dmesg from fglrx 13.35.1005-140223a-168507E (Ubuntu 13.04) (63.91 KB, text/plain)
2015-08-01 08:00 CDT, Lukáš Chmela
Details
last working fglrx (2:9.012-0ubuntu1) info from CCC (118.69 KB, image/png)
2015-08-01 08:02 CDT, Lukáš Chmela
Details
Xorg.log from the last working fglrx 13.35.1005-140223a-168507E (Ubuntu 13.04) (35.51 KB, text/x-log)
2015-08-01 08:13 CDT, Lukáš Chmela
Details
dmesg from the latest fglrx 15.20.1046 (15.7 on AMD website), Ubuntu 13.04 (60.21 KB, text/x-log)
2015-08-01 08:50 CDT, Lukáš Chmela
Details
Xorg.log from the latest fglrx 15.20.1046 (15.7 on AMD website), Ubuntu 15.04 (36.04 KB, text/x-log)
2015-08-03 09:52 CDT, Lukáš Chmela
Details
syslog from the latest fglrx 15.20.1046 (15.7 on AMD website), Ubuntu 15.04 (186.38 KB, application/octet-stream)
2015-08-03 09:55 CDT, Lukáš Chmela
Details
lspci -vv from the latest fglrx 15.20.1046 (15.7 on AMD website), Ubuntu 15.04 (38.64 KB, application/octet-stream)
2015-08-03 09:55 CDT, Lukáš Chmela
Details
syslog from the latest fglrx 15.20.1046 (15.7 on AMD website), Ubuntu 15.04 (180.84 KB, application/octet-stream)
2015-08-04 12:02 CDT, Lukáš Chmela
Details
Xorg.log from the latest fglrx 15.20.1046 (15.7 on AMD website), Ubuntu 15.04 (24.99 KB, text/x-log)
2015-08-04 12:04 CDT, Lukáš Chmela
Details
syslog, latest fglrx 15.20.1046 (15.7 from AMD's website), Ubuntu 15.04 (179.01 KB, application/octet-stream)
2015-08-04 12:48 CDT, Lukáš Chmela
Details
Xorg.log, latest fglrx 15.20.1046 (15.7 from AMD's website), Ubuntu 15.04 (19.11 KB, text/x-log)
2015-08-04 12:49 CDT, Lukáš Chmela
Details
Xorg.conf, Ubuntu 15.04 (383 bytes, application/octet-stream)
2015-08-04 12:51 CDT, Lukáš Chmela
Details
verbose Xorg.log, latest fglrx 15.20.1046 (15.7 from AMD's website), Ubuntu 15.04 (7.69 KB, text/x-log)
2015-08-22 05:57 CDT, Lukáš Chmela
Details
xorg.conf (684 bytes, application/octet-stream)
2015-08-22 06:02 CDT, Lukáš Chmela
Details
xorg.0.log for 15.2 (37.85 KB, text/x-log)
2015-09-02 08:30 CDT, smiler2505
Details
xorg.0.log for 15.2 with Radeon driver removed (20.78 KB, text/x-log)
2015-09-02 15:14 CDT, smiler2505
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nikoamia 2013-06-06 17:37:24 CDT
Created attachment 795 [details]
Xorg.0.log

When using Catalyst 13.4 and higher (checked with 13.6 beta), Xorg segfaults on start (computer hangs up, Xorg can be killed with magic sysrq, but on the second time it's hanged for good). 13.3 beta3 works without problems.
Comment 1 nikoamia 2013-06-06 17:38:10 CDT
Created attachment 796 [details]
lspci -vv
Comment 2 nikoamia 2013-06-06 17:42:55 CDT
Checked on the clean Arch Linux installation with Xorg.conf generated by "aticonfig --initial".
Comment 3 staffe 2013-06-06 18:46:59 CDT
Same here.
I already started a thread at devgurus some time ago.
http://devgurus.amd.com/thread/166671
Hope this bug gets some attention soon...
Comment 4 nikoamia 2013-06-24 02:48:42 CDT
Looks like this is an issue with a Mobility Radeon 5650 chip (there are other people affected with this bug at Arch Linux forums, and they all have this chip).
Comment 5 nikoamia 2013-08-04 12:04:26 CDT
Bug persists with a fresh 13.8 beta1 driver. Xorg.0.log is nearly the same.
Comment 6 nikoamia 2013-08-04 14:15:45 CDT
Now when 13.3 does not compile for kernel 3.10 anymore, this bug is a real stopper for me. I hope that it will be payed some attention.
Comment 7 calhaus 2013-12-26 10:41:38 CST
This bug still happens.

Like Nikoamia said, last time fglrx worked for me was with Catalyst 13.3 beta 3.

I've upgraded to Mint 16 (Ubuntu 13.10) and also tested Ubuntu 13.04 (all x32 and x64 versions) and none of the new drivers worked.

System freezes at boot after grub and before startx. 

Tested different grub options and kernels 13.12, 13.11 and 13.8 and nothing. X.server is 1.14.

@Nikoamia or others, did you find any solution? Or at least were you able to install 13.3 beta 3 in newer systems? (I've tried in 13.3beta3 with kernel 13.8 no freezes, but it hangs on start up because xserver is not supported)
Comment 8 nikoamia 2013-12-27 06:46:20 CST
Hello,
If you have graphics card with same series as 5650 (ones that are supported by r600g open-source driver), my solution would be to ditch fglrx completely and switch to open-source drivers with latest mesa (10 or later) and kernel. Performance and power consumption became really great in latest versions, I use -git builds and play Source-based games without any problems! I would even say that performance is greater than with catalyst in some workloads. The drawback is lack of proper support for OpenCL (still) and maximum OpenGL version 3.3 vs. 4.0+ in fglrx.
Comment 9 nikoamia 2013-12-27 06:50:04 CST
P.S. If you decide to use OSS drivers, don't forget to add these line to your modprobe config (located in /etc/modprobe.conf or /etc/modprobe.d/{create new file here}):
options radeon dpm=1 audio=1
This will enable dynamic power management and HDMI audio support (this line will not be needed in kernel 3.13+). With this you'll achieve same power consumption as with catalyst).
Comment 10 calhaus 2013-12-27 08:33:43 CST
Never tested that opensource drivers because i've always liked fglrx, after it started to work the first time (discrete only),i ve noticed the better performance and specially 13.3 beta3 because it was that beta that solved the last known problems i've had with gnome/cinnamon/steam...

So what i've done yesterday was gave up and install Catalyst 13.3 beta 3 again.
For that i've moved from kernel 3.12 to 3.8 and downgraded Xserver to 1.12.
Dunno if this will be the best solution but everything seems good now.


Notes:
The Xserver version supported by 13.3beta3 is 1.13. I had 1.14 but in synaptics downgrading (from xorg-edgers ppa) to 1.13 would remove me lots of packages, so what i've done was install the ppa with the fglrx-legacy drivers (https://launchpad.net/~makson96/+archive/fglrx ) that automatically installs the 1.12 like if it was the superior version and don't remove other packages.

For the kernel, probably there is a patch to make it work with higher kernel versions like in here: https://github.com/kolasa but i wasn't able to find it, any of you know something about this?


P.S.: On my previous comment i meant kernels 3.XX and not 13.XX obviously.
Comment 11 linuxguru 2014-01-19 08:20:48 CST
Created attachment 923 [details]
Xorg.0.log

Sample Xorg.0.log - Ubuntu 12.04.3, Catalyst 13.12
Comment 12 linuxguru 2014-01-19 08:25:05 CST
I have the same issues, Catalyst 13.3 beta 3 are the only drivers that seem to work. All other Catalyst driver 13.4/13.9/13.12 all seg faults. 

Acer Aspire 8942g with a ATI Mobility HD 5650
Comment 13 Parinya Teerakasemsuk 2014-02-04 12:18:45 CST
I'm having this problem too. Acer Aspire 4745G, Radeon HD 5650.
Comment 14 Tien Vo Xuan 2014-02-19 08:00:17 CST
I'm having this problem too. Acer Aspire 5553G, Radeon HD 5650.
This bug still appear on catalyst 14.1 beta 1.3
Comment 15 Lukáš Chmela 2014-02-20 15:45:59 CST
I am also experiencing this problem - Ubuntu GNOME freezes right after splash screen leaving the screen black. This first started to happen with Catalyst 12.11 I think and isn't fixed even in the 14.1 beta from 2/1/2014.

The only fglrx version that is "functional" (but buggy) is fglrx-updates package from Ubuntu 13.04 repository (the fglrx package from repository freezes the system like any other version).

I have Acer Aspire 8943G with Mobility Radeon HD 5850 (must be something with Acer Aspires as the people experiencing this issue I have seen all had an Aspire).

P.S.: The notebook has i5 processor with integrated Intel GPU (but I have it disabled in BIOS by setting VGA to Discrete till the very beginning of using Ubuntu on it - since switching between the integrated and discrete card never worked and only made the system unbotable with some fglrx versions).
Comment 16 calhaus 2014-05-08 11:32:37 CDT
So many time as passed and nothing,

yesterday i decided to test the latest Proprietary driver (14.4), and still this bug persists. (At least with olders kernels (3.8) and Xservers (1.12)). It's really annoying, specially because AMD says our card is supported. :/

I will probably install the next mint 17 (ubuntu 14.04) because it's lts, and i'm wondering if anyone found a solution for this bug?

If not, do you guys know a solution to install fglrx 13.3 beta3 on newer kernels/xservers?

Or what other solutions/opensource drivers do you recommend?

(I've tested the open Radeon driver that starts automatically when you dont have other drivers, it's good, but it's worst than fglrx when it comes to 3d, and for example it can't run No More Room in hell (source engine) from stream.)

Off topic: I've noticed lots of tearing in videos with fglrx (VLC and flash videos on chrome specially) even with VSync enabled. Any idea to fix this?
Comment 17 Lukáš Chmela 2014-05-08 11:47:15 CDT
Unfortunately, I have tried Catalyst 14.04 (both beta and final release) with Ubuntu 14.04 (fully updated, only about a week ago) and the freeze persists. It is not even possible to run Ubuntu 14.04 with fglrx or fglrx-updates from its repository.
Desperately trying to make the new drivers working I installed Debian stable last week. This was definitely not a good choice since it has kernel version 3.2 and fglrx 12.6. However, fglrx 12.6 with kernel 3.2 didn't work (I tried reinstalling the driver many times, run aticonfig --initial -f, whatever, but every time with weird errors in Xorg.log and no success). I also tried compiling Catalyst 14.4 and even with newer kernel from debian-backports but I wasunable to make it work either. I thought Ubuntu is horribly unstable, but uh... Debian stable was a catastrophe.
Comment 18 Lukáš Chmela 2014-05-08 12:00:39 CDT
And as for the video tearing, yes... this was one of the reasons why I was trying to install newer fglrx drivers hoping that this could have finally got fixed.
Comment 19 smiler2505 2014-06-01 19:54:06 CDT
Created attachment 979 [details]
xorg.log

I've monitored this for a while and tried to find solutions but there is nothing I can find to help resolve it.  Personally I have an Acer 8943G with HD 5850 gfx.  From what I have seen/people posted, what is common to the bug is this (please post if you don't have this setup!):

Acer laptop
AMD Mobility HD 5*** chip


Acer do something 'special' with the graphics chips on their laptops, it was a pain setting up video on a hackintosh on my last two, and I think this is related to the issue we have, which requires AMD to come up with some workaround unfortunately.  Posting my xorg.log too to confirm it is this problem with 'failed to open a CMMQS connection'.
Comment 20 smiler2505 2014-06-01 19:55:00 CDT
Additionally, I can confirm that the problem remains in driver version 14.6 (released May 23rd 2014).
Comment 21 smiler2505 2014-06-01 20:08:56 CDT
I'd encourage people to fill out the response here to make AMD aware of the issue: http://www.amdsurveys.com/se.ashx?s=5A1E27D23CFE9B36
Comment 22 fannisik 2014-06-09 01:50:17 CDT
I have the same issue, with my AMD 8570m on Lenovo G410. I tried 14.10 driver version and still no luck
Comment 23 hugotian 2014-06-12 04:34:34 CDT
we have found a similiar issue internally and have fixed it in 14.7beta driver. You can have a try when the driver is ready.
Comment 24 calhaus 2014-06-12 18:03:46 CDT
Amazing news! Thank you Hugotian, finaly a new hope. :D

Can't wait for 14.7 beta, hope it's released soon. Any release dates? :)
Comment 25 Lukáš Chmela 2014-07-16 09:32:18 CDT
Hello,

I have just tested the new 14.6 beta driver released two days ago (7/14/2014) with Ubuntu GNOME 14.04 and the issue persists - system still freezes with blank screen before GDM is shown.

The version of the Catalyst driver on official AMD webpages has not changed, however, only the release date. I am not sure whether this was the driver you were talking about or we have to wait for another release. There have always been many mistakes in version numbers for Linux on AMD websites in the past.
Comment 26 calhaus 2014-07-17 14:34:29 CDT
It's probably the older beta. I'm checking every day if 14.7 is released after the good news hugotian gave us. But still no luck. Come on amd :p
Comment 27 staffe 2014-09-30 02:39:26 CDT
Sigh...
Bug persists with Mobility Radeon HD 5650 on Arch Linux x86_64 with latest Catalyst 14.9 Drivers.

Sorry AMD, if you're not capable to fix a CRITICAL bug within more than 15 months... why won't you just open source your linux-drivers? I mean it's not like there's a glitch or a performance issue in a game (things you fix all the time). No, for many devices catalyst doesn't work at ALL. For over a year now.
Comment 28 staffe 2014-09-30 03:34:24 CDT
Created attachment 1000 [details]
xorg server log with catalyst 14.9; failed to open CMMQS connection; segfault;
Comment 29 Tien Vo Xuan 2014-10-01 10:54:42 CDT
I tested with linuxmint 17 cinnamon on acer 5553g, this driver does not work. After uninstalling, mouse and touchpad are very unstable (a click need 1 or 2 seconds to response, drag drop does not work, edge scroll does not work)
Comment 30 Lukáš Chmela 2014-10-01 14:42:58 CDT
The last working driver version was Catalyst 13.1 (shipped as fglrx-updates package in Ubuntu 13.04). The immediately older versions do not work (nor does any version newer than 13.1).

Since it looks like the issue concerns only A+I laptops (although my integrated Intel graphics is disables in BIOS), I've found one note in changelog of 13.1 which potentially could have fixed the previous issue: "X crash for AMD PowerXpress™ A+I High-Performance mode on Ubuntu 12.10."

I have no idea about what could introduce the CMMQS error in newer versions - I am only aware of an APL initialization failure (can't tell if I saw it in newer or older version) which was fixed in Catalyst 13.2 (which, however, crashes with the CMMQS error).
Comment 31 szatarynian 2014-10-16 14:43:36 CDT
Also confirm this error. 
Drivers above 13.1 (WHQL) and 13.3beta3 cause screen freeze on boot animation just before showing the login screen. Logs contain an error as shown: 
"Failed to open CMMQS connection." ... 
Problems occur on laptops with hybrid graphics (Mobility HD5000/HD6000, even the card integrated/dedicated is disabled in the BIOS/EFI) as well as in some of the usual Acer laptops. The problem also occurs on each distribution and version of Linux kernel and Xorg does not matter (I checked Ubuntu, Mint, Arch, Fedora, OpenSUSE in various versions from the years 2012/2013/2014). 
Is there any chance that anything done in this matter? 13.1 drivers are working properly but they are outdated and do not work in the new distributions.
I do not know if the problem is memory management or power management, but I know is very VERY annoying...
Comment 32 Daniel 2014-10-30 10:03:16 CDT
I experienced exactly the same error ("fglrx(0): Failed to open CMMQS connection.") on a standalone Gigabyte Radeon HD 7950.

I've been trying to install AMD propiertary driver 14.9 from the AMD web site as well as fglrx and fglrx-updates from the official repositories.
I tested it with (K)Ubuntu 14.04 (Trusty) and 14.10 (Utopic).

The whole PC hangs after the segfault occurs. Not even the virtual consoles (Ctrl+Alt+Fx) are accessible. The only way to get rid of that issue is uninstalling the drivers via dpkg, apt-get or amd-uninstall.sh from within the recovery consoles.

There's no way for me and this relatively new graphics card (mind that it's comparable to the R9 280) to get it running except for using the open source driver from oibaf on launchpad.

Sorry AMD - I'll remember this experience when buying my next graphics card.
Comment 33 smiler2505 2014-12-10 12:38:45 CST
(In reply to comment #23)
> we have found a similiar issue internally and have fixed it in 14.7beta
> driver. You can have a try when the driver is ready.

We're now on version 14.12 (stable...apparently) and the problem still persists, any update Hugo Tian?  This is getting silly.
Comment 34 calhaus 2014-12-13 14:59:36 CST
Bug still persists with the new "Omega (14.12)". (Tested with mint 17.1 x64 kernel 3.16.28)

This is getting really annoying. 
We had a working fglrx, then don't, and the hopes risen by Hugotian just make it worst... :( 


-Does anyone know how to patch drivers?
Maybe we could try to patch Catalyst 13.3 beta 3 to work/install in new kernels/xservers?
Comment 35 Maciej 2014-12-13 17:52:38 CST
I have exacly the same problem... Freeze on Ubuntu logo after installing and reboot. Logs -> segfault...
Installation with files from AMD website.
Initialization, reboot.... and **** starts to happen.

Got:
Asrock AM1H-ITX
Kabini Athlon 5350 with Radeon R3/HD 8400 !!!!

Ubuntu 14.04 all updated
Catalyst 14.12 Omega (1 version earlier was affected too)

It is a nightmare...
Don't know what to do. This problem stops me from all the fun with 'non-server' part of my rig.
Help...
Comment 36 Maciej 2014-12-13 17:55:06 CST
Created attachment 1019 [details]
AMD AM1 Kabini rig - Xorg failsafe log with segfault on Ubuntu 14.04 with C 14.12 OMEGA
Comment 37 Romy Prasetyo Hadi 2015-01-12 20:38:50 CST
Hi, I have Ati mobility radeon HD 5650 and using open source driver, but it gives crash when playing dota 2 since mesa 10.1 untill 10.5 version. Latest mesa version gives frequent unknown crash https://bugs.freedesktop.org/show_bug.cgi?id=87023
I intend to install Catalyst 13.3 beta3, anybody here could provide link for downloading it?
Comment 38 Lukáš Chmela 2015-01-13 04:45:12 CST
(In reply to comment #37)
> Hi, I have Ati mobility radeon HD 5650 and using open source driver, but it
> gives crash when playing dota 2 since mesa 10.1 untill 10.5 version. Latest
> mesa version gives frequent unknown crash
> https://bugs.freedesktop.org/show_bug.cgi?id=87023
> I intend to install Catalyst 13.3 beta3, anybody here could provide link for
> downloading it?

Hi,
this bug report describes a situation where GDM hangs immediately during booting and freezes computer (you wouldn't even see a login prompt). Thus, your problem doesn't seem to be related.

Anyway, you're looking for quite an old Catalyst release - the latest official version is 14.12 from December, 2014 and can be downloaded from amd.com websites. You can find older releases in the archive here: http://support.amd.com/en-us/download/embedded/previous?os=Linux
Comment 39 Lukáš Chmela 2015-01-13 05:26:17 CST
I've just realized that all the Ubuntu systems I tried with newer Catalyst drivers used GDM and the computer doesn't freeze with black screen but when the greeting wallpaper is already shown (only without login prompt).

Could anyone confirm that the X server segfaults also with LightDM?
Comment 40 Kamil 2015-01-13 05:29:23 CST
(In reply to comment #39)
> I've just realized that all the Ubuntu systems I tried with newer Catalyst
> drivers used GDM and the computer doesn't freeze with black screen but when
> the greeting wallpaper is already shown (only without login prompt).
> 
> Could anyone confirm that the X server segfaults also with LightDM?

I don't know whether this is same bug, but i had segfault on boot, no matter what dm is usd
http://ati.cchtml.com/show_bug.cgi?id=1129
Comment 41 Parinya Teerakasemsuk 2015-06-03 23:53:49 CDT
Now, AMD Catalyst™ 15.5 is out. Can anyone confirm, is it works with Radeon HD 5000 Series?
Comment 42 Tien Vo Xuan 2015-06-05 21:37:16 CDT
No, it is not working yet, just blank screen as before. I tested with lubuntu 14.04.1/14.04.2, ati 5650, acer 5553g.
Comment 43 Lukáš Chmela 2015-06-06 04:43:45 CDT
I tried 15.5 on Ubuntu 15.04 and it did not even compile correctly complaining about some undefined references (but kernel module was built and added to the kernel). After restart, Xorg crashed with segmentation fault dropping to shell. I've read somewhere that Catalyst 15.5 do not even support Xorg 1.17 (the version present in Ubuntu 15.04), which might be the reason why only old LTS Ubuntu versions are officially supported.

I guess we're all hopelessly stuck with open source drivers for good, sorry.
Comment 44 Tien Vo Xuan 2015-07-10 20:08:19 CDT
I tried 15.7 on Ubuntu 14.04 but it is not working yet.
Comment 45 Natalia 2015-07-31 12:40:39 CDT
Could anybody show dmesg, corresponding to properly run with fglrx version < 13.4 and the failure with recent fglrx, please?
Comment 46 Lukáš Chmela 2015-08-01 08:00:04 CDT
Created attachment 1058 [details]
dmesg from fglrx 13.35.1005-140223a-168507E (Ubuntu 13.04)

Fglrx version 2:9.012-0ubuntu1 from the Ubuntu 13.04 repository (package fglrx-updates with all related *-updates packages). This version is the last known to work well with AMD Mobility Radeon HD 5850. Tested with Acer Aspire 8943G laptop.
Comment 47 Lukáš Chmela 2015-08-01 08:02:29 CDT
Created attachment 1059 [details]
last working fglrx (2:9.012-0ubuntu1) info from CCC
Comment 48 Lukáš Chmela 2015-08-01 08:13:58 CDT
Created attachment 1060 [details]
Xorg.log from the last working fglrx 13.35.1005-140223a-168507E (Ubuntu 13.04)
Comment 49 Lukáš Chmela 2015-08-01 08:50:20 CDT
Created attachment 1061 [details]
dmesg from the latest fglrx 15.20.1046 (15.7 on AMD website), Ubuntu 13.04
Comment 50 Lukáš Chmela 2015-08-01 08:58:00 CDT
Sorry, I was not able to attach Xorg.log from Ubuntu 13.04 with the latest driver (15.20.1046) since no log file has been created. The computer froze again in the splash screen (GNOME 3 wallpaper shown over full screen) right before login prompt would be shown. Alt+SysRq+REISUB could not be issued as the computer hang completely.

Please let me know if you need additional information or logs (e.g from a newer system). I suppose the Xorg backtraces will be pretty much the same as shown in previous attachments - they always were up to fglrx 15.5. I am not sure, however, if fglrx 13.3 would be runable uder newer systems (or rather under newer Xorg versions).
Comment 51 Pratap 2015-08-03 02:50:35 CDT
Still this observed in latest AMD Catalyst Drivers ? If so please update this thread with complete information

Thanks,
Comment 52 Lukáš Chmela 2015-08-03 08:08:08 CDT
Yes, Xorg still crashes at startup and freezes the computer completely before showing login prompt with AMD Mobility Radeon HD 5850 and fglrx 15.7.

I will try to get Xorg.log, lspci -vv and dmesg outputs from Ubuntu 15.04 and upload them here in the thread.
Comment 53 Lukáš Chmela 2015-08-03 09:52:12 CDT
Created attachment 1063 [details]
Xorg.log from the latest fglrx 15.20.1046 (15.7 on AMD website), Ubuntu 15.04

fglrx 15.7 (latest version downloaded from AMD's website) run on Ubuntu 15.04 with AMD Mobility Radeon HD 5850
Comment 54 Lukáš Chmela 2015-08-03 09:55:10 CDT
Created attachment 1064 [details]
syslog from the latest fglrx 15.20.1046 (15.7 on AMD website), Ubuntu 15.04
Comment 55 Lukáš Chmela 2015-08-03 09:55:36 CDT
Created attachment 1065 [details]
lspci -vv from the latest fglrx 15.20.1046 (15.7 on AMD website), Ubuntu 15.04
Comment 56 Natalia 2015-08-03 12:41:22 CDT
From your last Xorg.0.log it is seen that both radeon and fglrx drivers try to run graphics. Try to blacklist radeon and show your Xorg.0.log and dmesg again, please (Xorg.0.log hasn't contain lines like "[    22.153] (II) RADEON: Driver for ATI Radeon chipsets:
	ATI Radeon Mobility X600 (M24) 3150 (PCIE), ...").
Comment 57 Lukáš Chmela 2015-08-04 12:02:06 CDT
Created attachment 1066 [details]
syslog from the latest fglrx 15.20.1046 (15.7 on AMD website), Ubuntu 15.04

Opensource radeon driver uninstalled (no luck blacklisting it)

The log contains some timeout warnings because of the filesystem being mounted synchronously - needed for system logs to be flushed to HDD before the computer froze.
Comment 58 Lukáš Chmela 2015-08-04 12:04:02 CDT
Created attachment 1067 [details]
Xorg.log from the latest fglrx 15.20.1046 (15.7 on AMD website), Ubuntu 15.04

Opensource radeon driver uninstalled (no luck blacklisting it).
Comment 59 Lukáš Chmela 2015-08-04 12:12:49 CDT
I also had to uninstall the ocl-icd-libopencl1 package (and wine which depends on it) due to a dependency problem. This problem seems to be solved with the fglrx-core_15.200-0ubuntu4_amd64 package from Ubuntu 15.04 repository but I thought it will be better to use the official release from AMD (packages were built using the installer, for ubuntu/vivid). The newer packages from repository were also the cause of the following error shown in the previous Xorg.log (probably only fglrx-core got updated during the `apt-get -f install` procedure when repairing broken dependencies):

[   591.155] (WW) fglrx(0): Kernel Module version does *not* match driver.
[   591.255] (EE) fglrx(0): incompatible kernel module detected - HW accelerated OpenGL will not work
Comment 60 Natalia 2015-08-04 12:20:09 CDT
Xorg.0.log:
"...
[   123.339] (WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
..."

Could you show your /etc/X11/xorg.conf file?
Comment 61 Lukáš Chmela 2015-08-04 12:34:52 CDT
Oh, please...

Yes, I've forgotten to run `aticonfig --initial -f`, as always (it never seemed to actually make any change even when fglrx worked). The outputs will be exactly the same, believe me.

...I will reboot and update the logs again.
Comment 62 Lukáš Chmela 2015-08-04 12:48:59 CDT
Created attachment 1068 [details]
syslog, latest fglrx 15.20.1046 (15.7 from AMD's website), Ubuntu 15.04
Comment 63 Lukáš Chmela 2015-08-04 12:49:40 CDT
Created attachment 1069 [details]
Xorg.log, latest fglrx 15.20.1046 (15.7 from AMD's website), Ubuntu 15.04
Comment 64 Lukáš Chmela 2015-08-04 12:51:12 CDT
Created attachment 1070 [details]
Xorg.conf, Ubuntu 15.04

Generated by the `aticonfig --initial -f` command.
Comment 65 Lukáš Chmela 2015-08-22 05:55:16 CDT
I think I might have finally obtained some useful information regarding this bug. By installing the xserver-xorg-core-dbg package, a more verbose output from fglrx has been revealed in the Xorg.0.log. Why hadn't anyone ever advised to install the package with debugging symbols? Surprisingly, with xserver-xorg-core-dbg installed, Xorg didn't crash with a segmentation fault.

In the verbose Xorg.log file, fglrx complains about a wrongly signed VBIOS.

Please feel free to ask me for any additional information or to instruct me how to obtain other data if there are any needed.

Thank you for your support.
Comment 66 Lukáš Chmela 2015-08-22 05:57:48 CDT
Created attachment 1072 [details]
verbose Xorg.log, latest fglrx 15.20.1046 (15.7 from AMD's website), Ubuntu 15.04
Comment 67 Lukáš Chmela 2015-08-22 06:02:32 CDT
Created attachment 1073 [details]
xorg.conf

xorg.xonf, as generated by `aticonfig --initial -f`.

This was the content of the file even during my last testing, I only uploaded a wrong file by accident.
Comment 68 smiler2505 2015-09-02 08:30:25 CDT
Created attachment 1076 [details]
xorg.0.log for 15.2

Lukas, I don't believe your issue is the same.  All others appear to be suffering from a failure to open a CMMQS connection and getting a segfault.  I too have installed the dbg package but the result is very similar to that which I saw before around a year ago.  Find attached the xorg log using the latest drivers on a clean install updated to Mint Rafaela (based on Trusty).

Is anyone at AMD there?!
Comment 69 Lukáš Chmela 2015-09-02 08:49:20 CDT
Well, the CMMQS error is exactly what I was getting since the times of Ubuntu 13.04 if I remember well. I am also quite convinced it appeared in Xorg.log from Ubuntu 14.04 (Trusty Tahr, which you've mentioned) but it has already been more than a year since I have tried to check this version of Ubuntu. As it is quite old, I have installed Ubuntu 15.04, the latest Ubuntu release with updated packages, and the error has changed into a complaint about the video card's BIOS.

Are you sure this is not what happens with your hardware configuration when running Ubuntu 15.04? If not, then I might be experiencing more problems at once.
Comment 70 Natalia 2015-09-02 10:38:15 CDT
@Lukáš Chmela, attachment 1072 [details]:

[    25.475] ukiDynamicMajor: failed to open /proc/ati/major
[    25.475] ukiDynamicMajor: failed to open /proc/ati/major

Your AMD card cannot be determined for some reason. Try to set BusID as

BusID       "PCI:01:00:0"

in xorg.conf file.


@smiler2505, attachment 1076 [details]:

[   363.879] (II) RADEON: Driver for ATI Radeon chipsets:
	ATI Radeon Mobility X600 (M24) 3150 (PCIE), ATI FireMV 2400 (PCI),
	ATI Radeon Mobility X300 (M24) 3152 (PCIE),
	ATI FireGL M24 GL 3154 (PCIE), ATI FireMV 2400 3155 (PCI),
        ...

Switch off loading of the radeon driver (blacklist it), it hasn't to be loaded if you are using fglrx.
Comment 71 smiler2505 2015-09-02 15:14:51 CDT
Created attachment 1077 [details]
xorg.0.log for 15.2 with Radeon driver removed

(In reply to Natalia from comment #70)

Good catch, try this
Comment 72 smiler2505 2015-09-02 15:44:52 CDT
I've pulled out a full list of CMMQS symbols in fglrx_drv.so:

   307: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND firegl_CMMQSWaitForIdle
  1287: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND firegl_CMMQSSetAperture
  1595: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND firegl_CMMQSFreeAperture
  1669: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND firegl_CMMQSFreeBuffer
  3809: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND firegl_CMMQSMemAlloc1D
  5164: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND firegl_CMMQSFreeBufferWithFence
  8523: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND firegl_CMMQSUnlock
 10355: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND firegl_CMMQSGetPoolSize
 12327: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND firegl_CMMQSAllocCommandBuffer
 15264: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND firegl_CMMQSUnlockSurfaceforSlave
 15331: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND firegl_CMMQSComputeSurfAlignments
 16529: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND firegl_CMMQSLock
 16627: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND firegl_CMMQSFlushCommandBuffer
 21168: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND firegl_CMMQSConnOpen
 22049: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND firegl_CMMQSUnlockMem
 26709: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND firegl_CMMQSAllocMemBuffer
 27533: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND firegl_CMMQSLockSurfaceforSlave
 32778: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND firegl_CMMQSLockMem
 37014: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND firegl_CMMQSConnClose


No mention of it from what I can see in any of the .c or .h source files.

Can't believe this still hasn't been assigned to anyone after two years.
Comment 73 Parinya Teerakasemsuk 2015-12-27 09:01:35 CST
Now 15.9 came out. Is segfault fixed yet in this version?
Comment 74 Natalia 2015-12-28 12:48:10 CST
(In reply to smiler2505 from comment #71)

Excuse me please that I didn't answer...
The same

[   254.464] (EE) fglrx(0): Failed to open CMMQS connection.

I obtain for 2 years at the Intel/AMD notebook... In dmesg output I have 

[fglrx] Try to set gart size 2697M failed, should be within 0M and 0M. Discard the setting.

with subsequent errors connected with memory allocation and CMMQS.
I don't know how to solve this problem...
Comment 76 Michael Cronenworth 2016-10-31 11:04:26 CDT
This message is a reminder that your bug is marked as Catalyst 15.7.

The current Catalyst version is 15.12.

AMD is transitioning to the AMDGPU-PRO driver for Radeon R7 series and newer hardware. The current AMDGPU-PRO driver is 16.40.

Please update to the AMDGPU-PRO driver, if possible, and enter a new bug report under the AMDGPU-PRO component with updated information:
http://ati.cchtml.com/enter_bug.cgi?product=AMDGPU-PRO

If the AMDGPU-PRO driver does not support your hardware the next best option is to use the open source driver available for your hardware.

Approximately 7 days from now the Bugzilla administrator will be removing the 15.7 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla administrator provides this as a unofficial, free service to AMD customers, and I like to keep my systems neat and tidy. If you would like to keep your bug from being closed, please try a new Catalyst version and update the 'version' field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will change it for you.