Bug 848 - Issues with FGLRX when using 2 screens
Summary: Issues with FGLRX when using 2 screens
Status: CLOSED DUPLICATE of bug 707
Alias: None
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: X11 Driver (show other bugs)
Version: .archived
Hardware: Radeon HD 7000 Series Linux
: low normal
Assignee: nobody
URL:
Depends on:
Blocks:
 
Reported: 2013-07-03 20:53 CDT by niniendowarrior
Modified: 2014-04-28 09:28 CDT (History)
2 users (show)



Attachments
Dual Head display corruption - Laptop display (370.61 KB, image/jpeg)
2013-09-05 18:07 CDT, niniendowarrior
Details
Dual Head display corruption - External Monitor display (389.79 KB, image/jpeg)
2013-09-05 18:08 CDT, niniendowarrior
Details

Note You need to log in before you can comment on or make changes to this bug.
Description niniendowarrior 2013-07-03 20:53:32 CDT
I used to use fglrx 13.4 on Ubuntu 12.10 without much issues at all.  When I upgraded to 13.04, I can no longer use 2 screens.  I can use my Big Desktop mode, but the screen display is all off.

Here is the resolution I am using: 2390 x 768
My laptop (HP Pavilion G4-2123TX) screen: 1366x768
My Samsung SyncMaster 591s monitor: 1024x768
Both at 60 Hz.

My xorg.conf file:
Section "ServerLayout"
	Identifier     "aticonfig Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
	Screen         "Screen1" RightOf "aticonfig-Screen[0]-0"
EndSection

Section "Module"
EndSection

Section "ServerFlags"
	Option "Xinerama" "on"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
	Option      "PreferredMode" "1366x768"
	Option      "TargetRefresh" "60"
	Option      "Position" "0 0"
	Option      "Rotate" "normal"
	Option      "Disable" "false"
EndSection

Section "Monitor"
	Identifier   "VGA1"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
	Option      "PreferredMode" "1024x768"
	Option      "TargetRefresh" "60"
	Option      "Positon" "1367 0"
	Option      "Rotate" "normal"
	Option      "Disable" "false"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	BusID       "PCI:1:0:0"
	Option "Monitor-LVDS" "aticonfig-Monitor[0]-0"
	Option "Monitor-CRT1" "VGA1"
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Virtual 2390 768
		Depth     24
	EndSubSection
EndSection

Section "Screen"
	Identifier "Screen1"
	Device     "aticonfig-Device[0]-0"
	Monitor    "VGA1"
	DefaultDepth     24
	SubSection "Display"
		Depth     24
	EndSubSection
EndSection
Comment 1 niniendowarrior 2013-07-03 20:56:20 CDT
The actual big desktop is misaligned. The task bar is drawn on the middle and the 2 desktop are off completely.  When I move the mouse, the desktop is refreshed with the correct alignment for the big desktop, but this only happens for a second, and then the desktop goes back to the broken layout. This makes the screen flicker really terribly.
Comment 2 niniendowarrior 2013-08-01 21:15:46 CDT
I would like to update this ticket in that this dual screen issue seems to have been caused by a workaround:
http://askubuntu.com/questions/205112/how-do-i-get-amd-intel-hybrid-graphics-drivers-to-work?rq=1

AMD fglrx drivers do not load on Intel/AMD hybrid setups on Ubuntu 13.04.  The workaround above will get fglrx to load, but at the cost of 2 screen support.
Comment 3 niniendowarrior 2013-08-02 04:21:43 CDT
I updated to 13.8 Beta and removed the workarounds discussed in the earlier link.  fglrx now loads fine, but the dual head issue remains.
Comment 4 niniendowarrior 2013-09-05 18:07:43 CDT
Created attachment 835 [details]
Dual Head display corruption - Laptop display

It's hard to describe the issue happening, but this is what it looks like on my laptop display.
Comment 5 niniendowarrior 2013-09-05 18:08:36 CDT
Created attachment 836 [details]
Dual Head display corruption - External Monitor display

This is what it looks like from my Samsung monitor display which is my external monitor.
Comment 6 niniendowarrior 2013-09-05 18:09:20 CDT
Updated to the latest beta drivers and the problem is still there.
Comment 7 niniendowarrior 2013-10-14 18:48:25 CDT
Used latest 13.11 beta but still has the same issues with Ubuntu 13.04.
Comment 8 Christoph Haag 2013-11-24 03:52:21 CST
This is a duplicate of #707, by the way.

Still the same problem with the latest beta, of course.
Comment 9 Michael Cronenworth 2014-04-21 14:04:19 CDT

*** This bug has been marked as a duplicate of bug 707 ***