Bug 949 - Catalyst 13.11 Beta6 Unable to Launch GDM if built with Wayland/EGL support
Summary: Catalyst 13.11 Beta6 Unable to Launch GDM if built with Wayland/EGL support
Status: CLOSED WONTFIX
Alias: None
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: X11 Driver (show other bugs)
Version: .archived
Hardware: Radeon HD 7000 Series Linux
: low major
Assignee: nobody
URL:
Depends on:
Blocks:
 
Reported: 2013-11-17 20:46 CST by Tommy He
Modified: 2015-10-07 16:03 CDT (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tommy He 2013-11-17 20:46:16 CST
Description of problem: 

Catalyst 13.11 beta6 fails to work with Fedora 20 Beta Desktop Edition(GNOME).

Steps to reproduce:
1. Install Catalyst 13.11 Beta6 on a Fedora 20 Beta after installing all required dependent tools (kernel-devel, gcc, dkms etc)
2. Go through standard install wizard and make sure the installation log says it's successful.
3. Reboot system as prompted 

Actual result: 
Black screen after Plymouth splash when about to launch GDM.

Other Display Manager with Desktop Environment still work. Only GNOME 3 is affected.

Expected result: 
Properly working as it is in Fedora 19.

Note: a bug is also opened on GNOME Bugzilla: https://bugzilla.gnome.org/show_bug.cgi?id=712340

From the recent comment of bug reporter it turns out the Wayland/EGL support seems to be the cause.

As all new Display Server (Wayland and Mir) are started to rely on EGL, Catalyst driver is expected to properly work around with EGL.
Comment 1 Statyan 2014-12-03 16:44:24 CST
The same problem for 14.9 Catalyst and Fedora 20 with GDM 3.10.1
Comment 2 Florian Sievers 2015-03-30 11:09:27 CDT
The bug also exists in Debian Jessie with GNOME 3.14, cogl 1.18.2-3 and fglrx 14.12 from experimental.
Comment 3 Michael Cronenworth 2015-09-29 12:57:46 CDT
This message is a reminder that your bug is marked as Catalyst 14.9.

The current legacy Catalyst version is 13.1.
The current Catalyst version is 15.9.

Approximately 7 days from now the Bugzilla administrator will be removing the 14.9 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla administrator provides this as a unofficial, free service to AMD customers, and I like to keep my systems neat and tidy. If you would like to keep your bug from being closed, please try a new Catalyst version and update the 'version' field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will change it for you.
Comment 4 Michael Cronenworth 2015-10-07 16:02:12 CDT
This bug is being closed due to the 'version' being 14.9 after 7 days of the previous closure notice.

Thank you for your bug report.