Bug 971 - Natural Selection 2 and FTL don't work on 13.11 beta and 13.12 drivers
Natural Selection 2 and FTL don't work on 13.11 beta and 13.12 drivers
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: OpenGL Driver
Radeon HD 7000 Series Linux
: low major
Assigned To: nobody
Depends on:
  Show dependency treegraph
Reported: 2013-12-19 20:00 CST by Кайдакс
Modified: 2015-01-19 20:40 CST (History)
1 user (show)


Note You need to log in before you can comment on or make changes to this bug.
Description Кайдакс 2013-12-19 20:00:48 CST
Description of problem: Natural Selection 2 loads two cores 100% and doesn't respond to SIGTERM. FTL loads one core and behaves the same. For Natural Selection 2 this is widely known issue that spans across several driver versions.

Steps to reproduce:
1. Install fglrx 13.11 beta 9.4, beta 6, or 13.12.
2. Launch NS2 or FTL.

Actual result: Hang.

Expected result: Gameplay, as on 13.9.
Comment 1 Кайдакс 2013-12-21 21:11:59 CST
I can't reproduce the FTL part anymore. It works for me with all of those driver versions. NS2 however is a well known issue http://forums.unknownworlds.com/discussion/132774/linux-b262-doesn-t-start
Comment 2 Riotta 2014-01-05 10:16:35 CST
I can confirm this issue for Natural Selection 2 on latest Catalyst 13.12
Comment 3 Michael Cronenworth 2015-01-12 09:43:04 CST
This message is a reminder that your bug is marked as Catalyst 13.11.

The current legacy Catalyst version is 13.1.
The current Catalyst version is 14.12.

Approximately 7 days from now the Bugzilla administrator will be removing the 13.11 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla administrator provides this as a unofficial, free service to AMD customers, and I like to keep my systems neat and tidy. If you would like to keep your bug from being closed, please try a new Catalyst version and update the 'version' field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will change it for you.
Comment 4 Michael Cronenworth 2015-01-19 20:39:40 CST
This bug is being closed due to the 'version' being 13.11 after 7 days of the previous closure notice.

Thank you for your bug report.