Bug 990 - Catalyst 13.11 beta V9.95 crashes X server when enabling compositing with KWin
: Catalyst 13.11 beta V9.95 crashes X server when enabling compositing with KWin
Status: CLOSED FIXED
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: X11 Driver
: 13.11
: Radeon HD 7000 Series Linux
: low major
Assigned To: nobody
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-09 19:05 CST by Daniel Scharrer
Modified: 2014-06-14 18:47 CDT (History)
3 users (show)



Attachments
atisysteminfo-report.txt (397.52 KB, text/plain)
2014-01-09 19:05 CST, Daniel Scharrer
Details
Xorg.0.log (54.75 KB, application/x-trash)
2014-01-09 19:06 CST, Daniel Scharrer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Scharrer 2014-01-09 19:05:16 CST
Created attachment 906 [details]
atisysteminfo-report.txt

Compositing works fine with Catalyst 13.12 or 13.11 beta V9.4.

Distro: Gentoo
GPU: Radeon HD 7950

[   111.583] (EE) Backtrace:
[   111.599] (EE) 0: /usr/bin/X (xorg_backtrace+0x36) [0x58a2f6]
[   111.599] (EE) 1: /usr/bin/X (0x400000+0x18e089) [0x58e089]
[   111.599] (EE) 2: /lib64/libpthread.so.0 (0x3ce7800000+0x11050) [0x3ce7811050]
[   111.599] (EE) 3: /usr/lib64/dri/fglrx_dri.so (0x7f1979000000+0x1b8ee1c) [0x7f197ab8ee1c]
[   111.599] (EE) 4: /usr/lib64/dri/fglrx_dri.so (0x7f1979000000+0x1b8f52d) [0x7f197ab8f52d]
[   111.599] (EE) 5: /usr/lib64/dri/fglrx_dri.so (0x7f1979000000+0x1b91f8d) [0x7f197ab91f8d]
[   111.599] (EE) 6: /usr/lib64/dri/fglrx_dri.so (0x7f1979000000+0x1bcb8b7) [0x7f197abcb8b7]
[   111.599] (EE) 7: /usr/lib64/dri/fglrx_dri.so (0x7f1979000000+0x1bc18ea) [0x7f197abc18ea]
[   111.599] (EE) 8: /usr/lib64/dri/fglrx_dri.so (0x7f1979000000+0x12f7077) [0x7f197a2f7077]
[   111.599] (EE) 9: /usr/lib64/dri/fglrx_dri.so (0x7f1979000000+0x12e1673) [0x7f197a2e1673]
[   111.599] (EE) 10: /usr/lib64/dri/fglrx_dri.so (0x7f1979000000+0x12e1787) [0x7f197a2e1787]
[   111.599] (EE) 11: /usr/lib64/dri/fglrx_dri.so (0x7f1979000000+0xfe5eaa) [0x7f1979fe5eaa]
[   111.599] (EE) 12: /usr/lib64/dri/fglrx_dri.so (0x7f1979000000+0x30792b) [0x7f197930792b]
[   111.599] (EE) 13: /usr/lib64/dri/fglrx_dri.so (0x7f1979000000+0x4771b2) [0x7f19794771b2]
[   111.599] (EE) 14: /usr/lib64/dri/fglrx_dri.so (0x7f1979000000+0x4775d8) [0x7f19794775d8]
[   111.599] (EE) 15: /usr/lib64/dri/fglrx_dri.so (0x7f1979000000+0x1006dd4) [0x7f197a006dd4]
[   111.599] (EE) 16: /usr/lib64/dri/fglrx_dri.so (0x7f1979000000+0x1b92618) [0x7f197ab92618]
[   111.599] (EE) 17: /usr/lib64/dri/fglrx_dri.so (0x7f1979000000+0x1b9142c) [0x7f197ab9142c]
[   111.599] (EE) 18: /usr/lib64/xorg/modules/extensions/libglx.so (0x7f197f108000+0x1af17) [0x7f197f122f17]
[   111.599] (EE) 19: /usr/lib64/xorg/modules/extensions/libglx.so (0x7f197f108000+0x1915d) [0x7f197f12115d]
[   111.599] (EE) 20: /usr/lib64/xorg/modules/extensions/libglx.so (0x7f197f108000+0x1eae7) [0x7f197f126ae7]
[   111.599] (EE) 21: /usr/bin/X (0x400000+0x3b176) [0x43b176]
[   111.599] (EE) 22: /usr/bin/X (0x400000+0x2a0ad) [0x42a0ad]
[   111.599] (EE) 23: /lib64/libc.so.6 (__libc_start_main+0xed) [0x3ce6c24b8d]
[   111.599] (EE) 24: /usr/bin/X (0x400000+0x2a421) [0x42a421]
[   111.599] (EE) 
[   111.599] (EE) Segmentation fault at address 0xe0

Steps to reproduce:
1. Start KDE with compositing enabled (or enable it afterwards)
Comment 1 Daniel Scharrer 2014-01-09 19:06:04 CST
Created attachment 907 [details]
Xorg.0.log
Comment 2 Tomasz 2014-01-14 06:15:39 CST
I can confirm this error. In addition, I suggest that it may be related to glamor-egl package in Ubuntu 13.10. The same happens when we have the package version glamor-egl_0.5.1-0ubuntu4.1 and glamor-egl_0.5.1-0ubuntu4.2 - under the drivers 13.12 and 13.11 beta v9.4. For drivers 13.12 and 13.11 beta 9.4 for glamor-egl version 0.5.1-0ubuntu4 all is ok.​
Comment 3 Jammy 2014-01-15 12:55:55 CST
(In reply to comment #2)
> I can confirm this error. In addition, I suggest that it may be related to
> glamor-egl package in Ubuntu 13.10. The same happens when we have the
> package version glamor-egl_0.5.1-0ubuntu4.1 and glamor-egl_0.5.1-0ubuntu4.2
> - under the drivers 13.12 and 13.11 beta v9.4. For drivers 13.12 and 13.11
> beta 9.4 for glamor-egl version 0.5.1-0ubuntu4 all is ok.​

Sound interesting. I don't think the Catalyst driver has any dependency on glamor or glamor-egl
Comment 4 Tomasz 2014-01-29 02:25:55 CST
(In reply to comment #3)
> (In reply to comment #2)
> > I can confirm this error. In addition, I suggest that it may be related to
> > glamor-egl package in Ubuntu 13.10. The same happens when we have the
> > package version glamor-egl_0.5.1-0ubuntu4.1 and glamor-egl_0.5.1-0ubuntu4.2
> > - under the drivers 13.12 and 13.11 beta v9.4. For drivers 13.12 and 13.11
> > beta 9.4 for glamor-egl version 0.5.1-0ubuntu4 all is ok.​
> 
> Sound interesting. I don't think the Catalyst driver has any dependency on
> glamor or glamor-egl

Unfortunately, it happens - I tested on 5 machines with AMD APU [desktops and laptops]
Comment 5 Tomasz 2014-01-29 04:50:10 CST
I just tested the library libglamoregl.so from package xserver-xorg-video-glamoregl_0.6.0-0ubuntu2_amd64.deb for Ubuntu 14.04 ... of course, in "standard mode" this package does not install. I done this to verify, whether the errors appear on all packages above of version xserver-xorg-glamoregl_0.5.1-0ubuntu4_amd64.deb. Here I swapped libglamoregl.so library in /usr/lib/xorg/modules/. When I done refresh the list of libraries [ldconfig ], then logged out and login again. Similarly, as is the case in versions xserver-xorg-glamoregl_0.5.1-0ubuntu4.1_amd64.deb and xserver-xorg-glamoregl_0.5.1-0ubuntu4.2_amd64.deb this occurred a crash of KDE and return to the login screen [lightdm]. Next login was successful = OGL compositing for Kwin was turned off. However, even when then I turn on Chrome [ browser ] - where active is support for video decoding or WebGL, this results in "getting kicked out of the system" to the login screen. Re-establishment of the libglamoregl.so library from package xserver-xorg-glamoregl_0.5.1-0ubuntu4_amd64.deb and everything "back to normal".

Greetings
Comment 6 Daniel Scharrer 2014-06-14 18:13:41 CDT
I don't have this problem anymore with newer driver versions.