Bug 992 - Brightness adjustment stops working after resume
Summary: Brightness adjustment stops working after resume
Status: CLOSED WONTFIX
Alias: None
Product: AMD Catalyst™Proprietary Display Driver
Classification: Unclassified
Component: X11 Driver (show other bugs)
Version: .archived
Hardware: All Linux
: low major
Assignee: nobody
URL:
Depends on:
Blocks:
 
Reported: 2014-01-12 10:17 CST by ico
Modified: 2014-12-20 21:50 CST (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ico 2014-01-12 10:17:04 CST
Description of problem: 

On AMD E-450 APU brightness *does not* work. It only works until suspend. After resuming (assuming you're lucky to be able to resume) it fails to work, at which point the only thing that fixes it is reboot or X restart, both of which defeat the purpose of having suspend in the first place.

This was checked with latest stable (13.12) and beta (released on 1/8/2014, conspicuously labeled as 13.11-betav9.95). Up until 13.11 (first beta) or so brightness did not work at all, then it started working as it does now (until suspend).

The last driver that had brigthness properly working is over a year old (12.1 or something like that). How hard is it to just port that brightness handling logic?

Steps to reproduce:
1. Start computer
2. Suspend
3. Resume

Actual result: Brightness fails to work (even though GUI brightness adjustment shows up)

Expected result: Brightness adjustment should continue to work
Comment 1 samarth.math 2014-02-09 01:32:20 CST
on my 13.251 (stable)
ATI mobility RADEON 5xxx series,

The brightness stops working after suspending. On resume, values in /sys/class/backlight/acpi_video0/actual_brightness and 
/sys/class/backlight/acpi_video0/brightness both change simultaneously and correctly, but real brightness is unaffected.

Steps to recreate.

Start System
Adjust brightness  - it works perfectly
suspend
try to adjust brighness - only gui changes occur, brightness doesn't work
reboot to fix it.
Comment 2 Michael Cronenworth 2014-12-10 19:30:04 CST
This message is a reminder that your bug is marked as Catalyst 13.12.

The current Catalyst version is 14.12.

Approximately 7 days from now the Bugzilla administrator will be removing the 13.12 version. At that time your bug will be CLOSED as WONTFIX.

Bug Reporter: Thank you for reporting this issue. However, the Bugzilla administrator provides this as a unofficial, free service to AMD customers, and I like to keep my systems neat and tidy. If you would like to keep your bug from being closed, please try a new Catalyst version and update the 'version' field if the issue still occurs.

If you are unable to update the version, please make a comment and someone will change it for you.
Comment 3 Michael Cronenworth 2014-12-20 21:49:32 CST
This bug is being closed due to the 'version' being 13.12 after 10 days of the previous closure notice.

Thank you for your bug report.